Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1330454
| From | David Laight <David.Laight@ACULAB.COM> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | RE: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality |
| Date | 2016-02-09 17:50 +0100 |
| Message-ID | <r0jEd-6IG-3@gated-at.bofh.it> (permalink) |
| References | <r0gZK-4N6-41@gated-at.bofh.it> <r0hj3-59v-3@gated-at.bofh.it> <r0jbe-6vm-29@gated-at.bofh.it> <r0jbf-6vm-55@gated-at.bofh.it> <r0jbe-6vm-53@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Karicheri, Muralidharan > Sent: 09 February 2016 16:19 > >... > >> >In reality the 'pad' fields ought to be renamed - since they aren't pads. > >> >Perhaps they should be a union? > > > >> No. At the end of the descriptor, host software can add scratchpad > >> which is not modified by the hardware, but is used by the driver. So > >> please don't rename. > > > >So comment in the definition that the hardware doesn't modify them. > >The driver is defining these fields and they are definitely NOT padding. > > > It is scratch pad, not padding. Looks like pad is a confusing name. Can be > renamed to sw_data to be in sync with spec below. > > The hardware spec from > http://www.ti.com/lit/ug/sprugr9h/sprugr9h.pdf > > The other SW data portion of the descriptor exists after all of the defined > words and is reserved for use by the host software to store completely > private data. This region is not used in any way by the DMA or queue manager > modules in a Multicore Navigator system and these modules will not modify > any bytes within this region. Right, so comment that the hardware doesn't look at the fields. But name/type the structure fields to indicate what they contain. Maybe sw_buf_len etc - but I suspect there are much more meaningful names. David
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] net: ti: netcp: restore get/set_pad_info() functionality Grygorii Strashko <grygorii.strashko@ti.com> - 2016-02-09 15:00 +0100
RE: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality David Laight <David.Laight@ACULAB.COM> - 2016-02-09 15:20 +0100
RE: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality "Karicheri, Muralidharan" <m-karicheri2@ti.com> - 2016-02-09 17:20 +0100
RE: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality "Karicheri, Muralidharan" <m-karicheri2@ti.com> - 2016-02-09 17:20 +0100
RE: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality David Laight <David.Laight@ACULAB.COM> - 2016-02-09 17:50 +0100
RE: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality "Karicheri, Muralidharan" <m-karicheri2@ti.com> - 2016-02-09 18:00 +0100
Re: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality Arnd Bergmann <arnd@arndb.de> - 2016-02-09 20:40 +0100
Re: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality Grygorii Strashko <grygorii.strashko@ti.com> - 2016-02-10 09:40 +0100
Re: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality Murali Karicheri <m-karicheri2@ti.com> - 2016-02-17 17:30 +0100
Re: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality Murali Karicheri <m-karicheri2@ti.com> - 2016-02-18 18:10 +0100
RE: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality David Laight <David.Laight@ACULAB.COM> - 2016-02-09 17:20 +0100
Re: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality David Miller <davem@davemloft.net> - 2016-02-16 21:30 +0100
Re: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality Murali Karicheri <m-karicheri2@ti.com> - 2016-02-18 18:20 +0100
Re: [PATCH] net: ti: netcp: restore get/set_pad_info() functionality David Miller <davem@davemloft.net> - 2016-02-18 21:10 +0100
csiph-web