Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1275710

Re: [PATCH (v4) 2/2] mtd: brcmnand: Add support for the BCM63268

From Florian Fainelli <f.fainelli@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH (v4) 2/2] mtd: brcmnand: Add support for the BCM63268
Date 2015-11-23 19:30 +0100
Message-ID <qy42f-5wu-43@gated-at.bofh.it> (permalink)
References <qxgf7-5LH-5@gated-at.bofh.it> <qxKPU-150-21@gated-at.bofh.it> <qxL9f-1sn-11@gated-at.bofh.it> <qxL9g-1sn-13@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 22/11/15 14:17, Simon Arlott wrote:
> The BCM63268 has a NAND interrupt register with combined status and enable
> registers. It also has a clock for the NAND controller that needs to be
> enabled.
> 
> Set up the device by enabling the clock, disabling and acking all
> interrupts, then handle the CTRL_READY interrupt.
> 
> Add a "device_remove" function to struct brcmnand_soc so that the clock
> can be disabled when the device is removed.
> 
> Signed-off-by: Simon Arlott <simon@fire.lp0.eu>
> ---
> On 22/11/15 21:59, Rob Herring wrote:
>>>>> + * "brcm,nand-bcm63268"
>>>>> + - compatible: should contain "brcm,nand-bcm<soc>", "brcm,nand-bcm63268"
>>>
>>> vendor,<soc>-device is preferred.
> 
> The existing two bindings use brcm,nand-<soc>, but I've changed this one.

Could we stick with the existing binding naming convention of using:

brcm,nand-<soc> just so automated tools or other things can match this
one too, and +1 for consistency?

Other than, that, same comment as Jonas, why do we we need the
device_remove callback to be called from the main driver down to this one?
-- 
Florian
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/2] mtd: brcmnand: Add brcm,nand-bcm63268 device tree binding Simon Arlott <simon@fire.lp0.eu> - 2015-11-21 14:20 +0100
  Re: [PATCH 1/2] mtd: brcmnand: Add brcm,nand-bcm63268 device tree  binding Rob Herring <robh@kernel.org> - 2015-11-22 23:00 +0100
    [PATCH (v4) 1/2] mtd: brcmnand: Add brcm,bcm63268-nand device tree  binding Simon Arlott <simon@fire.lp0.eu> - 2015-11-22 23:20 +0100
      [PATCH (v4) 2/2] mtd: brcmnand: Add support for the BCM63268 Simon Arlott <simon@fire.lp0.eu> - 2015-11-22 23:20 +0100
        Re: [PATCH (v4) 2/2] mtd: brcmnand: Add support for the BCM63268 Jonas Gorski <jogo@openwrt.org> - 2015-11-23 16:50 +0100
          Re: [PATCH (v4) 2/2] mtd: brcmnand: Add support for the BCM63268 Simon Arlott <simon@fire.lp0.eu> - 2015-11-23 19:40 +0100
        Re: [PATCH (v4) 2/2] mtd: brcmnand: Add support for the BCM63268 Florian Fainelli <f.fainelli@gmail.com> - 2015-11-23 19:30 +0100
          Re: [PATCH (v4) 2/2] mtd: brcmnand: Add support for the BCM63268 Simon Arlott <simon@fire.lp0.eu> - 2015-11-24 09:20 +0100
            [PATCH (v5) 2/2] mtd: brcmnand: Add support for the BCM63268 Simon Arlott <simon@fire.lp0.eu> - 2015-11-24 19:20 +0100
            Re: [PATCH (v4) 2/2] mtd: brcmnand: Add support for the BCM63268 Florian Fainelli <f.fainelli@gmail.com> - 2015-11-24 19:50 +0100
              [PATCH (v6) 1/2] mtd: brcmnand: Add brcm,bcm63268-nand device tree  binding "Simon Arlott" <simon@fire.lp0.eu> - 2015-11-24 21:20 +0100
                [PATCH (v6) 2/2] mtd: brcmnand: Add support for the BCM63268 "Simon Arlott" <simon@fire.lp0.eu> - 2015-11-24 21:30 +0100
                Re: [PATCH (v6) 2/2] mtd: brcmnand: Add support for the BCM63268 Jonas Gorski <jogo@openwrt.org> - 2015-11-25 11:50 +0100
                Re: [PATCH (v6) 2/2] mtd: brcmnand: Add support for the BCM63268 "Simon Arlott" <simon@fire.lp0.eu> - 2015-11-25 13:40 +0100
                Re: [PATCH (v6) 2/2] mtd: brcmnand: Add support for the BCM63268 Jonas Gorski <jogo@openwrt.org> - 2015-11-25 14:00 +0100
                [PATCH (v7) 2/2] mtd: brcmnand: Add support for the BCM63268 Simon Arlott <simon@fire.lp0.eu> - 2015-11-25 20:50 +0100
                Re: [PATCH (v6) 1/2] mtd: brcmnand: Add brcm,bcm63268-nand device  tree binding Rob Herring <robh@kernel.org> - 2015-11-25 21:10 +0100
      Re: [PATCH (v4) 1/2] mtd: brcmnand: Add brcm,bcm63268-nand device  tree binding Rob Herring <robh@kernel.org> - 2015-11-22 23:30 +0100

csiph-web