Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1273120

[PATCH 4/5] fs/bad_inode.c: is_bad_inode can be boolean

From Yaowei Bai <baiyaowei@cmss.chinamobile.com>
Newsgroups linux.kernel
Subject [PATCH 4/5] fs/bad_inode.c: is_bad_inode can be boolean
Date 2015-11-19 14:10 +0100
Message-ID <qwx8n-1jR-39@gated-at.bofh.it> (permalink)
References <qvIfv-1qi-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


This patch makes is_bad_inode return bool to improve
readability due to this particular function only using either
one or zero as its return value.

No functional change.

Signed-off-by: Yaowei Bai <baiyaowei@cmss.chinamobile.com>
---
 fs/bad_inode.c     | 2 +-
 include/linux/fs.h | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/fs/bad_inode.c b/fs/bad_inode.c
index 861b1e1..103f5d7 100644
--- a/fs/bad_inode.c
+++ b/fs/bad_inode.c
@@ -192,7 +192,7 @@ EXPORT_SYMBOL(make_bad_inode);
  *	Returns true if the inode in question has been marked as bad.
  */
  
-int is_bad_inode(struct inode *inode)
+bool is_bad_inode(struct inode *inode)
 {
 	return (inode->i_op == &bad_inode_ops);	
 }
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 4b23def..6b33ac4 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -2371,7 +2371,7 @@ extern void init_special_inode(struct inode *, umode_t, dev_t);
 
 /* Invalid inode operations -- fs/bad_inode.c */
 extern void make_bad_inode(struct inode *);
-extern int is_bad_inode(struct inode *);
+extern bool is_bad_inode(struct inode *);
 
 #ifdef CONFIG_BLOCK
 /*
-- 
1.9.1



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[PATCH 1/5] fs/block_dev.c: make sb_is_blkdev_sb return bool when CONFIG_BLOCK undefined Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-17 07:50 +0100
  Re: [PATCH 1/5] fs/block_dev.c: make sb_is_blkdev_sb return bool when CONFIG_BLOCK undefined Jeff Moyer <jmoyer@redhat.com> - 2015-11-17 15:30 +0100
  [PATCH 5/5] fs/attr.c: is_sxid can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-19 14:10 +0100
  [PATCH 4/5] fs/bad_inode.c: is_bad_inode can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-19 14:10 +0100

csiph-web