Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1264843
| From | Dmitry Krivenok <krivenok.dmitry@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 3/4] nvdimm: Add IOCTL pass thru |
| Date | 2015-11-07 15:10 +0100 |
| Message-ID | <qsclQ-3jn-7@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
> + if (IS_ENABLED(CONFIG_ACPI_NFIT_DEBUG)) {
> + dev_dbg(dev, "%s:%s cmd: %d input length: %d\n", __func__,
> + dimm_name, cmd, in_buf.buffer.length);
> + print_hex_dump_debug("cmd: ", DUMP_PREFIX_OFFSET, 4,
> + 4, in_buf.buffer.pointer, min_t(u32, 128,
> + in_buf.buffer.length), true);
> + }
Maybe move this code to a helper function? There are 4 almost
identical blocks now in acpi_nfit_ctl_passthru and
acpi_nfit_ctl_intel.
> + for (i = 0; i < ARRAY_SIZE(pkg.h.res); i++)
> + if (pkg.h.res[i])
> + return -EINVAL;
I'd rename "res" to "reserved" for clarity.
> + /* This may be bigger that the fixed portion of the pakcage */
s/that/than/
s/pakcage/package/
> + switch (type) {
> + case NVDIMM_TYPE_INTEL:
> + rc = __nd_ioctl(nvdimm_bus, nvdimm, ro, cmd, arg);
> + break;
> + case NVDIMM_TYPE_PASSTHRU:
> + rc = __nd_ioctl_passthru(nvdimm_bus, nvdimm, ro, cmd, arg);
> + break;
> + default:
> + rc = -ENOTTY;
> + }
The same comment. Identical code in nd_ioctl and nvdimm_ioctl.
Perhaps move to a helper function?
Thanks,
Dmitry
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH 3/4] nvdimm: Add IOCTL pass thru Dmitry Krivenok <krivenok.dmitry@gmail.com> - 2015-11-07 15:10 +0100
Re: [PATCH 3/4] nvdimm: Add IOCTL pass thru Jerry Hoemann <jerry.hoemann@hpe.com> - 2015-11-09 23:00 +0100
Re: [PATCH 3/4] nvdimm: Add IOCTL pass thru Dmitry Krivenok <krivenok.dmitry@gmail.com> - 2015-11-10 16:10 +0100
Re: [PATCH 3/4] nvdimm: Add IOCTL pass thru Jerry Hoemann <jerry.hoemann@hpe.com> - 2015-11-11 22:50 +0100
Re: [PATCH 3/4] nvdimm: Add IOCTL pass thru Dmitry Krivenok <krivenok.dmitry@gmail.com> - 2015-11-11 23:00 +0100
Re: [PATCH 3/4] nvdimm: Add IOCTL pass thru Jerry Hoemann <jerry.hoemann@hpe.com> - 2015-11-12 16:40 +0100
csiph-web