Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1260243
| From | David Miller <davem@davemloft.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] NET: ATM: MPOA: Remove 32-bit timekeeping |
| Date | 2015-11-01 22:40 +0100 |
| Message-ID | <qq8w2-57h-9@gated-at.bofh.it> (permalink) |
| References | <qpa6S-1AJ-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Tina Ruchandani <ruchandani.tina@gmail.com>
Date: Thu, 29 Oct 2015 22:01:07 -0700
> @@ -14,9 +15,9 @@ void atm_mpoa_init_cache(struct mpoa_client *mpc);
> typedef struct in_cache_entry {
> struct in_cache_entry *next;
> struct in_cache_entry *prev;
> - struct timeval tv;
> - struct timeval reply_wait;
> - struct timeval hold_down;
> + time64_t tv;
> + time64_t reply_wait;
> + time64_t hold_down;
> uint32_t packets_fwded;
> uint16_t entry_state;
> uint32_t retry_time;
> @@ -51,7 +52,7 @@ struct in_cache_ops{
> typedef struct eg_cache_entry{
> struct eg_cache_entry *next;
> struct eg_cache_entry *prev;
> - struct timeval tv;
> + time64_t tv;
Again, these structure member names like "tv" only make sense if
they store a "timeval". Please rename these structure members
appropriately, thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] NET: ATM: MPOA: Remove 32-bit timekeeping Tina Ruchandani <ruchandani.tina@gmail.com> - 2015-10-30 06:10 +0100 Re: [PATCH] NET: ATM: MPOA: Remove 32-bit timekeeping David Miller <davem@davemloft.net> - 2015-11-01 22:40 +0100
csiph-web