Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1241297

Re: [PATCH 03/15] arm64: Introduce helpers for page table levels

From "Suzuki K. Poulose" <Suzuki.Poulose@arm.com>
Newsgroups linux.kernel
Subject Re: [PATCH 03/15] arm64: Introduce helpers for page table levels
Date 2015-10-07 11:50 +0200
Message-ID <qgTwe-10x-9@gated-at.bofh.it> (permalink)
References <q90Ex-Jd-5@gated-at.bofh.it> <q90Ey-Jd-23@gated-at.bofh.it> <qgSgO-7JK-7@gated-at.bofh.it> <qgTcS-DX-21@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 07/10/15 10:26, Marc Zyngier wrote:
> On 07/10/15 09:26, Christoffer Dall wrote:
>> Hi Suzuki,
>>
>> On Tue, Sep 15, 2015 at 04:41:12PM +0100, Suzuki K. Poulose wrote:
>>> From: "Suzuki K. Poulose" <suzuki.poulose@arm.com>
>>>
>>> Introduce helpers for finding the number of page table
>>> levels required for a given VA width, shift for a particular
>>> page table level.
>>>
>>> Convert the existing users to the new helpers. More users
>>> to follow.
>>>
>>> Cc: Ard Biesheuvel <ard.biesheuvel@linaro.org>
>>> Cc: Mark Rutland <mark.rutland@arm.com>
>>> Cc: Catalin Marinas <catalin.marinas@arm.com>
>>> Cc: Will Deacon <will.deacon@arm.com>
>>> Signed-off-by: Suzuki K. Poulose <suzuki.poulose@arm.com>
>>> Reviewed-by: Ard Biesheuvel <ard.biesheuvel@linaro.org>
>>> Tested-by: Ard Biesheuvel <ard.biesheuvel@linaro.org>
>>> ---
>>>   arch/arm64/include/asm/pgtable-hwdef.h |   15 ++++++++++++---
>>>   1 file changed, 12 insertions(+), 3 deletions(-)
>>>
>>> diff --git a/arch/arm64/include/asm/pgtable-hwdef.h b/arch/arm64/include/asm/pgtable-hwdef.h
>>> index 24154b0..ce18389 100644
>>> --- a/arch/arm64/include/asm/pgtable-hwdef.h
>>> +++ b/arch/arm64/include/asm/pgtable-hwdef.h
>>> @@ -16,13 +16,21 @@
>>>   #ifndef __ASM_PGTABLE_HWDEF_H
>>>   #define __ASM_PGTABLE_HWDEF_H
>>>
>>> +/*
>>> + * Number of page-table levels required to address 'va_bits' wide
>>> + * address, without section mapping
>>> + */
>>> +#define ARM64_HW_PGTABLE_LEVELS(va_bits) (((va_bits) - 4) / (PAGE_SHIFT - 3))
>>
>> I don't understand the '(va_bits) - 4' here, can you explain it (and add a
>> comment to that effect) ?
>
> I just had a chat with Catalin, who did shed some light on this.
> It all has to do with rounding up. What you would like to have here is:
>
> #define ARM64_HW_PGTABLE_LEVELS(va_bits) DIV_ROUND_UP(va_bits - PAGE_SHIFT, PAGE_SHIFT - 3)
>
> where (va_bits - PAGE_SHIFT) is the total number of bits we deal
> with during a page table walk, and (PAGE_SHIFT - 3) is the number
> of bits we deal with per level.
>
> The clue is in how DIV_ROUND_UP is written:
>
> #define DIV_ROUND_UP(n,d) (((n) + (d) - 1) / (d))
>
> which gives you Suzuki's magic formula.

Thanks Marc for pitching in. That explains it better.

>
> I'd vote for the DIV_ROUND_UP(), which will make things a lot more readable.

Sure, I can change that.

Suzuki

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH 03/15] arm64: Introduce helpers for page table levels Christoffer Dall <christoffer.dall@linaro.org> - 2015-10-07 10:30 +0200
  Re: [PATCH 03/15] arm64: Introduce helpers for page table levels Marc Zyngier <marc.zyngier@arm.com> - 2015-10-07 11:30 +0200
    Re: [PATCH 03/15] arm64: Introduce helpers for page table levels "Suzuki K. Poulose" <Suzuki.Poulose@arm.com> - 2015-10-07 11:50 +0200
    Re: [PATCH 03/15] arm64: Introduce helpers for page table levels Christoffer Dall <christoffer.dall@linaro.org> - 2015-10-08 16:50 +0200
      Re: [PATCH 03/15] arm64: Introduce helpers for page table levels Catalin Marinas <catalin.marinas@arm.com> - 2015-10-08 19:30 +0200
        Re: [PATCH 03/15] arm64: Introduce helpers for page table levels "Suzuki K. Poulose" <Suzuki.Poulose@arm.com> - 2015-10-09 11:30 +0200
      Re: [PATCH 03/15] arm64: Introduce helpers for page table levels "Suzuki K. Poulose" <Suzuki.Poulose@arm.com> - 2015-10-08 19:30 +0200
  Re: [PATCH 03/15] arm64: Introduce helpers for page table levels "Suzuki K. Poulose" <Suzuki.Poulose@arm.com> - 2015-10-07 12:00 +0200

csiph-web