Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1238444
| Path | csiph.com!eternal-september.org!feeder.eternal-september.org!aioe.org!bofh.it!news.nic.it!robomod |
|---|---|
| From | Felipe Balbi <balbi@ti.com> |
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 13/14] RFC: usb/host/faraday-hcd: Move #defines outside struct |
| Date | Fri, 02 Oct 2015 19:40:01 +0200 |
| Message-ID | <qfctj-1MB-13@gated-at.bofh.it> (permalink) |
| References | <q91Kj-2gb-19@gated-at.bofh.it> <qbaT7-1N0-3@gated-at.bofh.it> <qbaT9-1N0-63@gated-at.bofh.it> |
| X-Original-To | Peter Senna Tschudin <peter.senna@gmail.com> |
| Reply-To | <balbi@ti.com> |
| MIME-Version | 1.0 |
| Content-Type | multipart/signed; micalg=pgp-sha1; protocol="application/pgp-signature"; boundary="uWCTLymdFNG0vGYZ" |
| Content-Disposition | inline |
| User-Agent | Mutt/1.5.24 (2015-08-30) |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 65 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | <balbi@ti.com>, <stern@rowland.harvard.edu>, <sergei.shtylyov@cogentembedded.com>, <standby24x7@gmail.com>, <pmladek@suse.cz>, <linux-usb@vger.kernel.org>, <linux-kernel@vger.kernel.org>, <gregkh@linuxfoundation.org> |
| X-Original-Date | Fri, 2 Oct 2015 12:37:47 -0500 |
| X-Original-Message-ID | <20151002173747.GX5552@saruman.tx.rr.com> |
| X-Original-References | <20150915165002.GP19948@saruman.tx.rr.com> <1442847678-7970-1-git-send-email-peter.senna@gmail.com> <1442847678-7970-14-git-send-email-peter.senna@gmail.com> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1238444 |
Show key headers only | View raw
[Multipart message — attachments visible in raw view] - view raw
On Mon, Sep 21, 2015 at 05:01:17PM +0200, Peter Senna Tschudin wrote:
> For making the code more readable and to facilitate supporting multiple
> hardware versions, move #defines to outside the struct declaration. This
> patch also renames fhcd2xx_regs to fotg210_regs as this struct is
> specific to fotg210.
>
> Signed-off-by: Peter Senna Tschudin <peter.senna@gmail.com>
> ---
> drivers/usb/host/faraday-hcd.h | 137 ++++++++++++++++++++++-------------------
> 1 file changed, 74 insertions(+), 63 deletions(-)
>
> diff --git a/drivers/usb/host/faraday-hcd.h b/drivers/usb/host/faraday-hcd.h
> index cf29edf..f75c467 100644
> --- a/drivers/usb/host/faraday-hcd.h
> +++ b/drivers/usb/host/faraday-hcd.h
> @@ -85,7 +85,7 @@ struct fhcd2xx_hcd { /* one per controller */
>
> /* glue to PCI and HCD framework */
> struct fhcd2xx_caps __iomem *caps;
> - struct fhcd2xx_regs __iomem *regs;
> + struct fotg210_regs __iomem *regs;
should this be in previous patch ?
personally, I don't see what's the benefit of this patch, however not against it
either.
--
balbi
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH 13/14] RFC: usb/host/faraday-hcd: Move #defines outside struct Felipe Balbi <balbi@ti.com> - 2015-10-02 19:40 +0200
csiph-web