Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1238444 > unrolled thread

Re: [PATCH 13/14] RFC: usb/host/faraday-hcd: Move #defines outside struct

Started byFelipe Balbi <balbi@ti.com>
First post2015-10-02 19:40 +0200
Last post2015-10-02 19:40 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH 13/14] RFC: usb/host/faraday-hcd: Move #defines outside  struct Felipe Balbi <balbi@ti.com> - 2015-10-02 19:40 +0200

#1238444 — Re: [PATCH 13/14] RFC: usb/host/faraday-hcd: Move #defines outside struct

FromFelipe Balbi <balbi@ti.com>
Date2015-10-02 19:40 +0200
SubjectRe: [PATCH 13/14] RFC: usb/host/faraday-hcd: Move #defines outside struct
Message-ID<qfctj-1MB-13@gated-at.bofh.it>

[Multipart message — attachments visible in raw view] — view raw

On Mon, Sep 21, 2015 at 05:01:17PM +0200, Peter Senna Tschudin wrote:
> For making the code more readable and to facilitate supporting multiple
> hardware versions, move #defines to outside the struct declaration. This
> patch also renames fhcd2xx_regs to fotg210_regs as this struct is
> specific to fotg210.
> 
> Signed-off-by: Peter Senna Tschudin <peter.senna@gmail.com>
> ---
>  drivers/usb/host/faraday-hcd.h | 137 ++++++++++++++++++++++-------------------
>  1 file changed, 74 insertions(+), 63 deletions(-)
> 
> diff --git a/drivers/usb/host/faraday-hcd.h b/drivers/usb/host/faraday-hcd.h
> index cf29edf..f75c467 100644
> --- a/drivers/usb/host/faraday-hcd.h
> +++ b/drivers/usb/host/faraday-hcd.h
> @@ -85,7 +85,7 @@ struct fhcd2xx_hcd {			/* one per controller */
>  
>  	/* glue to PCI and HCD framework */
>  	struct fhcd2xx_caps __iomem *caps;
> -	struct fhcd2xx_regs __iomem *regs;
> +	struct fotg210_regs __iomem *regs;

should this be in previous patch ?

personally, I don't see what's the benefit of this patch, however not against it
either.

-- 
balbi

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web