Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1236650

Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA

From Tycho Andersen <tycho.andersen@canonical.com>
Newsgroups linux.kernel
Subject Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA
Date 2015-09-30 20:50 +0200
Message-ID <qeuBY-4Wa-7@gated-at.bofh.it> (permalink)
References <qeu8V-4ns-9@gated-at.bofh.it> <qeu8W-4ns-19@gated-at.bofh.it> <qeuiC-4z9-15@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, Sep 30, 2015 at 11:25:41AM -0700, Andy Lutomirski wrote:
> On Wed, Sep 30, 2015 at 11:13 AM, Tycho Andersen
> <tycho.andersen@canonical.com> wrote:
> > This command allows comparing the underling private data of two fds. This
> > is useful e.g. to find out if a seccomp filter is inherited, since struct
> > seccomp_filter are unique across tasks and are the private_data seccomp
> > fds.
> 
> This is very implementation-specific and may have nasty ABI
> consequences far outside seccomp.  Let's do something specific to
> seccomp and/or eBPF.

We could change the name to a less generic KCMP_SECCOMP_FD or
something, but without some sort of GUID on each struct
seccomp_filter, the implementation would be effectively the same as it
is today. Is that enough, or do we need a GUID?

Tycho
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

checkpoint/restore of seccomp filters v3 Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:20 +0200
  [PATCH v3 3/5] seccomp: add a ptrace command to get seccomp filter fds Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:20 +0200
  [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:20 +0200
    Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Andy Lutomirski <luto@amacapital.net> - 2015-09-30 20:30 +0200
      Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Andy Lutomirski <luto@amacapital.net> - 2015-09-30 20:50 +0200
        Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Andy Lutomirski <luto@amacapital.net> - 2015-09-30 21:00 +0200
          Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 23:40 +0200
            Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Andy Lutomirski <luto@amacapital.net> - 2015-09-30 23:50 +0200
              Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Tycho Andersen <tycho.andersen@canonical.com> - 2015-10-01 00:20 +0200
              Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Tycho Andersen <tycho.andersen@canonical.com> - 2015-10-01 18:50 +0200
        Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 21:00 +0200
      Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:50 +0200
  [PATCH v3 5/5] bpf: save the program the user actually supplied Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:20 +0200
  [PATCH v3 1/5] seccomp: save the original filter Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:20 +0200
  [PATCH v3 2/5] seccomp: add the concept of a seccomp filter FD Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:20 +0200
    Re: [PATCH v3 2/5] seccomp: add the concept of a seccomp filter FD Andy Lutomirski <luto@amacapital.net> - 2015-09-30 20:30 +0200
      Re: [PATCH v3 2/5] seccomp: add the concept of a seccomp filter FD Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:40 +0200
        Re: [PATCH v3 2/5] seccomp: add the concept of a seccomp filter FD Andy Lutomirski <luto@amacapital.net> - 2015-09-30 20:50 +0200
    Re: [PATCH v3 2/5] seccomp: add the concept of a seccomp filter FD kbuild test robot <lkp@intel.com> - 2015-09-30 20:30 +0200

csiph-web