Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1237566

Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA

From Tycho Andersen <tycho.andersen@canonical.com>
Newsgroups linux.kernel
Subject Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA
Date 2015-10-01 18:50 +0200
Message-ID <qePdo-1O6-5@gated-at.bofh.it> (permalink)
References (4 earlier) <qeuBY-4Wa-5@gated-at.bofh.it> <qeuLE-57k-17@gated-at.bofh.it> <qeuLE-57k-15@gated-at.bofh.it> <qexgu-oR-25@gated-at.bofh.it> <qexqb-AE-19@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, Sep 30, 2015 at 02:48:47PM -0700, Andy Lutomirski wrote:
> On Wed, Sep 30, 2015 at 2:39 PM, Tycho Andersen
> <tycho.andersen@canonical.com> wrote:
> > On Wed, Sep 30, 2015 at 11:56:25AM -0700, Andy Lutomirski wrote:
> >> On Wed, Sep 30, 2015 at 11:55 AM, Tycho Andersen
> >> <tycho.andersen@canonical.com> wrote:
> >> > On Wed, Sep 30, 2015 at 11:47:05AM -0700, Andy Lutomirski wrote:
> >> >> On Wed, Sep 30, 2015 at 11:41 AM, Tycho Andersen
> >> >> <tycho.andersen@canonical.com> wrote:
> >> >> > On Wed, Sep 30, 2015 at 11:25:41AM -0700, Andy Lutomirski wrote:
> >> >> >> On Wed, Sep 30, 2015 at 11:13 AM, Tycho Andersen
> >> >> >> <tycho.andersen@canonical.com> wrote:
> >> >> >> > This command allows comparing the underling private data of two fds. This
> >> >> >> > is useful e.g. to find out if a seccomp filter is inherited, since struct
> >> >> >> > seccomp_filter are unique across tasks and are the private_data seccomp
> >> >> >> > fds.
> >> >> >>
> >> >> >> This is very implementation-specific and may have nasty ABI
> >> >> >> consequences far outside seccomp.  Let's do something specific to
> >> >> >> seccomp and/or eBPF.
> >> >> >
> >> >> > We could change the name to a less generic KCMP_SECCOMP_FD or
> >> >> > something, but without some sort of GUID on each struct
> >> >> > seccomp_filter, the implementation would be effectively the same as it
> >> >> > is today. Is that enough, or do we need a GUID?
> >> >> >
> >> >>
> >> >> I don't care about the GUID.  I think we should name it
> >> >> KCMP_SECCOMP_FD and make it only work on seccomp fds.
> >> >
> >> > Ok, I can do that.
> >> >
> >> >> Alternatively, we could figure out why KCMP_FILE doesn't do the trick
> >> >> and consider fixing it.  IMO it's really too bad that struct file is
> >> >> so heavyweight that we can't really just embed one in all kinds of
> >> >> structures.
> >> >
> >> > The problem is that KCMP_FILE compares the file objects themselves,
> >> > instead of the underlying data. If I ask for a seccomp fd for filter 0
> >> > twice, I'll have two different file objects and they won't be equal. I
> >> > suppose we could add some special logic inside KCMP_FILE to compare
> >> > the underlying data in special cases (seccomp, ebpf, others?), but it
> >> > seems cleaner to have a separate command as you described above.
> >> >
> >>
> >> What I meant was that maybe we could get the two requests to actually
> >> produce the same struct file.  But that could get very messy
> >> memory-wise.
> >
> > I see. The attached patch seems to work with KCMP_FILE and doesn't
> > look too bad if you don't mind the circular references. What do you
> > think?
> >
> 
> Could be reasonable.  I'm not that well versed on what fd_release
> does.  Are we guaranteed that it's called when the last fd goes away
> even if the struct file is pinned by the struct seccomp filter but is
> otherwise unreferenced?

After thinking about the patch a bit more, I think it's not safe.
There is a race where the last referenced is closed at the same time
someone else asks for the strcut file via ptrace(). I thought the lock
would fix this, but it doesn't. I'll see if I can find another way.

Tycho
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

checkpoint/restore of seccomp filters v3 Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:20 +0200
  [PATCH v3 3/5] seccomp: add a ptrace command to get seccomp filter fds Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:20 +0200
  [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:20 +0200
    Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Andy Lutomirski <luto@amacapital.net> - 2015-09-30 20:30 +0200
      Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Andy Lutomirski <luto@amacapital.net> - 2015-09-30 20:50 +0200
        Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Andy Lutomirski <luto@amacapital.net> - 2015-09-30 21:00 +0200
          Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 23:40 +0200
            Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Andy Lutomirski <luto@amacapital.net> - 2015-09-30 23:50 +0200
              Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Tycho Andersen <tycho.andersen@canonical.com> - 2015-10-01 00:20 +0200
              Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Tycho Andersen <tycho.andersen@canonical.com> - 2015-10-01 18:50 +0200
        Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 21:00 +0200
      Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:50 +0200
  [PATCH v3 5/5] bpf: save the program the user actually supplied Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:20 +0200
  [PATCH v3 1/5] seccomp: save the original filter Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:20 +0200
  [PATCH v3 2/5] seccomp: add the concept of a seccomp filter FD Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:20 +0200
    Re: [PATCH v3 2/5] seccomp: add the concept of a seccomp filter FD Andy Lutomirski <luto@amacapital.net> - 2015-09-30 20:30 +0200
      Re: [PATCH v3 2/5] seccomp: add the concept of a seccomp filter FD Tycho Andersen <tycho.andersen@canonical.com> - 2015-09-30 20:40 +0200
        Re: [PATCH v3 2/5] seccomp: add the concept of a seccomp filter FD Andy Lutomirski <luto@amacapital.net> - 2015-09-30 20:50 +0200
    Re: [PATCH v3 2/5] seccomp: add the concept of a seccomp filter FD kbuild test robot <lkp@intel.com> - 2015-09-30 20:30 +0200

csiph-web