Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1237867

Re: [PATCH] modpost: Add flag -f for making section mismatches fatal

From Rusty Russell <rusty@rustcorp.com.au>
Newsgroups linux.kernel
Subject Re: [PATCH] modpost: Add flag -f for making section mismatches fatal
Date 2015-10-02 03:30 +0200
Message-ID <qeXkB-5f4-9@gated-at.bofh.it> (permalink)
References <qeWye-458-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Nicolas Boichat <drinkcat@chromium.org> writes:
> The section mismatch warning can be easy to miss during the kernel build
> process. Allow it to be marked as fatal to be easily caught and prevent
> bugs from slipping in.
>
> Setting CONFIG_SECTION_MISMATCH_WARNING=y causes these warnings to be
> non-fatal, since there are a number of section mismatches when using
> allmodconfig on some architectures, and we do not want to break these
> builds by default.
>
> Signed-off-by: Nicolas Boichat <drinkcat@chromium.org>
>
> Change-Id: Ic346706e3297c9f0d790e3552aa94e5cff9897a6
> ---
>
> I'm trying to revive this old patch. When it was first submitted [1],
> Jonathan got the following feedback:
>  - The logic of the option should be inverted (i.e. SECTION_MISMATCH_WARNING),
>    so that is not not enabled in allmodconfig for some architectures that do
>    have section mismatches. I've seen some failures (namely, on arm64), so I
>    did that.
>  - CONFIG_DEBUG_SECTION_MISMATCH should be removed and warnings should always
>    be shown verbosely. This option does 3 things:
>      1. Enable -fno-inline-functions-called-onc
>      2. Run the section mismatch analysis for each module/built-in.o
>      3. Enable verbose reporting from modpost
>    We definitely do not want 1 by default, so I think we should keep the option.
>    If we enable 2 & 3 by default, which I think would be reasonable, then the
>    option name does not make much sense anymore, and I'm not sure what to do
>    with the documentation that is currently provided in the Kconfig description.
>
> Tested on x86-64 allmodconfig, setting the option to =n, and creating a
> section mismatch by running:
> sed -i -e 's/\(ssize_t soc_codec_reg_show\)/__init \1/' sound/soc/soc-core.c

Minor feedback:

1) Please rename to CONFIG_SECTION_MISMATCH_WARN_ONLY.
2) -f means force, perhaps -E for error?

Otherwise, quite nice.

Thanks,
Rusty.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] modpost: Add flag -f for making section mismatches fatal Nicolas Boichat <drinkcat@chromium.org> - 2015-10-02 02:40 +0200
  Re: [PATCH] modpost: Add flag -f for making section mismatches fatal Rusty Russell <rusty@rustcorp.com.au> - 2015-10-02 03:30 +0200

csiph-web