Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1323054
| From | Bjørn Mork <bjorn@mork.no> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 11/14] USB: serial: mos7840: move constants to right |
| Date | 2016-02-01 13:40 +0100 |
| Message-ID | <qXlVT-2IS-1@gated-at.bofh.it> (permalink) |
| References | <qWHOO-7mY-3@gated-at.bofh.it> <qWHOP-7mY-39@gated-at.bofh.it> <qX7SW-Rd-17@gated-at.bofh.it> <qXljb-25A-5@gated-at.bofh.it> |
| Organization | m |
Mathieu OTHACEHE <m.othacehe@gmail.com> writes: > On Sun, Jan 31, 2016 at 10:33:54PM +0100, Bjørn Mork wrote: > >> I feel I'm missing something here, so I have to ask the stupid question: >> What could possibly be the benefit here? Is it faster? Safer? Easier >> to read? > > I don't think it will be faster or safer, maybe easier to read. But the point is to remove the > warnings produced by the file scripts/coccinelle/misc/compare_const_fl.cocci when > running make coccicheck. Making a tool happy is never going to be a valid reason for anything. If it were, then you would not be necessary... Luckily you still are. Your task is adding some intelligence to the output of the script. That means that you should look at the output and describe how it improves the code in a way that makes me understand it. And I can be pretty slow :) If you can't do that, then there is a high probability that the script didn't improve anything. Bjørn
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/14] USB: serial: Fix coccinelle warnings Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-01-30 18:50 +0100
[PATCH 06/14] USB: serial: garmin_gps: move constants to right Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-01-30 18:50 +0100
[PATCH 02/14] USB: serial: safe_serial: fix assignment of bool to non 0/1 constant Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-01-30 18:50 +0100
[PATCH 05/14] USB: serial: mos7840: remove comparison to bool Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-01-30 18:50 +0100
[PATCH 13/14] USB: serial: f81232: move constants to right Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-01-30 18:50 +0100
[PATCH 03/14] USB: serial: quatech2: remove comparison to bool Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-01-30 18:50 +0100
[PATCH 11/14] USB: serial: mos7840: move constants to right Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-01-30 18:50 +0100
Re: [PATCH 11/14] USB: serial: mos7840: move constants to right Bjørn Mork <bjorn@mork.no> - 2016-01-31 22:40 +0100
Re: [PATCH 11/14] USB: serial: mos7840: move constants to right Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-02-01 13:00 +0100
Re: [PATCH 11/14] USB: serial: mos7840: move constants to right Bjørn Mork <bjorn@mork.no> - 2016-02-01 13:40 +0100
[PATCH 10/14] USB: serial: garmin_gps: remove unneeded variable Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-01-30 18:50 +0100
[PATCH 01/14] USB: serial: safe_serial: fix assignment of bool to 0/1 Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-01-30 18:50 +0100
[PATCH 08/14] USB: serial: keyspan: remove unused semicolon Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-01-30 18:50 +0100
Re: [PATCH 00/14] USB: serial: Fix coccinelle warnings Johan Hovold <johan@kernel.org> - 2016-01-31 21:20 +0100
csiph-web