Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1315304

Re: [PATCH 1/2] regulator: core: Use a bitfield for continuous_voltage_range

From Joe Perches <joe@perches.com>
Newsgroups linux.kernel
Subject Re: [PATCH 1/2] regulator: core: Use a bitfield for continuous_voltage_range
Date 2016-01-22 22:50 +0100
Message-ID <qTRKG-1ss-9@gated-at.bofh.it> (permalink)
References <qTu1H-1V0-1@gated-at.bofh.it> <qTPpw-8pj-3@gated-at.bofh.it> <qTRB1-1oj-33@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, 2016-01-22 at 21:31 +0000, Mark Brown wrote:
> On Fri, Jan 22, 2016 at 11:15:28AM -0800, Joe Perches wrote:
> > On Thu, 2016-01-21 at 20:24 +0000, Mark Brown wrote:
> 
> > > -	bool continuous_voltage_range;
> > > +	unsigned int continuous_voltage_range:1;
> 
> > Is this really valuable?
> 
> > There are already padding bytes that are unused
> > and adding a couple more bools would be space
> > cost-free and more readable.
> 
> > I believe that read/write of bytes is also more
> > efficient on some architectures than bit field
> > read/modify/write uses.
> 
> It adds up when you get more flags and these are not in the least bit
> performance sensitive.

Sure, but intelligibility is useful too.
Do you expect to have more than 4 of these flags?

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/2] regulator: core: Use a bitfield for continuous_voltage_range Mark Brown <broonie@kernel.org> - 2016-01-21 21:30 +0100
  [PATCH 2/2] regulator: core: Provide per-regulator runtime PM support Mark Brown <broonie@kernel.org> - 2016-01-21 21:30 +0100
    Re: [PATCH 2/2] regulator: core: Provide per-regulator runtime PM  support kbuild test robot <lkp@intel.com> - 2016-01-21 23:00 +0100
  Re: [PATCH 1/2] regulator: core: Use a bitfield for  continuous_voltage_range Joe Perches <joe@perches.com> - 2016-01-22 20:20 +0100
    Re: [PATCH 1/2] regulator: core: Use a bitfield for  continuous_voltage_range Mark Brown <broonie@kernel.org> - 2016-01-22 22:40 +0100
      Re: [PATCH 1/2] regulator: core: Use a bitfield for  continuous_voltage_range Joe Perches <joe@perches.com> - 2016-01-22 22:50 +0100
        Re: [PATCH 1/2] regulator: core: Use a bitfield for  continuous_voltage_range Mark Brown <broonie@kernel.org> - 2016-01-23 16:20 +0100

csiph-web