Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1306671
| From | mchristi@redhat.com |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 20/35] dm: pass dm stats data dir instead of bi_rw |
| Date | 2016-01-11 21:40 +0100 |
| Message-ID | <qPRpV-7qL-13@gated-at.bofh.it> (permalink) |
| References | <qPRgd-7mV-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Mike Christie <mchristi@redhat.com>
It looks like dm stats cares about the data direction
(READ vs WRITE) and does not need the bio/request flags.
Commands like REQ_FLUSH, REQ_DISCARD and REQ_WRITE_SAME
are currently always set with REQ_WRITE, so the extra check for
REQ_DISCARD in dm_stats_account_io is not needed.
This patch has it use the bio and request data_dir helpers
instead of accessing the bi_rw/cmd_flags directly. This makes
the next patches that remove the operation from the cmd_flags
and bi_rw easier, because we will no longer have the REQ_WRITE
bit set for operations like discards.
This patch is compile tested only.
v2:
1. Merged Mike Snitzer's fixes to pass in int instead of
unsigned long.
2. Fix 80 char col issues.
Signed-off-by: Mike Christie <mchristi@redhat.com>
---
drivers/md/dm-stats.c | 9 ++++-----
drivers/md/dm.c | 21 ++++++++++++---------
2 files changed, 16 insertions(+), 14 deletions(-)
diff --git a/drivers/md/dm-stats.c b/drivers/md/dm-stats.c
index 8289804..4fba26c 100644
--- a/drivers/md/dm-stats.c
+++ b/drivers/md/dm-stats.c
@@ -514,11 +514,10 @@ static void dm_stat_round(struct dm_stat *s, struct dm_stat_shared *shared,
}
static void dm_stat_for_entry(struct dm_stat *s, size_t entry,
- unsigned long bi_rw, sector_t len,
+ int idx, sector_t len,
struct dm_stats_aux *stats_aux, bool end,
unsigned long duration_jiffies)
{
- unsigned long idx = bi_rw & REQ_WRITE;
struct dm_stat_shared *shared = &s->stat_shared[entry];
struct dm_stat_percpu *p;
@@ -584,7 +583,7 @@ static void dm_stat_for_entry(struct dm_stat *s, size_t entry,
#endif
}
-static void __dm_stat_bio(struct dm_stat *s, unsigned long bi_rw,
+static void __dm_stat_bio(struct dm_stat *s, int bi_rw,
sector_t bi_sector, sector_t end_sector,
bool end, unsigned long duration_jiffies,
struct dm_stats_aux *stats_aux)
@@ -645,8 +644,8 @@ void dm_stats_account_io(struct dm_stats *stats, unsigned long bi_rw,
last = raw_cpu_ptr(stats->last);
stats_aux->merged =
(bi_sector == (ACCESS_ONCE(last->last_sector) &&
- ((bi_rw & (REQ_WRITE | REQ_DISCARD)) ==
- (ACCESS_ONCE(last->last_rw) & (REQ_WRITE | REQ_DISCARD)))
+ ((bi_rw == WRITE) ==
+ (ACCESS_ONCE(last->last_rw) == WRITE))
));
ACCESS_ONCE(last->last_sector) = end_sector;
ACCESS_ONCE(last->last_rw) = bi_rw;
diff --git a/drivers/md/dm.c b/drivers/md/dm.c
index 1777c9c..b882e56c 100644
--- a/drivers/md/dm.c
+++ b/drivers/md/dm.c
@@ -686,8 +686,9 @@ static void start_io_acct(struct dm_io *io)
atomic_inc_return(&md->pending[rw]));
if (unlikely(dm_stats_used(&md->stats)))
- dm_stats_account_io(&md->stats, bio->bi_rw, bio->bi_iter.bi_sector,
- bio_sectors(bio), false, 0, &io->stats_aux);
+ dm_stats_account_io(&md->stats, bio_data_dir(bio),
+ bio->bi_iter.bi_sector, bio_sectors(bio),
+ false, 0, &io->stats_aux);
}
static void end_io_acct(struct dm_io *io)
@@ -701,8 +702,9 @@ static void end_io_acct(struct dm_io *io)
generic_end_io_acct(rw, &dm_disk(md)->part0, io->start_time);
if (unlikely(dm_stats_used(&md->stats)))
- dm_stats_account_io(&md->stats, bio->bi_rw, bio->bi_iter.bi_sector,
- bio_sectors(bio), true, duration, &io->stats_aux);
+ dm_stats_account_io(&md->stats, bio_data_dir(bio),
+ bio->bi_iter.bi_sector, bio_sectors(bio),
+ true, duration, &io->stats_aux);
/*
* After this is decremented the bio must not be touched if it is
@@ -1084,9 +1086,9 @@ static void rq_end_stats(struct mapped_device *md, struct request *orig)
if (unlikely(dm_stats_used(&md->stats))) {
struct dm_rq_target_io *tio = tio_from_request(orig);
tio->duration_jiffies = jiffies - tio->duration_jiffies;
- dm_stats_account_io(&md->stats, orig->cmd_flags, blk_rq_pos(orig),
- tio->n_sectors, true, tio->duration_jiffies,
- &tio->stats_aux);
+ dm_stats_account_io(&md->stats, rq_data_dir(orig),
+ blk_rq_pos(orig), tio->n_sectors, true,
+ tio->duration_jiffies, &tio->stats_aux);
}
}
@@ -2017,8 +2019,9 @@ static void dm_start_request(struct mapped_device *md, struct request *orig)
struct dm_rq_target_io *tio = tio_from_request(orig);
tio->duration_jiffies = jiffies;
tio->n_sectors = blk_rq_sectors(orig);
- dm_stats_account_io(&md->stats, orig->cmd_flags, blk_rq_pos(orig),
- tio->n_sectors, false, 0, &tio->stats_aux);
+ dm_stats_account_io(&md->stats, rq_data_dir(orig),
+ blk_rq_pos(orig), tio->n_sectors, false, 0,
+ &tio->stats_aux);
}
/*
--
1.8.3.1
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/35 v3] eparate operations from flags in the bio/request structs mchristi@redhat.com - 2016-01-11 21:30 +0100 [PATCH 32/35] block: shrink bi_rw and bi_op mchristi@redhat.com - 2016-01-11 21:30 +0100 [PATCH 19/35] dm: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:30 +0100 [PATCH 30/35] block, fs, drivers: do not test bi_rw for REQ_OPs mchristi@redhat.com - 2016-01-11 21:30 +0100 [PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH mchristi@redhat.com - 2016-01-11 21:30 +0100 [PATCH 27/35] drivers: set request op to REQ_OP mchristi@redhat.com - 2016-01-11 21:30 +0100 [PATCH 08/35] btrfs: set bi_op tp REQ_OP mchristi@redhat.com - 2016-01-11 21:30 +0100 [PATCH 33/35] block, drivers: add REQ_OP_FLUSH operation mchristi@redhat.com - 2016-01-11 21:30 +0100 [PATCH 34/35] block: add QUEUE_FLAGs for flush and fua mchristi@redhat.com - 2016-01-11 21:30 +0100 [PATCH 31/35] block, fs: remove old REQ definitions. mchristi@redhat.com - 2016-01-11 21:30 +0100 [PATCH 18/35] pm: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100 [PATCH 13/35] xfs: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100 [PATCH 24/35] xen: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100 [PATCH 20/35] dm: pass dm stats data dir instead of bi_rw mchristi@redhat.com - 2016-01-11 21:40 +0100 [PATCH 17/35] ocfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100 [PATCH 11/35] f2fs: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100 [PATCH 12/35] gfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100 [PATCH 26/35] block: set op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100 [PATCH 15/35] mpage: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100 [PATCH 23/35] md/raid: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100 [PATCH 21/35] bcache: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100 [PATCH 07/35] btrfs: have submit_one_bio users setup bio bi_op mchristi@redhat.com - 2016-01-11 21:40 +0100 [PATCH 09/35] btrfs: update __btrfs_map_block for bi_op transition mchristi@redhat.com - 2016-01-11 21:50 +0100 [PATCH 04/35] fs: have submit_bh users pass in op and flags separately mchristi@redhat.com - 2016-01-11 21:50 +0100 [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields mchristi@redhat.com - 2016-01-11 21:50 +0100 [PATCH 06/35] direct-io: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:50 +0100 [PATCH 05/35] fs: have ll_rw_block users pass in op and flags separately mchristi@redhat.com - 2016-01-11 21:50 +0100 [PATCH 10/35] btrfs: don't pass rq_flag_bits if there is a bio mchristi@redhat.com - 2016-01-11 21:50 +0100
csiph-web