Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1306656

[PATCH 00/35 v3] eparate operations from flags in the bio/request structs

From mchristi@redhat.com
Newsgroups linux.kernel
Subject [PATCH 00/35 v3] eparate operations from flags in the bio/request structs
Date 2016-01-11 21:30 +0100
Message-ID <qPRgd-7mV-3@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


The following patches begin to cleanup the request->cmd_flags and
bio->bi_rw mess. We currently use cmd_flags to specify the operation,
attributes and state of the request. For bi_rw we use it for similar
info and also the priority but then also have another bi_flags field
for state. At some point, we abused them so much we just made cmd_flags
64 bits, so we could add more.

The following patches seperate the operation (read, write discard,
flush, etc) from cmd_flags/bi_rw.

This patchset was made against linux-next from today Jan 11 2016.
(git tag next-20160111).

I put a git tree here:
https://github.com/mikechristie/linux-kernel.git

v3:

1. Used "=" instead of "|="  to setup bio bi_rw.
2. Removed __get_request cmd_flags compat code.
3. Merged initial dm related changes requested by Mike Snitzer.
4. Fixed ubd kbuild errors in flush related patches.
5. Fix 80 char col issues in several patches.
6. Fix issue with one of the btrfs patches where it looks like I reverted
a patch when trying to fix a merge error.

v2

1. Dropped arguments from submit_bio, and had callers setup
bio.
2. Add REQ_OP_FLUSH for request_fn users and renamed REQ_FLUSH
to REQ_PREFLUSH for make_request_fn users.
3. Dropped bio/rq_data_dir functions, and added a op_is_write
function instead.

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH 00/35 v3] eparate operations from flags in the bio/request structs mchristi@redhat.com - 2016-01-11 21:30 +0100
  [PATCH 32/35] block: shrink bi_rw and bi_op mchristi@redhat.com - 2016-01-11 21:30 +0100
  [PATCH 19/35] dm: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:30 +0100
  [PATCH 30/35] block, fs, drivers: do not test bi_rw for REQ_OPs mchristi@redhat.com - 2016-01-11 21:30 +0100
  [PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH mchristi@redhat.com - 2016-01-11 21:30 +0100
  [PATCH 27/35] drivers: set request op to REQ_OP mchristi@redhat.com - 2016-01-11 21:30 +0100
  [PATCH 08/35] btrfs: set bi_op tp REQ_OP mchristi@redhat.com - 2016-01-11 21:30 +0100
  [PATCH 33/35] block, drivers: add REQ_OP_FLUSH operation mchristi@redhat.com - 2016-01-11 21:30 +0100
  [PATCH 34/35] block: add QUEUE_FLAGs for flush and fua mchristi@redhat.com - 2016-01-11 21:30 +0100
  [PATCH 31/35] block, fs: remove old REQ definitions. mchristi@redhat.com - 2016-01-11 21:30 +0100
  [PATCH 18/35] pm: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100
  [PATCH 13/35] xfs: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100
  [PATCH 24/35] xen: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100
  [PATCH 20/35] dm: pass dm stats data dir instead of bi_rw mchristi@redhat.com - 2016-01-11 21:40 +0100
  [PATCH 17/35] ocfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100
  [PATCH 11/35] f2fs: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100
  [PATCH 12/35] gfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100
  [PATCH 26/35] block: set op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100
  [PATCH 15/35] mpage: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100
  [PATCH 23/35] md/raid: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100
  [PATCH 21/35] bcache: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:40 +0100
  [PATCH 07/35] btrfs: have submit_one_bio users setup bio bi_op mchristi@redhat.com - 2016-01-11 21:40 +0100
  [PATCH 09/35] btrfs: update __btrfs_map_block for bi_op transition mchristi@redhat.com - 2016-01-11 21:50 +0100
  [PATCH 04/35] fs: have submit_bh users pass in op and flags separately mchristi@redhat.com - 2016-01-11 21:50 +0100
  [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields mchristi@redhat.com - 2016-01-11 21:50 +0100
  [PATCH 06/35] direct-io: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-11 21:50 +0100
  [PATCH 05/35] fs: have ll_rw_block users pass in op and flags separately mchristi@redhat.com - 2016-01-11 21:50 +0100
  [PATCH 10/35] btrfs: don't pass rq_flag_bits if there is a bio mchristi@redhat.com - 2016-01-11 21:50 +0100

csiph-web