Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1285099
| Path | csiph.com!au2pb.net!2.us.feeder.erje.net!feeder.erje.net!2.eu.feeder.erje.net!weretis.net!feeder1.news.weretis.net!newsfeed.CARNet.hr!news.spin.it!bofh.it!news.nic.it!robomod |
|---|---|
| From | Ingo Molnar <mingo@kernel.org> |
| Newsgroups | linux.kernel |
| Subject | [PATCH 0/4] [RFC] cpumask: Robustify the var-cpumask allocation APIs |
| Date | Mon, 07 Dec 2015 10:00:02 +0100 |
| Message-ID | <qCZOh-2cf-5@gated-at.bofh.it> (permalink) |
| X-Original-To | linux-kernel@vger.kernel.org |
| Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=sender:from:to:cc:subject:date:message-id; bh=PC7wXkcCIbWSebQih1LtulFvFHKhPq3BlkSzmoe2+dM=; b=VWhc61IAsc/748z+CjJvsTctFdOSf6H8Lo1rEqygSTJ2bHaTld8XMDPWwlPEJky1a9 LvQHNyOyELkLZHw5s+XiEUyHNTlAIRyXfnC2EyPitp7Gefud2mz7ovO1BX6Ty1sXdgqk UqDqmBOzPk0Gu2rNAaTzoYc+jID+NLgLn7r8Tt+RQ4PFdCAQQY6/ET4C+0oDWqA9l4yp DoeGe8E5QJYFOIoMoO0IV4+e/fZazCeIrh9cpAjl5zeLEYL8kSCn3NbvvnfU4iPKFycP Jwb/tj2vg9gGcbi11u+GmzvTfcK/4hCi+v4FkFpEkYNagcZ5XDGAxkkyRvkdBENsO+3z TvGQ== |
| X-Received | by 10.28.216.201 with SMTP id p192mr20220870wmg.29.1449478206542; Mon, 07 Dec 2015 00:50:06 -0800 (PST) |
| X-Mailer | git-send-email 2.5.0 |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 97 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | Rusty Russell <rusty@rustcorp.com.au>, Peter Zijlstra <peterz@infradead.org>, Sergey Senozhatsky <sergey.senozhatsky@gmail.com>, Xunlei Pang <xlpang@redhat.com>, Rik van Riel <riel@redhat.com>, Andrew Morton <akpm@linux-foundation.org>, Linus Torvalds <torvalds@linux-foundation.org>, Thomas Gleixner <tglx@linutronix.de> |
| X-Original-Date | Mon, 7 Dec 2015 09:49:40 +0100 |
| X-Original-Message-ID | <1449478184-27168-1-git-send-email-mingo@kernel.org> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1285099 |
Show key headers only | View raw
Hi Rusty, this is the cpumask API robustification change we talked about in this lkml thread: [PATCH] sched/core: Clear the root_domain cpumasks in init_rootdomain() The idea is to first migrate all users of alloc_cpumask_var() to zalloc_cpumask_var(), then remove the old API. We still keep __alloc_cpumask_var_node(), for users who absolutely want to micro-manage their cpumask allocations. I also addressed a related naming ambiguity in alloc_bootmem_cpumask_var(). Lightly tested. ( If you like this series I can merge it via -tip, or you can pick it up, your call! ) Thanks, Ingo ========> Ingo Molnar (4): cpumask: Migrate 'alloc_cpumask_var()' users to 'zalloc_cpumask_var()' cpumask: Remove 'alloc_cpumask_var()' cpumask: Rename 'alloc_bootmem_cpumask_var()' to 'zalloc_bootmem_cpumask_var()' cpumask: Rename 'alloc_cpumask_var_node()' to '__alloc_cpumask_var_node()' arch/ia64/kernel/smp.c | 2 +- arch/mips/kernel/mips-mt-fpaff.c | 6 +++--- arch/powerpc/kernel/irq.c | 2 +- arch/powerpc/kernel/rtas.c | 4 ++-- arch/powerpc/kernel/smp.c | 2 +- arch/powerpc/mm/numa.c | 2 +- arch/powerpc/platforms/powernv/subcore.c | 2 +- arch/powerpc/platforms/pseries/smp.c | 2 +- arch/powerpc/platforms/pseries/suspend.c | 2 +- arch/x86/kernel/apic/vector.c | 4 ++-- arch/x86/kernel/cpu/common.c | 8 +++---- arch/x86/kernel/cpu/mcheck/mce-inject.c | 2 +- arch/x86/kernel/smp.c | 2 +- arch/x86/mm/mmio-mod.c | 2 +- arch/x86/mm/numa.c | 2 +- arch/x86/platform/uv/uv_nmi.c | 2 +- arch/x86/xen/mmu.c | 2 +- arch/x86/xen/smp.c | 2 +- block/blk-mq-cpumap.c | 2 +- crypto/pcrypt.c | 4 ++-- drivers/acpi/acpi_pad.c | 2 +- drivers/acpi/processor_throttling.c | 2 +- drivers/base/cpu.c | 2 +- drivers/cpufreq/cpufreq.c | 2 +- drivers/crypto/n2_core.c | 2 +- drivers/firmware/dcdbas.c | 2 +- drivers/hwmon/dell-smm-hwmon.c | 2 +- drivers/net/ethernet/intel/i40e/i40e_main.c | 2 +- drivers/pci/host/pci-xgene-msi.c | 2 +- drivers/scsi/mpt3sas/mpt3sas_base.c | 2 +- drivers/virtio/virtio_pci_common.c | 2 +- include/linux/cpumask.h | 20 ++++++----------- kernel/compat.c | 4 ++-- kernel/cpu.c | 2 +- kernel/cpuset.c | 16 +++++++------- kernel/irq/irqdesc.c | 2 +- kernel/irq/manage.c | 6 +++--- kernel/irq/proc.c | 4 ++-- kernel/padata.c | 10 ++++----- kernel/profile.c | 4 ++-- kernel/rcu/tree_plugin.h | 2 +- kernel/sched/core.c | 16 +++++++------- kernel/smpboot.c | 4 ++-- kernel/taskstats.c | 4 ++-- kernel/time/tick-sched.c | 6 +++--- kernel/torture.c | 2 +- kernel/trace/ring_buffer.c | 2 +- kernel/trace/trace.c | 10 ++++----- kernel/workqueue.c | 4 ++-- lib/cpumask.c | 33 ++++++++++++++--------------- mm/vmstat.c | 2 +- net/core/flow.c | 2 +- net/core/net-sysfs.c | 4 ++-- net/core/sysctl_net_core.c | 2 +- 54 files changed, 116 insertions(+), 123 deletions(-) -- 2.5.0 -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 0/4] [RFC] cpumask: Robustify the var-cpumask allocation APIs Ingo Molnar <mingo@kernel.org> - 2015-12-07 10:00 +0100
[PATCH 1/4] cpumask: Migrate 'alloc_cpumask_var()' users to 'zalloc_cpumask_var()' Ingo Molnar <mingo@kernel.org> - 2015-12-07 10:00 +0100
Re: [PATCH 1/4] cpumask: Migrate 'alloc_cpumask_var()' users to 'zalloc_cpumask_var()' Linus Torvalds <torvalds@linux-foundation.org> - 2015-12-08 02:30 +0100
Re: [PATCH 1/4] cpumask: Migrate 'alloc_cpumask_var()' users to 'zalloc_cpumask_var()' Ingo Molnar <mingo@kernel.org> - 2015-12-08 05:10 +0100
Re: [PATCH 1/4] cpumask: Migrate 'alloc_cpumask_var()' users to 'zalloc_cpumask_var()' Ingo Molnar <mingo@kernel.org> - 2015-12-08 05:20 +0100
csiph-web