Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1225823

Re: [RFC PATCH v3 2/3] ia64: rename migrate_irqs() to avoid compiling error

From Thomas Gleixner <tglx@linutronix.de>
Newsgroups linux.kernel
Subject Re: [RFC PATCH v3 2/3] ia64: rename migrate_irqs() to avoid compiling error
Date 2015-09-16 10:30 +0200
Message-ID <q9ggi-7oR-19@gated-at.bofh.it> (permalink)
References <q9ccF-1CG-3@gated-at.bofh.it> <q9ccF-1CG-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, 16 Sep 2015, Yang Yingliang wrote:

> To avoid multi-declaration error after adding migrate_irqs into
> kernel/irq/migration.c, rename migrate_irqs() to move_irqs().

And why can't you chose a different name for the generic function
instead of creating useless churn in IA64?
 
Thanks,

	tglx
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[RFC PATCH v3 2/3] ia64: rename migrate_irqs() to avoid compiling error Yang Yingliang <yangyingliang@huawei.com> - 2015-09-16 06:10 +0200
  Re: [RFC PATCH v3 2/3] ia64: rename migrate_irqs() to avoid compiling  error Thomas Gleixner <tglx@linutronix.de> - 2015-09-16 10:30 +0200
    Re: [RFC PATCH v3 2/3] ia64: rename migrate_irqs() to avoid compiling  error Yang Yingliang <yangyingliang@huawei.com> - 2015-09-16 13:20 +0200

csiph-web