Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1225706
| From | Yang Yingliang <yangyingliang@huawei.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [RFC PATCH v3 2/3] ia64: rename migrate_irqs() to avoid compiling error |
| Date | 2015-09-16 06:10 +0200 |
| Message-ID | <q9ccF-1CG-1@gated-at.bofh.it> (permalink) |
| References | <q9ccF-1CG-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
To avoid multi-declaration error after adding migrate_irqs into
kernel/irq/migration.c, rename migrate_irqs() to move_irqs().
Cc: Jiang Liu <jiang.liu@linux.intel.com>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Marc Zyngier <marc.zyngier@arm.com>
Cc: Mark Rutland <mark.rutland@arm.com>
Cc: Will Deacon <will.deacon@arm.com>
Cc: Russell King - ARM Linux <linux@arm.linux.org.uk>
Cc: Hanjun Guo <hanjun.guo@linaro.org>
Signed-off-by: Yang Yingliang <yangyingliang@huawei.com>
---
arch/ia64/kernel/irq.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/ia64/kernel/irq.c b/arch/ia64/kernel/irq.c
index de4fc00..005f339 100644
--- a/arch/ia64/kernel/irq.c
+++ b/arch/ia64/kernel/irq.c
@@ -98,7 +98,7 @@ unsigned int vectors_in_migration[NR_IRQS];
* Since cpu_online_mask is already updated, we just need to check for
* affinity that has zeros
*/
-static void migrate_irqs(void)
+static void move_irqs(void)
{
int irq, new_cpu;
@@ -167,7 +167,7 @@ void fixup_irqs(void)
* Phase 1: Locate IRQs bound to this cpu and
* relocate them for cpu removal.
*/
- migrate_irqs();
+ move_irqs();
/*
* Phase 2: Perform interrupt processing for all entries reported in
--
2.5.0
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[RFC PATCH v3 2/3] ia64: rename migrate_irqs() to avoid compiling error Yang Yingliang <yangyingliang@huawei.com> - 2015-09-16 06:10 +0200
Re: [RFC PATCH v3 2/3] ia64: rename migrate_irqs() to avoid compiling error Thomas Gleixner <tglx@linutronix.de> - 2015-09-16 10:30 +0200
Re: [RFC PATCH v3 2/3] ia64: rename migrate_irqs() to avoid compiling error Yang Yingliang <yangyingliang@huawei.com> - 2015-09-16 13:20 +0200
csiph-web