Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1220918

Re: [PATCH 3/3] arm64: dts: mt8173: Add nor flash node

From Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>
Newsgroups linux.kernel
Subject Re: [PATCH 3/3] arm64: dts: mt8173: Add nor flash node
Date 2015-09-08 17:20 +0200
Message-ID <q6sQF-80Q-5@gated-at.bofh.it> (permalink)
References <q6nR0-Fh-5@gated-at.bofh.it> <q6nR1-Fh-37@gated-at.bofh.it> <q6pJ8-3l8-27@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 8 September 2015 at 08:53, Jagan Teki <jteki@openedev.com> wrote:
> On 8 September 2015 at 15:19, Bayi Cheng <bayi.cheng@mediatek.com> wrote:
>> Add Mediatek nor flash node
>>
>> Signed-off-by: Bayi Cheng <bayi.cheng@mediatek.com>
>> ---
>>  arch/arm64/boot/dts/mediatek/mt8173.dtsi | 10 ++++++++++
>>  1 file changed, 10 insertions(+)
>>
>> diff --git a/arch/arm64/boot/dts/mediatek/mt8173.dtsi b/arch/arm64/boot/dts/mediatek/mt8173.dtsi
>> index d18ee42..a14f005 100644
>> --- a/arch/arm64/boot/dts/mediatek/mt8173.dtsi
>> +++ b/arch/arm64/boot/dts/mediatek/mt8173.dtsi
>> @@ -365,6 +365,16 @@
>>                         status = "disabled";
>>                 };
>>
>> +               nor_flash: nor@1100d000 {
>
> Based on the comments from 1/3 - this notation needs to be change something like
> qspi0: quadspi@1100d000
>

Actually, to follow ePAPR recomendations it should be named as flash@1100d000.
(See ePAPR, 2.2.2 Generic Names Recommendation).

I believe the phandle name choice can be more descriptive.
-- 
Ezequiel García, VanguardiaSur
www.vanguardiasur.com.ar
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/3] Mediatek SPI-NOR flash driver  Bayi Cheng <bayi.cheng@mediatek.com> - 2015-09-08 12:00 +0200
  [PATCH 1/3] doc: dt: add documentation for Mediatek spi-nor controller Bayi Cheng <bayi.cheng@mediatek.com> - 2015-09-08 12:00 +0200
    Re: [PATCH 1/3] doc: dt: add documentation for Mediatek spi-nor controller Jagan Teki <jteki@openedev.com> - 2015-09-08 13:40 +0200
    Re: [PATCH 1/3] doc: dt: add documentation for Mediatek spi-nor  controller Sascha Hauer <s.hauer@pengutronix.de> - 2015-09-09 07:50 +0200
    Re: [PATCH 1/3] doc: dt: add documentation for Mediatek spi-nor  controller Brian Norris <computersforpeace@gmail.com> - 2015-09-11 23:50 +0200
    Re: [PATCH 1/3] doc: dt: add documentation for Mediatek spi-nor  controller Brian Norris <computersforpeace@gmail.com> - 2015-09-11 23:50 +0200
  [PATCH 2/3] mtd: mtk-nor: mtk serial flash controller driver Bayi Cheng <bayi.cheng@mediatek.com> - 2015-09-08 12:00 +0200
    Re: [PATCH 2/3] mtd: mtk-nor: mtk serial flash controller driver Sascha Hauer <s.hauer@pengutronix.de> - 2015-09-09 08:40 +0200
      Re: [PATCH 2/3] mtd: mtk-nor: mtk serial flash controller driver Lothar Waßmann <LW@KARO-electronics.de> - 2015-09-09 15:10 +0200
  [PATCH 3/3] arm64: dts: mt8173: Add nor flash node Bayi Cheng <bayi.cheng@mediatek.com> - 2015-09-08 12:00 +0200
    Re: [PATCH 3/3] arm64: dts: mt8173: Add nor flash node Jagan Teki <jteki@openedev.com> - 2015-09-08 14:00 +0200
      Re: [PATCH 3/3] arm64: dts: mt8173: Add nor flash node Ezequiel Garcia <ezequiel@vanguardiasur.com.ar> - 2015-09-08 17:20 +0200
        Re: [PATCH 3/3] arm64: dts: mt8173: Add nor flash node Rob Herring <robh@kernel.org> - 2015-09-09 07:40 +0200
          Re: [PATCH 3/3] arm64: dts: mt8173: Add nor flash node Brian Norris <computersforpeace@gmail.com> - 2015-09-12 00:00 +0200

csiph-web