Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1212795

Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc()

From Ingo Molnar <mingo@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc()
Date 2015-08-25 10:20 +0200
Message-ID <q1hCy-P0-25@gated-at.bofh.it> (permalink)
References <q15rH-8v0-1@gated-at.bofh.it> <q15Bo-gI-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


* Luis R. Rodriguez <mcgrof@do-not-panic.com> wrote:

> From: "Luis R. Rodriguez" <mcgrof@suse.com>
> 
> Rename dma_*_writecombine() to dma_*_wc(), so that the naming
> is coherent across the various write-combining APIs.
> 
> The following Coccinelle SmPL patch was used for this simple
> transformation:
> 
> @ rename_dma_alloc_writecombine @
> expression dev, size, dma_addr, gfp;
> @@
> 
> -dma_alloc_writecombine(dev, size, dma_addr, gfp)
> +dma_alloc_wc(dev, size, dma_addr, gfp)
> 
> @ rename_dma_free_writecombine @
> expression dev, size, cpu_addr, dma_addr;
> @@
> 
> -dma_free_writecombine(dev, size, cpu_addr, dma_addr)
> +dma_free_wc(dev, size, cpu_addr, dma_addr)
> 
> @ rename_dma_mmap_writecombine @
> expression dev, vma, cpu_addr, dma_addr, size;
> @@
> 
> -dma_mmap_writecombine(dev, vma, cpu_addr, dma_addr, size)
> +dma_mmap_wc(dev, vma, cpu_addr, dma_addr, size)
> 
> Generated-by: Coccinelle SmPL
> Suggested-by: Ingo Molnar <mingo@kernel.org>
> Signed-off-by: Luis R. Rodriguez <mcgrof@suse.com>
> ---
>  arch/arm/mach-lpc32xx/phy3250.c           | 13 ++++++-------
>  arch/arm/mach-netx/fb.c                   | 14 ++++++--------
>  arch/arm/mach-nspire/clcd.c               | 13 ++++++-------
>  arch/avr32/include/asm/dma-mapping.h      | 20 ++++++++++----------
>  arch/avr32/mm/dma-coherent.c              | 12 ++++++------
>  arch/metag/include/asm/dma-mapping.h      |  4 ++--
>  arch/metag/kernel/dma.c                   |  6 +++---
>  drivers/dma/iop-adma.c                    |  8 ++++----
>  drivers/dma/mv_xor.c                      |  4 ++--
>  drivers/dma/qcom_bam_dma.c                | 14 +++++++-------
>  drivers/gpu/drm/drm_gem_cma_helper.c      | 13 ++++++-------
>  drivers/gpu/drm/omapdrm/omap_dmm_tiler.c  | 13 ++++++-------
>  drivers/gpu/drm/omapdrm/omap_gem.c        |  8 ++++----
>  drivers/gpu/drm/sti/sti_cursor.c          | 13 ++++++-------
>  drivers/gpu/drm/sti/sti_gdp.c             |  3 +--
>  drivers/gpu/drm/sti/sti_hqvdp.c           |  6 +++---
>  drivers/gpu/drm/tegra/gem.c               | 11 +++++------
>  drivers/gpu/host1x/cdma.c                 |  8 ++++----
>  drivers/gpu/host1x/job.c                  | 10 ++++------
>  drivers/media/platform/coda/coda-bit.c    | 10 +++++-----
>  drivers/video/fbdev/acornfb.c             |  4 ++--
>  drivers/video/fbdev/amba-clcd-versatile.c | 14 ++++++--------
>  drivers/video/fbdev/amba-clcd.c           |  4 ++--
>  drivers/video/fbdev/atmel_lcdfb.c         |  9 +++++----
>  drivers/video/fbdev/ep93xx-fb.c           |  9 +++------
>  drivers/video/fbdev/gbefb.c               |  8 ++++----
>  drivers/video/fbdev/imxfb.c               | 12 ++++++------
>  drivers/video/fbdev/mx3fb.c               |  9 ++++-----
>  drivers/video/fbdev/nuc900fb.c            |  8 ++++----
>  drivers/video/fbdev/omap/lcdc.c           | 16 ++++++++--------
>  drivers/video/fbdev/pxa168fb.c            |  8 ++++----
>  drivers/video/fbdev/pxafb.c               |  4 ++--
>  drivers/video/fbdev/s3c-fb.c              |  7 +++----
>  drivers/video/fbdev/s3c2410fb.c           |  8 ++++----
>  drivers/video/fbdev/sa1100fb.c            |  8 ++++----
>  include/linux/dma-mapping.h               | 16 ++++++++--------
>  sound/arm/pxa2xx-pcm-lib.c                | 20 ++++++++------------
>  sound/soc/fsl/imx-pcm-fiq.c               | 10 ++++------
>  sound/soc/nuc900/nuc900-pcm.c             |  6 ++----
>  sound/soc/omap/omap-pcm.c                 | 12 ++++--------
>  40 files changed, 183 insertions(+), 212 deletions(-)

Which kernel is this against? It has conflicts in 3 files with Linus's latest: 
v4.2-rc8.

Thanks,

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v4 00/11] x86/dma: RIP MTRR and dma write-combine API rename "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:20 +0200
  [PATCH v4 01/11] PCI: Add pci_ioremap_wc_bar() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:20 +0200
    [tip:x86/mm] PCI: Add pci_ioremap_wc_bar() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 02/11] drivers/video/fbdev/i740fb: Use arch_phys_wc_add() and pci_ioremap_wc_bar() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:20 +0200
    [tip:x86/mm] drivers/video/fbdev/i740fb: Use arch_phys_wc_add()   and pci_ioremap_wc_bar() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 03/11] drivers/video/fbdev/kyrofb: Use arch_phys_wc_add() and pci_ioremap_wc_bar() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] drivers/video/fbdev/kyrofb: Use arch_phys_wc_add()   and pci_ioremap_wc_bar() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 05/11] PCI: Add pci_iomap_wc() variants "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] PCI: Add pci_iomap_wc() variants "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 08/11] drivers/video/fbdev/vt8623fb: Use arch_phys_wc_add() and pci_iomap_wc() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] drivers/video/fbdev/vt8623fb: Use arch_phys_wc_add()   and pci_iomap_wc() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 11/11] mtrr: bury MTRR - unexport mtrr_add() and mtrr_del() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] x86/mm/mtrr: Remove kernel internal MTRR interfaces:   unexport mtrr_add() and mtrr_del() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-28 10:20 +0200
  [PATCH v4 09/11] drivers/dma/iop-adma: Use dma_alloc_writecombine() kernel-style "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] drivers/dma/iop-adma: Use dma_alloc_writecombine()   kernel-style "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 04/11] drivers/video/fbdev/gxt4500: Use pci_ioremap_wc_bar() to map framebuffer "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] drivers/video/fbdev/gxt4500: Use pci_ioremap_wc_bar(  ) to map framebuffer "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 07/11] drivers/video/fbdev/s3fb: Use arch_phys_wc_add() and pci_iomap_wc() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] drivers/video/fbdev/s3fb: Use arch_phys_wc_add()   and pci_iomap_wc() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 06/11] drivers/video/fbdev/arkfb.c: Use arch_phys_wc_add() and pci_iomap_wc() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] drivers/video/fbdev/arkfb.c: Use arch_phys_wc_add()   and pci_iomap_wc() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc() Ingo Molnar <mingo@kernel.org> - 2015-08-25 10:20 +0200
    Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc() "Luis R. Rodriguez" <mcgrof@suse.com> - 2015-08-25 17:50 +0200
      Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc() Andrew Morton <akpm@linux-foundation.org> - 2015-08-25 22:50 +0200
        Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc() "Luis R. Rodriguez" <mcgrof@suse.com> - 2015-08-26 01:20 +0200
          Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc() Andrew Morton <akpm@linux-foundation.org> - 2015-08-26 01:30 +0200
            Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc() Ingo Molnar <mingo@kernel.org> - 2015-08-26 06:30 +0200

csiph-web