Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1212443

[PATCH v4 09/11] drivers/dma/iop-adma: Use dma_alloc_writecombine() kernel-style

From "Luis R. Rodriguez" <mcgrof@do-not-panic.com>
Newsgroups linux.kernel
Subject [PATCH v4 09/11] drivers/dma/iop-adma: Use dma_alloc_writecombine() kernel-style
Date 2015-08-24 21:30 +0200
Message-ID <q15Bo-gI-15@gated-at.bofh.it> (permalink)
References <q15rH-8v0-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: "Luis R. Rodriguez" <mcgrof@suse.com>

dma_alloc_writecombine()'s call and return value check is tangled in all
in one call. Untangle both calls according to kernel coding style.

Signed-off-by: Luis R. Rodriguez <mcgrof@suse.com>
Acked-by: Vinod Koul <vinod.koul@intel.com>
Cc: Vinod Koul <vinod.koul@intel.com>
Cc: Dan Williams <dan.j.williams@intel.com>
Cc: dmaengine@vger.kernel.org
Cc: x86@kernel.org
Link: http://lkml.kernel.org/r/1435258191-543-2-git-send-email-mcgrof@do-not-panic.com
Signed-off-by: Borislav Petkov <bp@suse.de>
---
 drivers/dma/iop-adma.c | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/drivers/dma/iop-adma.c b/drivers/dma/iop-adma.c
index 998826854fdd..e4f43125e0fb 100644
--- a/drivers/dma/iop-adma.c
+++ b/drivers/dma/iop-adma.c
@@ -1300,10 +1300,11 @@ static int iop_adma_probe(struct platform_device *pdev)
 	 * note: writecombine gives slightly better performance, but
 	 * requires that we explicitly flush the writes
 	 */
-	if ((adev->dma_desc_pool_virt = dma_alloc_writecombine(&pdev->dev,
-					plat_data->pool_size,
-					&adev->dma_desc_pool,
-					GFP_KERNEL)) == NULL) {
+	adev->dma_desc_pool_virt = dma_alloc_writecombine(&pdev->dev,
+							  plat_data->pool_size,
+							  &adev->dma_desc_pool,
+							  GFP_KERNEL);
+	if (!adev->dma_desc_pool_virt) {
 		ret = -ENOMEM;
 		goto err_free_adev;
 	}
-- 
2.4.3

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v4 00/11] x86/dma: RIP MTRR and dma write-combine API rename "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:20 +0200
  [PATCH v4 01/11] PCI: Add pci_ioremap_wc_bar() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:20 +0200
    [tip:x86/mm] PCI: Add pci_ioremap_wc_bar() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 02/11] drivers/video/fbdev/i740fb: Use arch_phys_wc_add() and pci_ioremap_wc_bar() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:20 +0200
    [tip:x86/mm] drivers/video/fbdev/i740fb: Use arch_phys_wc_add()   and pci_ioremap_wc_bar() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 03/11] drivers/video/fbdev/kyrofb: Use arch_phys_wc_add() and pci_ioremap_wc_bar() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] drivers/video/fbdev/kyrofb: Use arch_phys_wc_add()   and pci_ioremap_wc_bar() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 05/11] PCI: Add pci_iomap_wc() variants "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] PCI: Add pci_iomap_wc() variants "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 08/11] drivers/video/fbdev/vt8623fb: Use arch_phys_wc_add() and pci_iomap_wc() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] drivers/video/fbdev/vt8623fb: Use arch_phys_wc_add()   and pci_iomap_wc() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 11/11] mtrr: bury MTRR - unexport mtrr_add() and mtrr_del() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] x86/mm/mtrr: Remove kernel internal MTRR interfaces:   unexport mtrr_add() and mtrr_del() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-28 10:20 +0200
  [PATCH v4 09/11] drivers/dma/iop-adma: Use dma_alloc_writecombine() kernel-style "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] drivers/dma/iop-adma: Use dma_alloc_writecombine()   kernel-style "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 04/11] drivers/video/fbdev/gxt4500: Use pci_ioremap_wc_bar() to map framebuffer "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] drivers/video/fbdev/gxt4500: Use pci_ioremap_wc_bar(  ) to map framebuffer "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 07/11] drivers/video/fbdev/s3fb: Use arch_phys_wc_add() and pci_iomap_wc() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] drivers/video/fbdev/s3fb: Use arch_phys_wc_add()   and pci_iomap_wc() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  [PATCH v4 06/11] drivers/video/fbdev/arkfb.c: Use arch_phys_wc_add() and pci_iomap_wc() "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-08-24 21:30 +0200
    [tip:x86/mm] drivers/video/fbdev/arkfb.c: Use arch_phys_wc_add()   and pci_iomap_wc() "tip-bot for Luis R. Rodriguez" <tipbot@zytor.com> - 2015-08-25 10:30 +0200
  Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc() Ingo Molnar <mingo@kernel.org> - 2015-08-25 10:20 +0200
    Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc() "Luis R. Rodriguez" <mcgrof@suse.com> - 2015-08-25 17:50 +0200
      Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc() Andrew Morton <akpm@linux-foundation.org> - 2015-08-25 22:50 +0200
        Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc() "Luis R. Rodriguez" <mcgrof@suse.com> - 2015-08-26 01:20 +0200
          Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc() Andrew Morton <akpm@linux-foundation.org> - 2015-08-26 01:30 +0200
            Re: [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc() Ingo Molnar <mingo@kernel.org> - 2015-08-26 06:30 +0200

csiph-web