Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1161897

Re: [RFC][PATCH 0/5] do not dereference NULL pools in pools' destroy() functions

From Andrew Morton <akpm@linux-foundation.org>
Newsgroups linux.kernel
Subject Re: [RFC][PATCH 0/5] do not dereference NULL pools in pools' destroy() functions
Date 2015-06-10 03:50 +0200
Message-ID <pzDjs-7Zy-3@gated-at.bofh.it> (permalink)
References <pzqvT-682-7@gated-at.bofh.it> <pzzfQ-246-17@gated-at.bofh.it> <pzCQp-7qt-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, 9 Jun 2015 20:11:25 -0500 (CDT) Christoph Lameter <cl@linux.com> wrote:

> On Tue, 9 Jun 2015, Andrew Morton wrote:
> 
> > Well I like it, even though it's going to cause a zillion little cleanup
> > patches.
> >
> > checkpatch already has a "kfree(NULL) is safe and this check is
> > probably not required" test so I guess Joe will need to get busy ;)
> >
> > I'll park these patches until after 4.1 is released - it's getting to
> > that time...
> 
> Why do this at all?

For the third time: because there are approx 200 callsites which are
already doing it.

> I understand that kfree/kmem_cache_free can take a
> null pointer but this is the destruction of a cache and it usually
> requires multiple actions to clean things up and these actions have to be
> properly sequenced. All other processors have to stop referencing this
> cache before it can be destroyed. I think failing if someone does
> something strange like doing cache destruction with a NULL pointer is
> valuable.

More than half of the kmem_cache_destroy() callsites are declining that
value by open-coding the NULL test.  That's reality and we should recognize
it.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [RFC][PATCH 0/5] do not dereference NULL pools in pools' destroy()  functions Christoph Lameter <cl@linux.com> - 2015-06-10 03:20 +0200
  Re: [RFC][PATCH 0/5] do not dereference NULL pools in pools'  destroy() functions Andrew Morton <akpm@linux-foundation.org> - 2015-06-10 03:50 +0200
    Re: [RFC][PATCH 0/5] do not dereference NULL pools in pools' destroy()  functions Christoph Lameter <cl@linux.com> - 2015-06-10 04:10 +0200
      Re: [RFC][PATCH 0/5] do not dereference NULL pools in pools'  destroy() functions Andrew Morton <akpm@linux-foundation.org> - 2015-06-10 04:20 +0200
  Re: [RFC][PATCH 0/5] do not dereference NULL pools in pools'  destroy() functions Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2015-06-10 04:10 +0200

csiph-web