Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1207912

Re: [PATCH] nd_blk: add support for "read flush" DSM flag

From Dan Williams <dan.j.williams@intel.com>
Newsgroups linux.kernel
Subject Re: [PATCH] nd_blk: add support for "read flush" DSM flag
Date 2015-08-14 23:30 +0200
Message-ID <pXuI2-5F4-7@gated-at.bofh.it> (permalink)
References <pXu5j-4GE-7@gated-at.bofh.it> <pXuoF-5iA-7@gated-at.bofh.it> <pXuoF-5iA-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Aug 14, 2015 at 2:07 PM, Ross Zwisler
<ross.zwisler@linux.intel.com> wrote:
> On Fri, 2015-08-14 at 14:05 -0700, Dan Williams wrote:
>> On Fri, Aug 14, 2015 at 1:43 PM, Ross Zwisler
>> This should be s/MEMREMAP_WB/ARCH_MEMREMAP_PMEM/, but other than that
>> looks good to me.
>>
>> I also should go move ARCH_MEMREMAP_PMEM over to
>> arch/x86/include/asm/pmem.h and fold it in to your other pending
>> pmem-api cleanups.
>
> Sounds good.  Would you like a v2 with those changes, or would you rather
> fix it as you apply it to the nvdimm tree?

Actually on closer this breaks the build for the unit test, so please
respin with the ARCH_MEMREMAP_PMEM change and the unit test fixups.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] nd_blk: add support for "read flush" DSM flag Ross Zwisler <ross.zwisler@linux.intel.com> - 2015-08-14 22:50 +0200
  Re: [PATCH] nd_blk: add support for "read flush" DSM flag Ross Zwisler <ross.zwisler@linux.intel.com> - 2015-08-14 23:10 +0200
    Re: [PATCH] nd_blk: add support for "read flush" DSM flag Dan Williams <dan.j.williams@intel.com> - 2015-08-14 23:30 +0200
  Re: [PATCH] nd_blk: add support for "read flush" DSM flag Dan Williams <dan.j.williams@intel.com> - 2015-08-14 23:10 +0200

csiph-web