Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1202439

[PATCH] coredump: Replace opencoded set_mask_bits()

From Vineet Gupta <Vineet.Gupta1@synopsys.com>
Newsgroups linux.kernel
Subject [PATCH] coredump: Replace opencoded set_mask_bits()
Date 2015-08-07 10:20 +0200
Message-ID <pUL2G-2d0-31@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


Cc: Alexander Viro <viro@zeniv.linux.org.uk>
Cc: Oleg Nesterov <oleg@redhat.com>
Cc: Peter Zijlstra (Intel) <peterz@infradead.org>
Cc: linux-fsdevel@vger.kernel.org
Cc: linux-kernel@vger.kernel.org
Signed-off-by: Vineet Gupta <vgupta@synopsys.com>
---
 fs/exec.c | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)

diff --git a/fs/exec.c b/fs/exec.c
index 1977c2a553ac..25078627f048 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -1690,15 +1690,10 @@ EXPORT_SYMBOL(set_binfmt);
  */
 void set_dumpable(struct mm_struct *mm, int value)
 {
-	unsigned long old, new;
-
 	if (WARN_ON((unsigned)value > SUID_DUMP_ROOT))
 		return;
 
-	do {
-		old = ACCESS_ONCE(mm->flags);
-		new = (old & ~MMF_DUMPABLE_MASK) | value;
-	} while (cmpxchg(&mm->flags, old, new) != old);
+	set_mask_bits(&mm->flags, MMF_DUMPABLE_MASK, value);
 }
 
 SYSCALL_DEFINE3(execve,
-- 
1.9.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH] coredump: Replace opencoded set_mask_bits() Vineet Gupta <Vineet.Gupta1@synopsys.com> - 2015-08-07 10:20 +0200
  Re: [PATCH] coredump: Replace opencoded set_mask_bits() Oleg Nesterov <oleg@redhat.com> - 2015-08-07 14:00 +0200
    Re: [PATCH] coredump: Replace opencoded set_mask_bits() Vineet Gupta <vgupta@synopsys.com> - 2015-08-07 16:50 +0200
      Re: [PATCH] coredump: Replace opencoded set_mask_bits() Peter Zijlstra <peterz@infradead.org> - 2015-08-07 17:00 +0200
        Re: [PATCH] coredump: Replace opencoded set_mask_bits() Vineet Gupta <vgupta@synopsys.com> - 2015-08-07 17:40 +0200
          Re: [PATCH] coredump: Replace opencoded set_mask_bits() Peter Zijlstra <peterz@infradead.org> - 2015-08-07 17:50 +0200
            Re: [PATCH] coredump: Replace opencoded set_mask_bits() Vineet Gupta <vgupta@synopsys.com> - 2015-08-07 18:00 +0200
              Re: [PATCH] coredump: Replace opencoded set_mask_bits() Peter Zijlstra <peterz@infradead.org> - 2015-08-07 18:10 +0200

csiph-web