Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1200080
| From | Ulrich Obergfell <uobergfe@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/4] watchdog: introduce watchdog_park_threads() and watchdog_unpark_threads() |
| Date | 2015-08-04 17:30 +0200 |
| Message-ID | <pTMkc-65J-55@gated-at.bofh.it> (permalink) |
| References | <pSEoF-4YJ-3@gated-at.bofh.it> <pSEoG-4YJ-13@gated-at.bofh.it> <pTKs2-3mh-25@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
> ----- Original Message -----
> From: "Michal Hocko" <mhocko@kernel.org>
...
> On Sat 01-08-15 14:49:22, Ulrich Obergfell wrote:
>> These functions are intended to be used only from inside kernel/watchdog.c
>> to park/unpark all watchdog threads that are specified in watchdog_cpumask.
>
> I would suggest merging this into Patch2. It is usually better to add
> new functions along with their users.
Michal,
watchdog_{park|unpark}_threads are called by watchdog_{suspend|resume}
in Patch 2/4 and by update_watchdog_all_cpus() in Patch 3/4, so I would
have to merge three patches into one, and I would end up with one large
patch and one smaller patch. I think the result would be harder to read,
review and understand. Thus I'd prefer to leave the patches split as they
currently are.
Regards,
Uli
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH 1/4] watchdog: introduce watchdog_park_threads() and watchdog_unpark_threads() Michal Hocko <mhocko@kernel.org> - 2015-08-04 15:30 +0200 Re: [PATCH 1/4] watchdog: introduce watchdog_park_threads() and watchdog_unpark_threads() Ulrich Obergfell <uobergfe@redhat.com> - 2015-08-04 17:30 +0200
csiph-web