Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1194779
| From | YH Huang <yh.huang@mediatek.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v6 0/3] Add MediaTek display PWM driver |
| Date | 2015-07-29 05:10 +0200 |
| Message-ID | <pRpUJ-41i-3@gated-at.bofh.it> (permalink) |
| References | <pOesO-3Zl-9@gated-at.bofh.it> <pPGQ1-Az-7@gated-at.bofh.it> <pPHj3-1rz-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, 2015-07-24 at 17:10 +0800, YH Huang wrote: > On Fri, 2015-07-24 at 10:42 +0200, Matthias Brugger wrote: > > On Monday, July 20, 2015 04:17:14 PM YH Huang wrote: > > > This patch series add the use of display PWM driver, documentation > > > and device tree for Mediatek SoCs. The driver is used to support > > > the backlight of the panel. This is based on v4.2-rc1. > > > > > > The clock definitions (CLK_MM_DISP_PWM*) are added by James Liao's patch: > > > clk: mediatek: Add subsystem clocks of MT8173 > > > > > > Change in v6: > > > 1. Enable clocks in the pwm_enable function > > > 2. Remove suspend/resume code since pwm-backlight driver has done the same > > > things 3. Revise some code to make it easier to read > > > > > > > Can you please provide the whole change log for all versions the next time. > > It's easier this way to understand the evolution of the series. > > Change in v6: > 1. Enable clocks in the pwm_enable function. > 2. Remove suspend/resume code since pwm-backlight driver has done the > same things. > 3. Revise some code to make it easier to read. > > Change in v5: > 1. Configure PWM output via pinctrl. > 2. Fix the parameter name in dtsi. > > Change in v4: > 1. Codebase is on v4.2-rc1. > 2. Add the PWM node in dtsi. > 3. Change the dependency in Kconfig. > 4. Rewrite some code for readability. > > Change in v3: > 1. Add suspend/resume function. > 2. Fix the formula for high_width calculation. > 3. Rewrite some code to make it easier to read. > 4. Add more information in the commit message. > > Change in v2: > 1. Rewrite descriptions for driver in kconfig to make it much clear. > 2. Rename the driver from "pwm-mediatek-disp" to "pwm-mtk-disp". > 3. Disable clocks in the error path. > 4. Change the shift values in decimal instead of hex. > 5. Rename and add some variables or function name for consistency and > readability. > 6. Drop unnecessary parentheses, spaces, variables and add newlines to > make the code easiler to read. Hi all, If you have any suggestions, please let me know. Perhaps we can apply the patch? Regards, YH Huang -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [PATCH v6 0/3] Add MediaTek display PWM driver Matthias Brugger <matthias.bgg@gmail.com> - 2015-07-24 10:50 +0200
Re: [PATCH v6 0/3] Add MediaTek display PWM driver YH Huang <yh.huang@mediatek.com> - 2015-07-24 11:20 +0200
Re: [PATCH v6 0/3] Add MediaTek display PWM driver YH Huang <yh.huang@mediatek.com> - 2015-07-29 05:10 +0200
Re: [PATCH v6 0/3] Add MediaTek display PWM driver YH Huang <yh.huang@mediatek.com> - 2015-08-03 08:40 +0200
csiph-web