Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1190056

Re: [PATCH v4 07/19] PCI/MSI: Let pci_msi_get_domain use struct device's msi_domain

From Marc Zyngier <marc.zyngier@arm.com>
Newsgroups linux.kernel
Subject Re: [PATCH v4 07/19] PCI/MSI: Let pci_msi_get_domain use struct device's msi_domain
Date 2015-07-22 17:30 +0200
Message-ID <pP482-2op-21@gated-at.bofh.it> (permalink)
References <pMtPj-7dE-5@gated-at.bofh.it> <pMtPk-7dE-41@gated-at.bofh.it> <pON7c-3eW-17@gated-at.bofh.it>
Organization ARM Ltd

Show all headers | View raw


On 21/07/15 22:17, Bjorn Helgaas wrote:
> Hi Marc,
> 
> On Wed, Jul 15, 2015 at 01:16:41PM +0100, Marc Zyngier wrote:
>> Now that we can easily find which MSI domain a PCI device is
>> using, use dev_get_msi_domain as a way to retrieve the information.
>>
>> The original code is still used as a fallback.
>>
>> Signed-off-by: Marc Zyngier <marc.zyngier@arm.com>
>> ---
>>  drivers/pci/msi.c | 3 ++-
>>  1 file changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/pci/msi.c b/drivers/pci/msi.c
>> index ef4ec6e..c77fdaf 100644
>> --- a/drivers/pci/msi.c
>> +++ b/drivers/pci/msi.c
>> @@ -41,7 +41,8 @@ static struct irq_domain *pci_msi_get_domain(struct pci_dev *dev)
>>  {
>>  	struct irq_domain *domain = NULL;
>>  
>> -	if (dev->bus->msi)
>> +	domain = dev_get_msi_domain(&dev->dev);
>> +	if (!domain && dev->bus->msi)
>>  		domain = dev->bus->msi->domain;
>>  	if (!domain)
>>  		domain = arch_get_pci_msi_domain(dev);
> 
> I think this would be slightly easier to read as:
> 
>     struct irq_domain *domain;
> 
>     domain = dev_get_msi_domain(&dev->dev);
>     if (domain)
> 	return domain;
> 
>     if (dev->bus->msi && (domain = dev->bus->msi->domain))
> 	return domain;
> 
>     return arch_get_pci_msi_domain(dev);
> 
> I'm not a huge fan of assignments inside "if" conditions, and checkpatch
> might even complain about it, but it exposes the fallback order pretty well
> here.  I guess we could also just repeat the dev->bus->msi->domain
> expression:
> 
>     if (dev->bus->msi && dev->bus->msi->domain)
> 	return dev->bus->msi->domain;
> 
> We can at least get rid of the superfluous initialization of domain to
> NULL.

Yeah, that's better, considering that (as you've noticed) the ugly
assignment is removed in the last patch.

Thanks,

	M.
-- 
Jazz is not dead. It just smells funny...
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v4 00/19] Per-device MSI domain & platform MSI Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
  [PATCH v4 02/19] PCI: MSI: Register irq domain with specific token Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
  [PATCH v4 11/19] irqchip: gicv3-its: Split PCI/MSI code from the core ITS driver Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
  [PATCH v4 08/19] platform: of: Assign MSI domain to platform device Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
  [PATCH v4 19/19] PCI/MSI: Drop domain field from msi_controller Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
  [PATCH v4 05/19] PCI/MSI: of: Add support for OF-provided msi_domain Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
  [PATCH v4 07/19] PCI/MSI: Let pci_msi_get_domain use struct device's msi_domain Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
    Re: [PATCH v4 07/19] PCI/MSI: Let pci_msi_get_domain use struct device's  msi_domain Marc Zyngier <marc.zyngier@arm.com> - 2015-07-22 17:30 +0200
  [PATCH v4 03/19] device core: Introduce per-device MSI domain pointer Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
  [PATCH v4 14/19] irqchip: gicv3-its: Make the PCI/MSI code standalone Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
  [PATCH v4 16/19] irqchip: GICv2m: Get rid of struct msi_controller Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
  [PATCH v4 12/19] irqchip: gicv3-its: Register irq domain with NEXUS token Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
  [PATCH v4 13/19] irqchip: gicv3-its: Get rid of struct msi_controller Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
  [PATCH v4 17/19] irqchip: GICv2m: Add platform MSI support Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:20 +0200
  [PATCH v4 10/19] genirq: Add DOMAIN_BUS_NEXUS irqdomain property Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:30 +0200
  [PATCH v4 01/19] genirq: irqdomain: Allow irq domain aliasing Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:30 +0200
  [PATCH v4 06/19] PCI/MSI: of: Allow msi_domain lookup using the host bridge node Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:30 +0200
  [PATCH v4 04/19] PCI/MSI: Add hooks to populate the msi_domain field Marc Zyngier <marc.zyngier@arm.com> - 2015-07-15 14:30 +0200
    Re: [PATCH v4 04/19] PCI/MSI: Add hooks to populate the msi_domain  field Marc Zyngier <marc.zyngier@arm.com> - 2015-07-22 16:50 +0200
      Re: [PATCH v4 04/19] PCI/MSI: Add hooks to populate the msi_domain field Bjorn Helgaas <bhelgaas@google.com> - 2015-07-22 16:50 +0200
        Re: [PATCH v4 04/19] PCI/MSI: Add hooks to populate the msi_domain  field Marc Zyngier <marc.zyngier@arm.com> - 2015-07-22 17:00 +0200
          Re: [PATCH v4 04/19] PCI/MSI: Add hooks to populate the msi_domain  field Bjorn Helgaas <bhelgaas@google.com> - 2015-07-22 19:00 +0200
            Re: [PATCH v4 04/19] PCI/MSI: Add hooks to populate the msi_domain  field Marc Zyngier <marc.zyngier@arm.com> - 2015-07-22 19:50 +0200

csiph-web