Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.user > #193892 > unrolled thread

Printing impossible

Started byMENGUAL Jean-Philippe <mengualjeanphi@free.fr>
First post2018-03-18 23:30 +0100
Last post2018-03-25 11:20 +0200
Articles 17 — 4 participants

Back to article view | Back to linux.debian.user


Contents

  Printing impossible MENGUAL Jean-Philippe <mengualjeanphi@free.fr> - 2018-03-18 23:30 +0100
    Re: Printing impossible Brian <ad44@cityscape.co.uk> - 2018-03-19 13:30 +0100
      Re: Printing impossible MENGUAL Jean-Philippe <mengualjeanphi@free.fr> - 2018-03-19 14:20 +0100
        Re: Printing impossible Brian <ad44@cityscape.co.uk> - 2018-03-19 15:00 +0100
          Re: Printing impossible Curt <curty@free.fr> - 2018-03-19 16:00 +0100
            Re: Printing impossible Brian <ad44@cityscape.co.uk> - 2018-03-19 16:30 +0100
              Re: Printing impossible Brian <ad44@cityscape.co.uk> - 2018-03-20 19:50 +0100
                Re: Printing impossible MENGUAL Jean-Philippe <mengualjeanphi@free.fr> - 2018-03-25 11:40 +0200
                  Re: Printing impossible Brian <ad44@cityscape.co.uk> - 2018-03-25 19:10 +0200
                    Re: Printing impossible MENGUAL Jean-Philippe <mengualjeanphi@free.fr> - 2018-03-25 23:00 +0200
                      Re: Printing impossible Brian <ad44@cityscape.co.uk> - 2018-03-26 01:20 +0200
                        Re: Printing impossible MENGUAL Jean-Philippe <mengualjeanphi@free.fr> - 2018-03-26 06:00 +0200
                          Re: Printing impossible MENGUAL Jean-Philippe <mengualjeanphi@free.fr> - 2018-03-27 10:40 +0200
                            Re: Printing impossible Brian <ad44@cityscape.co.uk> - 2018-03-27 12:40 +0200
              Re: Printing impossible MENGUAL Jean-Philippe <mengualjeanphi@free.fr> - 2018-03-25 11:30 +0200
    Re: Printing impossible songbird <songbird@anthive.com> - 2018-03-19 16:10 +0100
      Re: Printing impossible MENGUAL Jean-Philippe <mengualjeanphi@free.fr> - 2018-03-25 11:20 +0200

#193892 — Printing impossible

FromMENGUAL Jean-Philippe <mengualjeanphi@free.fr>
Date2018-03-18 23:30 +0100
SubjectPrinting impossible
Message-ID<vuOYq-68H-25@gated-at.bofh.it>

[Multipart message — attachments visible in raw view] — view raw

Hi,

For some time on Buster, I no longer can print on any printer, in
particular my Samsung ML1750. If I check the attached log, it seems
however that it is not related to the printer, but rather filters. The
job is 71. Lines 3455 and so on are interesting I think.

Attached file: http://demo.accelibreinfo.eu/error_log

Would you have an idea about the pb? What could I do to fix it?
Many thanks for help

regards

-- 
signature_jp_2
Logo Hypra 	JEAN-PHILIPPE MENGUAL
DIRECTEUR TECHNIQUE ET QUALITÉ
102, rue des poissonniers, 75018, Paris
Tel : +331 84 73 06 61 <tel:+33184730661> Mob : +336 76 34 93 37
<tel:+33676349337>
jpmengual@hypra.fr <mailto:jpmengual@hypra.fr>
www.hypra.fr <http://www.hypra.fr/>
Facebook Hypra <https://www.facebook.com/hyprasoftware/> Twitter Hypra
<https://twitter.com/Hypra_> Linkedin Jean-Philippe
<https://fr.linkedin.com/in/jean-philippe-mengual-800133135>


[toc] | [next] | [standalone]


#193896

FromBrian <ad44@cityscape.co.uk>
Date2018-03-19 13:30 +0100
Message-ID<vv25k-6rv-11@gated-at.bofh.it>
In reply to#193892
On Sun 18 Mar 2018 at 23:28:08 +0100, MENGUAL Jean-Philippe wrote:

> For some time on Buster, I no longer can print on any printer, in
> particular my Samsung ML1750. If I check the attached log, it seems
> however that it is not related to the printer, but rather filters. The
> job is 71. Lines 3455 and so on are interesting I think.
> 
> Attached file: http://demo.accelibreinfo.eu/error_log
> 
> Would you have an idea about the pb? What could I do to fix it?
> Many thanks for help

Looks like Ghostscript doesn't like something:

 D [18/Mar/2018:03:56:11 +0100] [Job 71] ./base/gsicc_manage.c:1148: gsicc_open_search(): Could not find default_gray.icc
 D [18/Mar/2018:03:56:11 +0100] [Job 71] | ./base/gsicc_manage.c:1799: gsicc_set_device_profile(): cannot find device
profile
 D [18/Mar/2018:03:56:11 +0100] [Job 71] Unrecoverable error: rangecheck in .putdeviceprops
 I [18/Mar/2018:03:56:11 +0100] Expiring subscriptions...
 D [18/Mar/2018:03:56:11 +0100] [Job 71] Operand stack:
 D [18/Mar/2018:03:56:11 +0100] [Job 71] true
 E [18/Mar/2018:03:56:11 +0100] [Job 71] SpliX Cannot open job

Use cupsfilter (please see the wiki) to test a wide range of input
files and see if the problem occurs with all of them.

Try setting SRT MODE in the PPD to "Normal" or stopping the colord
service.

-- 
Brian.

[toc] | [prev] | [next] | [standalone]


#193899

FromMENGUAL Jean-Philippe <mengualjeanphi@free.fr>
Date2018-03-19 14:20 +0100
Message-ID<vv2RH-6Yt-9@gated-at.bofh.it>
In reply to#193896
Hi,

Le 19/03/2018 à 13:22, Brian a écrit :
> On Sun 18 Mar 2018 at 23:28:08 +0100, MENGUAL Jean-Philippe wrote:
> 
> 
> Use cupsfilter (please see the wiki) to test a wide range of input
> files and see if the problem occurs with all of them.

Is:
cupsfilter -P Samsung.ppd doc.odt

enough? I get always: no filter to convert to application/pdf

although cups-filters seems to be installed.

The same with --list-filters parameter.


> 
> Try setting SRT MODE in the PPD to "Normal" or stopping the colord
> service.

How do I do it? Editing the ppd? In a commandline switch of cups-filter?

Thanks for your help

Regards

> 

[toc] | [prev] | [next] | [standalone]


#193900

FromBrian <ad44@cityscape.co.uk>
Date2018-03-19 15:00 +0100
Message-ID<vv3up-7fm-1@gated-at.bofh.it>
In reply to#193899
On Mon 19 Mar 2018 at 14:14:28 +0100, MENGUAL Jean-Philippe wrote:

> Hi,
> 
> Le 19/03/2018 à 13:22, Brian a écrit :
> > On Sun 18 Mar 2018 at 23:28:08 +0100, MENGUAL Jean-Philippe wrote:
> > 
> > 
> > Use cupsfilter (please see the wiki) to test a wide range of input
> > files and see if the problem occurs with all of them.
> 
> Is:
> cupsfilter -P Samsung.ppd doc.odt
> 
> enough? I get always: no filter to convert to application/pdf

Text, PS, PDF, JPEG (JPG) for input.

An example; as root:

 cupsfilter -p /etc/cups/ppd/<PPD_for_the_1750> -m printer/foo -e /etc/services > output 2>log

> although cups-filters seems to be installed.

cups-filters will not process .odt files.

> The same with --list-filters parameter.

 cupsfilter -p /etc/cups/ppd/<PPD_for_the_1750> -m printer/foo --list-filters -e /etc/services

> > Try setting SRT MODE in the PPD to "Normal" or stopping the colord
> > service.
> 
> How do I do it? Editing the ppd? In a commandline switch of cups-filter?

Using the CUPS web interface at localhost:631 is easiest.

 Printers -> Queue -> Administration -> Set Default Options

-- 
Brian.

[toc] | [prev] | [next] | [standalone]


#193904

FromCurt <curty@free.fr>
Date2018-03-19 16:00 +0100
Message-ID<vv4qu-7S1-7@gated-at.bofh.it>
In reply to#193900
On 2018-03-19, Brian <ad44@cityscape.co.uk> wrote:
>> 
>> How do I do it? Editing the ppd? In a commandline switch of cups-filter?
>
> Using the CUPS web interface at localhost:631 is easiest.
>
>  Printers -> Queue -> Administration -> Set Default Options
>

Just piping up to say he was advised by Ken Sharp (as an initial
experimental move) to remove "setpagedevice" from the gs command line
here (after having metooed a bug that turned out being a different one
from the one from which he suffers):

https://bugs.ghostscript.com/show_bug.cgi?id=695873

Sorry if this is merely a distraction.

-- 
Bah, the latest news, the latest news is not the last.
Samuel Beckett

[toc] | [prev] | [next] | [standalone]


#193910

FromBrian <ad44@cityscape.co.uk>
Date2018-03-19 16:30 +0100
Message-ID<vv4Tw-8gF-11@gated-at.bofh.it>
In reply to#193904
On Mon 19 Mar 2018 at 14:52:25 +0000, Curt wrote:

> On 2018-03-19, Brian <ad44@cityscape.co.uk> wrote:
> >> 
> >> How do I do it? Editing the ppd? In a commandline switch of cups-filter?
> >
> > Using the CUPS web interface at localhost:631 is easiest.
> >
> >  Printers -> Queue -> Administration -> Set Default Options
> >
> 
> Just piping up to say he was advised by Ken Sharp (as an initial
> experimental move) to remove "setpagedevice" from the gs command line
> here (after having metooed a bug that turned out being a different one
> from the one from which he suffers):
> 
> https://bugs.ghostscript.com/show_bug.cgi?id=695873
> 
> Sorry if this is merely a distraction.

No need to be sorry; every little helps and it could certainly be an
avenue for exploration. If the issue appears with a varied selection
of files we could be looking at a defect in gstoraster's Ghostscript
command.

-- 
Brian.

[toc] | [prev] | [next] | [standalone]


#193962

FromBrian <ad44@cityscape.co.uk>
Date2018-03-20 19:50 +0100
Message-ID<vvuuC-7UI-7@gated-at.bofh.it>
In reply to#193910
On Mon 19 Mar 2018 at 15:25:41 +0000, Brian wrote:

> On Mon 19 Mar 2018 at 14:52:25 +0000, Curt wrote:
> 
> > On 2018-03-19, Brian <ad44@cityscape.co.uk> wrote:
> > >> 
> > >> How do I do it? Editing the ppd? In a commandline switch of cups-filter?
> > >
> > > Using the CUPS web interface at localhost:631 is easiest.
> > >
> > >  Printers -> Queue -> Administration -> Set Default Options
> > >
> > 
> > Just piping up to say he was advised by Ken Sharp (as an initial
> > experimental move) to remove "setpagedevice" from the gs command line
> > here (after having metooed a bug that turned out being a different one
> > from the one from which he suffers):
> > 
> > https://bugs.ghostscript.com/show_bug.cgi?id=695873
> > 
> > Sorry if this is merely a distraction.
> 
> No need to be sorry; every little helps and it could certainly be an
> avenue for exploration. If the issue appears with a varied selection
> of files we could be looking at a defect in gstoraster's Ghostscript
> command.

I'll add that I set up a queue with

  lpadmin - p 1750 -v file:/dev/null -E -m drv:///splix-samsung.drv/ml1750.ppd

and printed the test page from the CUPS web interface. All filters
completed without any errors, as they do when cupsfilter was used with
any file I threw at it. Not much use in my testing the Ghostscript
command in that situation. The OP's experiences might be different, of
course.

-- 
Brian.

[toc] | [prev] | [next] | [standalone]


#194144

FromMENGUAL Jean-Philippe <mengualjeanphi@free.fr>
Date2018-03-25 11:40 +0200
Message-ID<vxai6-274-3@gated-at.bofh.it>
In reply to#193962
> 
> I'll add that I set up a queue with
> 
>   lpadmin - p 1750 -v file:/dev/null -E -m drv:///splix-samsung.drv/ml1750.ppd
> 
> and printed the test page from the CUPS web interface. All filters
> completed without any errors, as they do when cupsfilter was used with
> any file I threw at it. Not much use in my testing the Ghostscript
> command in that situation. The OP's experiences might be different, of
> course.


I did all this. On http://demo.accelibreinfo.eu/error_log you have my
newest log, job 74 and 75. Still not printing.

I add also that I think indeed it is a ghostscript problem, but changing
the commandline as suggested in the bug report is impossible for me as I
dont know how I could set cups to change the commandline it sends.

Thanks for any further help.

Best regards

[toc] | [prev] | [next] | [standalone]


#194152

FromBrian <ad44@cityscape.co.uk>
Date2018-03-25 19:10 +0200
Message-ID<vxhjA-6La-13@gated-at.bofh.it>
In reply to#194144
On Sun 25 Mar 2018 at 11:29:38 +0200, MENGUAL Jean-Philippe wrote:

> > I'll add that I set up a queue with
> > 
> >   lpadmin - p 1750 -v file:/dev/null -E -m drv:///splix-samsung.drv/ml1750.ppd
> > 
> > and printed the test page from the CUPS web interface. All filters
> > completed without any errors, as they do when cupsfilter was used with
> > any file I threw at it. Not much use in my testing the Ghostscript
> > command in that situation. The OP's experiences might be different, of
> > course.
> 
> 
> I did all this. On http://demo.accelibreinfo.eu/error_log you have my
> newest log, job 74 and 75. Still not printing.

Are we to assume you did the following?

1. Set up a queue as shown above. (There is no output because it goes to
   /dev/null).

2. Print to it with 'lp -d /etc/services'.

3. Examine the error_log. Four filters are used. Do any of them fail?

> I add also that I think indeed it is a ghostscript problem, but changing
> the commandline as suggested in the bug report is impossible for me as I
> dont know how I could set cups to change the commandline it sends.

Your three logs show gstoraster stopped, so spliX has no input from it
to render. We can test the ghostscript command without doing anything to
cups. The command is in your logs.

gs -dQUIET -dPARANOIDSAFER -dNOPAUSE -dBATCH -dNOINTERPOLATE \
   -dNOMEDIAATTRS -dShowAcroForm -sstdout=%stderr \
   -sOutputFile=%stdout \   <----- Replace %stdout with out.ras.
   -sDEVICE=cups -r600x600 -dMediaPosition=1 -dDEVICEWIDTHPOINTS=595 \
   -dDEVICEHEIGHTPOINTS=842 -dcupsBitsPerColor=1 -dcupsColorOrder=0 \
   -dcupsColorSpace=3 -dcupsCompression=17 -scupsPageSizeName=A4 \
   -I/usr/share/cups/fonts -c \
   input.pdf

I have removed the -c switch and its argument because the argument is
interpreted as PostScript code and we are not inputting PostScript.

I have also split the command to use short, readable lines; the "\"s
have to be omitted when it is put on a single line.

Before running the gs command we need an input.pdf which has been
processed by cups. Do this:

cupsfilter -p /etc/cups/ppd/Samsung.ppd -m application/vnd.cups-pdf /etc/services > input.pdf

Also use any other PDF on your machine as input.pdf.

'file out.ras' will identify out.ras as CUPS raster.

-- 
Brian.

[toc] | [prev] | [next] | [standalone]


#194159

FromMENGUAL Jean-Philippe <mengualjeanphi@free.fr>
Date2018-03-25 23:00 +0200
Message-ID<vxkU9-qI-9@gated-at.bofh.it>
In reply to#194152

Logo Hypra 	JEAN-PHILIPPE MENGUAL
DIRECTEUR TECHNIQUE ET QUALITÉ
102, rue des poissonniers, 75018, Paris
Tel : +331 84 73 06 61 <tel:+33184730661> Mob : +336 76 34 93 37
<tel:+33676349337>
jpmengual@hypra.fr <mailto:jpmengual@hypra.fr>
www.hypra.fr <http://www.hypra.fr/>
Facebook Hypra <https://www.facebook.com/hyprasoftware/> Twitter Hypra
<https://twitter.com/Hypra_> Linkedin Jean-Philippe
<https://fr.linkedin.com/in/jean-philippe-mengual-800133135>



Le 25/03/2018 à 19:05, Brian a écrit :
> On Sun 25 Mar 2018 at 11:29:38 +0200, MENGUAL Jean-Philippe wrote:
> 
>>> I'll add that I set up a queue with
>>>
>>>   lpadmin - p 1750 -v file:/dev/null -E -m drv:///splix-samsung.drv/ml1750.ppd
>>>
>>> and printed the test page from the CUPS web interface. All filters
>>> completed without any errors, as they do when cupsfilter was used with
>>> any file I threw at it. Not much use in my testing the Ghostscript
>>> command in that situation. The OP's experiences might be different, of
>>> course.
>>
>>
>> I did all this. On http://demo.accelibreinfo.eu/error_log you have my
>> newest log, job 74 and 75. Still not printing.
> 
> Are we to assume you did the following?
> 
> 1. Set up a queue as shown above. (There is no output because it goes to
>    /dev/null).

With lpadmin, yes. And in Printers - Queue - Default options.


> 2. Print to it with 'lp -d /etc/services'.

I tried to print a test page. If I do lp -d /etc/services, I get "no
such file or dir". If I add a pdf file (lp -d /etc/services file.pdf" or
"lp file.pdf -d /etc/services", I get a similar error message.


> 3. Examine the error_log. Four filters are used. Do any of them fail?

Logs dont seem to say another error than the initial mail I posted,
"COuld not find default_gray.icc", and "Cannot find device profile".
Just some lines later however, I have "gstoraster filter stopped" with
status 1. So I would say this filter fails.

>> I add also that I think indeed it is a ghostscript problem, but changing
>> the commandline as suggested in the bug report is impossible for me as I
>> dont know how I could set cups to change the commandline it sends.
> 
> Your three logs show gstoraster stopped, so spliX has no input from it
> to render. We can test the ghostscript command without doing anything to
> cups. The command is in your logs.
> 
> gs -dQUIET -dPARANOIDSAFER -dNOPAUSE -dBATCH -dNOINTERPOLATE \
>    -dNOMEDIAATTRS -dShowAcroForm -sstdout=%stderr \
>    -sOutputFile=%stdout \   <----- Replace %stdout with out.ras.

Not sure I understood: I did: -sOutputFile=out.ras \

>    -sDEVICE=cups -r600x600 -dMediaPosition=1 -dDEVICEWIDTHPOINTS=595 \
>    -dDEVICEHEIGHTPOINTS=842 -dcupsBitsPerColor=1 -dcupsColorOrder=0 \
>    -dcupsColorSpace=3 -dcupsCompression=17 -scupsPageSizeName=A4 \
>    -I/usr/share/cups/fonts -c \
>    input.pdf
> 
> I have removed the -c switch and its argument because the argument is
> interpreted as PostScript code and we are not inputting PostScript.
> 
> I have also split the command to use short, readable lines; the "\"s
> have to be omitted when it is put on a single line.
> 
> Before running the gs command we need an input.pdf which has been
> processed by cups. Do this:
> 
> cupsfilter -p /etc/cups/ppd/Samsung.ppd -m application/vnd.cups-pdf /etc/services > input.pdf

ok many thanks. input.pdf processing (first command) gives:
  ./base/gsicc_manage.c:1148: gsicc_open_search(): Could not find
default_gray.icc
| ./base/gsicc_manage.c:1799: gsicc_set_device_profile(): cannot find
device profile
Unrecoverable error: rangecheck in .putdeviceprops
Operand stack:
    true

> Also use any other PDF on your machine as input.pdf.

I get:
 ./base/gsicc_manage.c:1148: gsicc_open_search(): Could not find
default_gray.icc
| ./base/gsicc_manage.c:1799: gsicc_set_device_profile(): cannot find
device profile
Unrecoverable error: rangecheck in .putdeviceprops
Operand stack:
    true


That is wh I reported to ghoscript before asking here.

> 'file out.ras' will identify out.ras as CUPS raster


oh ok  I understand better.

Best regards and many thanks for your help for this complex problem.

[toc] | [prev] | [next] | [standalone]


#194162

FromBrian <ad44@cityscape.co.uk>
Date2018-03-26 01:20 +0200
Message-ID<vxn5D-2sw-7@gated-at.bofh.it>
In reply to#194159
On Sun 25 Mar 2018 at 22:51:25 +0200, MENGUAL Jean-Philippe wrote:

> Le 25/03/2018 à 19:05, Brian a écrit :
> > On Sun 25 Mar 2018 at 11:29:38 +0200, MENGUAL Jean-Philippe wrote:
> > 
> >>> I'll add that I set up a queue with
> >>>
> >>>   lpadmin - p 1750 -v file:/dev/null -E -m drv:///splix-samsung.drv/ml1750.ppd
> >>>
> >>> and printed the test page from the CUPS web interface. All filters
> >>> completed without any errors, as they do when cupsfilter was used with
> >>> any file I threw at it. Not much use in my testing the Ghostscript
> >>> command in that situation. The OP's experiences might be different, of
> >>> course.
> >>
> >>
> >> I did all this. On http://demo.accelibreinfo.eu/error_log you have my
> >> newest log, job 74 and 75. Still not printing.
> > 
> > Are we to assume you did the following?
> > 
> > 1. Set up a queue as shown above. (There is no output because it goes to
> >    /dev/null).
> 
> With lpadmin, yes. And in Printers - Queue - Default options.
> 
> 
> > 2. Print to it with 'lp -d /etc/services'.
> 
> I tried to print a test page. If I do lp -d /etc/services, I get "no
> such file or dir". If I add a pdf file (lp -d /etc/services file.pdf" or
> "lp file.pdf -d /etc/services", I get a similar error message.

Sometimes a respondent makes an error or a there is typo. Consulting the
lp manual might have helped you to sort it yourself.

 lp -d 1750 /etc/services

> > 3. Examine the error_log. Four filters are used. Do any of them fail?
> 
> Logs dont seem to say another error than the initial mail I posted,
> "COuld not find default_gray.icc", and "Cannot find device profile".
> Just some lines later however, I have "gstoraster filter stopped" with
> status 1. So I would say this filter fails.
> 
> >> I add also that I think indeed it is a ghostscript problem, but changing
> >> the commandline as suggested in the bug report is impossible for me as I
> >> dont know how I could set cups to change the commandline it sends.
> > 
> > Your three logs show gstoraster stopped, so spliX has no input from it
> > to render. We can test the ghostscript command without doing anything to
> > cups. The command is in your logs.
> > 
> > gs -dQUIET -dPARANOIDSAFER -dNOPAUSE -dBATCH -dNOINTERPOLATE \
> >    -dNOMEDIAATTRS -dShowAcroForm -sstdout=%stderr \
> >    -sOutputFile=%stdout \   <----- Replace %stdout with out.ras.
> 
> Not sure I understood: I did: -sOutputFile=out.ras \

That's ok.

> >    -sDEVICE=cups -r600x600 -dMediaPosition=1 -dDEVICEWIDTHPOINTS=595 \
> >    -dDEVICEHEIGHTPOINTS=842 -dcupsBitsPerColor=1 -dcupsColorOrder=0 \
> >    -dcupsColorSpace=3 -dcupsCompression=17 -scupsPageSizeName=A4 \
> >    -I/usr/share/cups/fonts -c \
> >    input.pdf
> > 
> > I have removed the -c switch and its argument because the argument is
> > interpreted as PostScript code and we are not inputting PostScript.
> > 
> > I have also split the command to use short, readable lines; the "\"s
> > have to be omitted when it is put on a single line.
> > 
> > Before running the gs command we need an input.pdf which has been
> > processed by cups. Do this:
> > 
> > cupsfilter -p /etc/cups/ppd/Samsung.ppd -m application/vnd.cups-pdf /etc/services > input.pdf
> 
> ok many thanks. input.pdf processing (first command) gives:
>   ./base/gsicc_manage.c:1148: gsicc_open_search(): Could not find
> default_gray.icc
> | ./base/gsicc_manage.c:1799: gsicc_set_device_profile(): cannot find
> device profile
> Unrecoverable error: rangecheck in .putdeviceprops
> Operand stack:
>     true
> 
> > Also use any other PDF on your machine as input.pdf.
> 
> I get:
>  ./base/gsicc_manage.c:1148: gsicc_open_search(): Could not find
> default_gray.icc
> | ./base/gsicc_manage.c:1799: gsicc_set_device_profile(): cannot find
> device profile
> Unrecoverable error: rangecheck in .putdeviceprops
> Operand stack:
>     true
> 
> 
> That is wh I reported to ghoscript before asking here.

And upstream at https://bugs.ghostscript.com/show_bug.cgi?id=695873 said:

 > The only way to tell for sure would be to try removing each
 > option until the problem goes away. You can do *that* from
 > the command shell yourself.

You have the command. Remove options one by one and report back.

-- 
Brian.

[toc] | [prev] | [next] | [standalone]


#194169

FromMENGUAL Jean-Philippe <mengualjeanphi@free.fr>
Date2018-03-26 06:00 +0200
Message-ID<vxrsB-5R8-1@gated-at.bofh.it>
In reply to#194162

Logo Hypra 	JEAN-PHILIPPE MENGUAL
DIRECTEUR TECHNIQUE ET QUALITÉ
102, rue des poissonniers, 75018, Paris
Tel : +331 84 73 06 61 <tel:+33184730661> Mob : +336 76 34 93 37
<tel:+33676349337>
jpmengual@hypra.fr <mailto:jpmengual@hypra.fr>
www.hypra.fr <http://www.hypra.fr/>
Facebook Hypra <https://www.facebook.com/hyprasoftware/> Twitter Hypra
<https://twitter.com/Hypra_> Linkedin Jean-Philippe
<https://fr.linkedin.com/in/jean-philippe-mengual-800133135>



Le 26/03/2018 à 01:17, Brian a écrit :
> On Sun 25 Mar 2018 at 22:51:25 +0200, MENGUAL Jean-Philippe wrote:
> 
>> Le 25/03/2018 à 19:05, Brian a écrit :
>>> On Sun 25 Mar 2018 at 11:29:38 +0200, MENGUAL Jean-Philippe wrote:
>>>
>>>>> I'll add that I set up a queue with
>>>>>
>>>>>   lpadmin - p 1750 -v file:/dev/null -E -m drv:///splix-samsung.drv/ml1750.ppd
>>>>>
>>>>> and printed the test page from the CUPS web interface. All filters
>>>>> completed without any errors, as they do when cupsfilter was used with
>>>>> any file I threw at it. Not much use in my testing the Ghostscript
>>>>> command in that situation. The OP's experiences might be different, of
>>>>> course.
>>>>
>>>>
>>>> I did all this. On http://demo.accelibreinfo.eu/error_log you have my
>>>> newest log, job 74 and 75. Still not printing.
>>>
>>> Are we to assume you did the following?
>>>
>>> 1. Set up a queue as shown above. (There is no output because it goes to
>>>    /dev/null).
>>
>> With lpadmin, yes. And in Printers - Queue - Default options.
>>
>>
>>> 2. Print to it with 'lp -d /etc/services'.
>>
>> I tried to print a test page. If I do lp -d /etc/services, I get "no
>> such file or dir". If I add a pdf file (lp -d /etc/services file.pdf" or
>> "lp file.pdf -d /etc/services", I get a similar error message.
> 
> Sometimes a respondent makes an error or a there is typo. Consulting the
> lp manual might have helped you to sort it yourself.
> 
>  lp -d 1750 /etc/services

Ok thank. Sorry I did not look at the man as I am very confused with the
complexity of Cups commands as the problem requires advanced commands.
So in the global stream, I lack of knowledge sometimes. :) Anyway, the
command gives the same result. Log is up-to-date on
http://demo.accelibreinfo.eu/error_log



>>> 3. Examine the error_log. Four filters are used. Do any of them fail?
>>
>> Logs dont seem to say another error than the initial mail I posted,
>> "COuld not find default_gray.icc", and "Cannot find device profile".
>> Just some lines later however, I have "gstoraster filter stopped" with
>> status 1. So I would say this filter fails.
>>
>>>> I add also that I think indeed it is a ghostscript problem, but changing
>>>> the commandline as suggested in the bug report is impossible for me as I
>>>> dont know how I could set cups to change the commandline it sends.
>>>
>>> Your three logs show gstoraster stopped, so spliX has no input from it
>>> to render. We can test the ghostscript command without doing anything to
>>> cups. The command is in your logs.
>>>
>>> gs -dQUIET -dPARANOIDSAFER -dNOPAUSE -dBATCH -dNOINTERPOLATE \
>>>    -dNOMEDIAATTRS -dShowAcroForm -sstdout=%stderr \
>>>    -sOutputFile=%stdout \   <----- Replace %stdout with out.ras.
>>
>> Not sure I understood: I did: -sOutputFile=out.ras \
> 
> That's ok.
> 
>>>    -sDEVICE=cups -r600x600 -dMediaPosition=1 -dDEVICEWIDTHPOINTS=595 \
>>>    -dDEVICEHEIGHTPOINTS=842 -dcupsBitsPerColor=1 -dcupsColorOrder=0 \
>>>    -dcupsColorSpace=3 -dcupsCompression=17 -scupsPageSizeName=A4 \
>>>    -I/usr/share/cups/fonts -c \
>>>    input.pdf
>>>
>>> I have removed the -c switch and its argument because the argument is
>>> interpreted as PostScript code and we are not inputting PostScript.
>>>
>>> I have also split the command to use short, readable lines; the "\"s
>>> have to be omitted when it is put on a single line.
>>>
>>> Before running the gs command we need an input.pdf which has been
>>> processed by cups. Do this:
>>>
>>> cupsfilter -p /etc/cups/ppd/Samsung.ppd -m application/vnd.cups-pdf /etc/services > input.pdf
>>
>> ok many thanks. input.pdf processing (first command) gives:
>>   ./base/gsicc_manage.c:1148: gsicc_open_search(): Could not find
>> default_gray.icc
>> | ./base/gsicc_manage.c:1799: gsicc_set_device_profile(): cannot find
>> device profile
>> Unrecoverable error: rangecheck in .putdeviceprops
>> Operand stack:
>>     true
>>
>>> Also use any other PDF on your machine as input.pdf.
>>
>> I get:
>>  ./base/gsicc_manage.c:1148: gsicc_open_search(): Could not find
>> default_gray.icc
>> | ./base/gsicc_manage.c:1799: gsicc_set_device_profile(): cannot find
>> device profile
>> Unrecoverable error: rangecheck in .putdeviceprops
>> Operand stack:
>>     true
>>
>>
>> That is wh I reported to ghoscript before asking here.
> 
> And upstream at https://bugs.ghostscript.com/show_bug.cgi?id=695873 said:
> 
>  > The only way to tell for sure would be to try removing each
>  > option until the problem goes away. You can do *that* from
>  > the command shell yourself.
> 
> You have the command. Remove options one by one and report back.

ok thanks very much. You gave me essential things to go on while I was
lost.

I go on with the bugreport, as even without option, the problem is still
there. I let you informed when I get improvements with upstream.

Regards

[toc] | [prev] | [next] | [standalone]


#194204

FromMENGUAL Jean-Philippe <mengualjeanphi@free.fr>
Date2018-03-27 10:40 +0200
Message-ID<vxSj8-1qD-7@gated-at.bofh.it>
In reply to#194169

[Multipart message — attachments visible in raw view] — view raw

Hi,

Ok now I am completely blocked. It results from the thread on the
bugreport that:
- I tried all I was advised, it does not work
- The upstream devs explain Debian is responsible
- No answer from Debian Printing team.

Well, I am out of idea and, as often, people upstream explain it is
Debian :D Not easy to hope fixing easily such problems.

Thanks very much for your further help.

Best regards,

signature_jp_2
Logo Hypra 	JEAN-PHILIPPE MENGUAL
DIRECTEUR TECHNIQUE ET QUALITÉ
102, rue des poissonniers, 75018, Paris
Tel : +331 84 73 06 61 <tel:+33184730661> Mob : +336 76 34 93 37
<tel:+33676349337>
jpmengual@hypra.fr <mailto:jpmengual@hypra.fr>
www.hypra.fr <http://www.hypra.fr/>
Facebook Hypra <https://www.facebook.com/hyprasoftware/> Twitter Hypra
<https://twitter.com/Hypra_> Linkedin Jean-Philippe
<https://fr.linkedin.com/in/jean-philippe-mengual-800133135>


Le 26/03/2018 à 05:51, MENGUAL Jean-Philippe a écrit :
>
> Logo Hypra 	JEAN-PHILIPPE MENGUAL
> DIRECTEUR TECHNIQUE ET QUALITÉ
> 102, rue des poissonniers, 75018, Paris
> Tel : +331 84 73 06 61 <tel:+33184730661> Mob : +336 76 34 93 37
> <tel:+33676349337>
> jpmengual@hypra.fr <mailto:jpmengual@hypra.fr>
> www.hypra.fr <http://www.hypra.fr/>
> Facebook Hypra <https://www.facebook.com/hyprasoftware/> Twitter Hypra
> <https://twitter.com/Hypra_> Linkedin Jean-Philippe
> <https://fr.linkedin.com/in/jean-philippe-mengual-800133135>
>
>
>
> Le 26/03/2018 à 01:17, Brian a écrit :
>> On Sun 25 Mar 2018 at 22:51:25 +0200, MENGUAL Jean-Philippe wrote:
>>
>>> Le 25/03/2018 à 19:05, Brian a écrit :
>>>> On Sun 25 Mar 2018 at 11:29:38 +0200, MENGUAL Jean-Philippe wrote:
>>>>
>>>>>> I'll add that I set up a queue with
>>>>>>
>>>>>>   lpadmin - p 1750 -v file:/dev/null -E -m drv:///splix-samsung.drv/ml1750.ppd
>>>>>>
>>>>>> and printed the test page from the CUPS web interface. All filters
>>>>>> completed without any errors, as they do when cupsfilter was used with
>>>>>> any file I threw at it. Not much use in my testing the Ghostscript
>>>>>> command in that situation. The OP's experiences might be different, of
>>>>>> course.
>>>>>
>>>>> I did all this. On http://demo.accelibreinfo.eu/error_log you have my
>>>>> newest log, job 74 and 75. Still not printing.
>>>> Are we to assume you did the following?
>>>>
>>>> 1. Set up a queue as shown above. (There is no output because it goes to
>>>>    /dev/null).
>>> With lpadmin, yes. And in Printers - Queue - Default options.
>>>
>>>
>>>> 2. Print to it with 'lp -d /etc/services'.
>>> I tried to print a test page. If I do lp -d /etc/services, I get "no
>>> such file or dir". If I add a pdf file (lp -d /etc/services file.pdf" or
>>> "lp file.pdf -d /etc/services", I get a similar error message.
>> Sometimes a respondent makes an error or a there is typo. Consulting the
>> lp manual might have helped you to sort it yourself.
>>
>>  lp -d 1750 /etc/services
> Ok thank. Sorry I did not look at the man as I am very confused with the
> complexity of Cups commands as the problem requires advanced commands.
> So in the global stream, I lack of knowledge sometimes. :) Anyway, the
> command gives the same result. Log is up-to-date on
> http://demo.accelibreinfo.eu/error_log
>
>
>
>>>> 3. Examine the error_log. Four filters are used. Do any of them fail?
>>> Logs dont seem to say another error than the initial mail I posted,
>>> "COuld not find default_gray.icc", and "Cannot find device profile".
>>> Just some lines later however, I have "gstoraster filter stopped" with
>>> status 1. So I would say this filter fails.
>>>
>>>>> I add also that I think indeed it is a ghostscript problem, but changing
>>>>> the commandline as suggested in the bug report is impossible for me as I
>>>>> dont know how I could set cups to change the commandline it sends.
>>>> Your three logs show gstoraster stopped, so spliX has no input from it
>>>> to render. We can test the ghostscript command without doing anything to
>>>> cups. The command is in your logs.
>>>>
>>>> gs -dQUIET -dPARANOIDSAFER -dNOPAUSE -dBATCH -dNOINTERPOLATE \
>>>>    -dNOMEDIAATTRS -dShowAcroForm -sstdout=%stderr \
>>>>    -sOutputFile=%stdout \   <----- Replace %stdout with out.ras.
>>> Not sure I understood: I did: -sOutputFile=out.ras \
>> That's ok.
>>
>>>>    -sDEVICE=cups -r600x600 -dMediaPosition=1 -dDEVICEWIDTHPOINTS=595 \
>>>>    -dDEVICEHEIGHTPOINTS=842 -dcupsBitsPerColor=1 -dcupsColorOrder=0 \
>>>>    -dcupsColorSpace=3 -dcupsCompression=17 -scupsPageSizeName=A4 \
>>>>    -I/usr/share/cups/fonts -c \
>>>>    input.pdf
>>>>
>>>> I have removed the -c switch and its argument because the argument is
>>>> interpreted as PostScript code and we are not inputting PostScript.
>>>>
>>>> I have also split the command to use short, readable lines; the "\"s
>>>> have to be omitted when it is put on a single line.
>>>>
>>>> Before running the gs command we need an input.pdf which has been
>>>> processed by cups. Do this:
>>>>
>>>> cupsfilter -p /etc/cups/ppd/Samsung.ppd -m application/vnd.cups-pdf /etc/services > input.pdf
>>> ok many thanks. input.pdf processing (first command) gives:
>>>   ./base/gsicc_manage.c:1148: gsicc_open_search(): Could not find
>>> default_gray.icc
>>> | ./base/gsicc_manage.c:1799: gsicc_set_device_profile(): cannot find
>>> device profile
>>> Unrecoverable error: rangecheck in .putdeviceprops
>>> Operand stack:
>>>     true
>>>
>>>> Also use any other PDF on your machine as input.pdf.
>>> I get:
>>>  ./base/gsicc_manage.c:1148: gsicc_open_search(): Could not find
>>> default_gray.icc
>>> | ./base/gsicc_manage.c:1799: gsicc_set_device_profile(): cannot find
>>> device profile
>>> Unrecoverable error: rangecheck in .putdeviceprops
>>> Operand stack:
>>>     true
>>>
>>>
>>> That is wh I reported to ghoscript before asking here.
>> And upstream at https://bugs.ghostscript.com/show_bug.cgi?id=695873 said:
>>
>>  > The only way to tell for sure would be to try removing each
>>  > option until the problem goes away. You can do *that* from
>>  > the command shell yourself.
>>
>> You have the command. Remove options one by one and report back.
> ok thanks very much. You gave me essential things to go on while I was
> lost.
>
> I go on with the bugreport, as even without option, the problem is still
> there. I let you informed when I get improvements with upstream.
>
> Regards

[toc] | [prev] | [next] | [standalone]


#194207

FromBrian <ad44@cityscape.co.uk>
Date2018-03-27 12:40 +0200
Message-ID<vxUbg-2F3-25@gated-at.bofh.it>
In reply to#194204
On Tue 27 Mar 2018 at 10:28:29 +0200, MENGUAL Jean-Philippe wrote:

> Ok now I am completely blocked. It results from the thread on the
> bugreport that:
> - I tried all I was advised, it does not work
> - The upstream devs explain Debian is responsible
> - No answer from Debian Printing team.

Your initial report was responded to on Sat 24 Mar 2018 and you were
cc'ed. I'd advise that you update the report with details on what you
have tried and how it turned out.

Fwiw, the command provided to you by upstream:

  gs -sDEVICE=tiff24nc -sOutputFile=out.tif input.pdf

runs without error here on unstable.

-- 
Brian.

[toc] | [prev] | [next] | [standalone]


#194143

FromMENGUAL Jean-Philippe <mengualjeanphi@free.fr>
Date2018-03-25 11:30 +0200
Message-ID<vxa8p-21J-1@gated-at.bofh.it>
In reply to#193910
>>>  Printers -> Queue -> Administration -> Set Default Options

SRT is set to normal and the problem still appears. I disabled colord
service, and tried again the job. Not result.

>>>
>>
>> Just piping up to say he was advised by Ken Sharp (as an initial
>> experimental move) to remove "setpagedevice" from the gs command line
>> here (after having metooed a bug that turned out being a different one
>> from the one from which he suffers):
>>
>> https://bugs.ghostscript.com/show_bug.cgi?id=695873
>>
>> Sorry if this is merely a distraction.

Sorry I han not mentioned this as I was said it was nothing to do with
the initial bugreport, and I had not understood at all explanations.

> No need to be sorry; every little helps and it could certainly be an
> avenue for exploration. If the issue appears with a varied selection
> of files we could be looking at a defect in gstoraster's Ghostscript
> command.

So far it appears with allf iles I submitted, even in cups-filter from
your suggested command.

> 

[toc] | [prev] | [next] | [standalone]


#193908

Fromsongbird <songbird@anthive.com>
Date2018-03-19 16:10 +0100
Message-ID<vv4A9-8aE-1@gated-at.bofh.it>
In reply to#193892
MENGUAL Jean-Philippe wrote:
...
> Hi,
>
> For some time on Buster, I no longer can print on any printer, in
> particular my Samsung ML1750. If I check the attached log, it seems
> however that it is not related to the printer, but rather filters. The
> job is 71. Lines 3455 and so on are interesting I think.
>
> Attached file: http://demo.accelibreinfo.eu/error_log
>
> Would you have an idea about the pb? What could I do to fix it?
> Many thanks for help

  first thing i would try is to completely purge/remove
cups and reinstall to make sure i had all the required
parts.  then i would set up the printer and try a
test page.

  since you didn't say what you had tried already...


  songbird

[toc] | [prev] | [next] | [standalone]


#194142

FromMENGUAL Jean-Philippe <mengualjeanphi@free.fr>
Date2018-03-25 11:20 +0200
Message-ID<vx9YJ-1Wb-7@gated-at.bofh.it>
In reply to#193908
Hi guys and thanks for your feedbacks

Le 19/03/2018 à 15:53, songbird a écrit :
> MENGUAL Jean-Philippe wrote:
> ...
>> Hi,
>>
>> For some time on Buster, I no longer can print on any printer, in
>> particular my Samsung ML1750. If I check the attached log, it seems
>> however that it is not related to the printer, but rather filters. The
>> job is 71. Lines 3455 and so on are interesting I think.
>>
>> Attached file: http://demo.accelibreinfo.eu/error_log
>>
>> Would you have an idea about the pb? What could I do to fix it?
>> Many thanks for help
> 
>   first thing i would try is to completely purge/remove
> cups and reinstall to make sure i had all the required
> parts.  then i would set up the printer and try a

I unistalled via tasksel, then apt remove --purge all cups packages and
printer-* packages. However I need to say that the configuration wan not
purged, then I found my printer immediately after I re-installed cups.

> test page.

I did after I removed and reinstalled the printer. No result.

> 
>   since you didn't say what you had tried already...

I had not tried as logs seemed to show another problem.

Regards

> 
>   songbird
> 
> 

[toc] | [prev] | [standalone]


Back to top | Article view | linux.debian.user


csiph-web