Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.user > #193252 > unrolled thread
| Started by | Marc Auslander <marcslists@gmail.com> |
|---|---|
| First post | 2018-03-01 15:20 +0100 |
| Last post | 2018-03-02 11:20 +0100 |
| Articles | 4 — 3 participants |
Back to article view | Back to linux.debian.user
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: Using apcupsd for power failure controle Marc Auslander <marcslists@gmail.com> - 2018-03-01 15:20 +0100
Re: Using apcupsd for power failure controle Richard Hector <richard@walnut.gen.nz> - 2018-03-02 03:30 +0100
Re: Using apcupsd for power failure controle deloptes <deloptes@gmail.com> - 2018-03-02 09:10 +0100
Re: Using apcupsd for power failure controle deloptes <deloptes@gmail.com> - 2018-03-02 11:20 +0100
| From | Marc Auslander <marcslists@gmail.com> |
|---|---|
| Date | 2018-03-01 15:20 +0100 |
| Subject | Re: Using apcupsd for power failure controle |
| Message-ID | <voxdU-4TA-1@gated-at.bofh.it> |
(Was Were is gapcmon?) >> >> I've always use apcupsd which still works in stretch. My use is pretty >> trivial - just reports - I don't do anything automatic on power fail >> since I can't figure out how to do anything that will always wind up >> with my machine running when the power comes back! > >I think you can usually set the power-on behaviour in the BIOS (or EFI, >presumably) - independently of the OS or any shutdown process. > >Richard So here's the issue - maybe I'm missing something. If I configure apcupsd to shutdown on power fail and the power really stays off till the apc unit shut down, my machine will reboot on power up. But what if the power comes back once the daemon has started the shutdown? What is needed is a guaranteed power cycle from the apc unit - which AFAIK is not an option. So I just use the apc to cover short outages and prevent power bouncing which I know from experience can cause damage. When the battery goes flat I get a hard powerfail shutdown which modern linux tollerates quite well - yeah for journaled file systems. Marc Auslander
[toc] | [next] | [standalone]
| From | Richard Hector <richard@walnut.gen.nz> |
|---|---|
| Date | 2018-03-02 03:30 +0100 |
| Message-ID | <voICq-4FN-5@gated-at.bofh.it> |
| In reply to | #193252 |
[Multipart message — attachments visible in raw view] — view raw
On 02/03/18 03:09, Marc Auslander wrote: >> I think you can usually set the power-on behaviour in the BIOS (or EFI, >> presumably) - independently of the OS or any shutdown process. >> >> Richard > So here's the issue - maybe I'm missing something. > > If I configure apcupsd to shutdown on power fail and the power really > stays off till the apc unit shut down, my machine will reboot on power > up. But what if the power comes back once the daemon has started the > shutdown? > > What is needed is a guaranteed power cycle from the apc unit - which > AFAIK is not an option. Interesting point. I confess I've never set up a ups for all this before, but I've read about it ... I'm pretty sure you can instruct the ups to shut down, but I don't know whether you can tell it to come back as soon as the power is stable (possibly immediately). I guess you could go more extreme, and have the ups controlled by something else, like a battery-powered Raspberry Pi ... does the ups listen for instructions in its 'down' state? Richard
[toc] | [prev] | [next] | [standalone]
| From | deloptes <deloptes@gmail.com> |
|---|---|
| Date | 2018-03-02 09:10 +0100 |
| Message-ID | <voNVn-8jV-1@gated-at.bofh.it> |
| In reply to | #193265 |
Richard Hector wrote: > I confess I've never set up a ups for all this before, but I've read > about it ... I'm pretty sure you can instruct the ups to shut down, but > I don't know whether you can tell it to come back as soon as the power > is stable (possibly immediately). perhaps no, but I have seen an option in many bioses to power on on network activity
[toc] | [prev] | [next] | [standalone]
| From | deloptes <deloptes@gmail.com> |
|---|---|
| Date | 2018-03-02 11:20 +0100 |
| Message-ID | <voPXc-1cM-1@gated-at.bofh.it> |
| In reply to | #193265 |
Richard Hector wrote: > On 02/03/18 03:09, Marc Auslander wrote: >>> I think you can usually set the power-on behaviour in the BIOS (or EFI, >>> presumably) - independently of the OS or any shutdown process. >>> >>> Richard >> So here's the issue - maybe I'm missing something. >> >> If I configure apcupsd to shutdown on power fail and the power really >> stays off till the apc unit shut down, my machine will reboot on power >> up. But what if the power comes back once the daemon has started the >> shutdown? >> >> What is needed is a guaranteed power cycle from the apc unit - which >> AFAIK is not an option. > > Interesting point. > > I confess I've never set up a ups for all this before, but I've read > about it ... I'm pretty sure you can instruct the ups to shut down, but > I don't know whether you can tell it to come back as soon as the power > is stable (possibly immediately). > > I guess you could go more extreme, and have the ups controlled by > something else, like a battery-powered Raspberry Pi ... does the ups > listen for instructions in its 'down' state? > > Richard This seems to be a common use case but depends on server (bios) and UPS make/model https://serverfault.com/questions/617762/automatic-power-on-after-graceful-shutdown-on-ups http://www.apc.com/us/en/faqs/FA244868/ I just checked our setup here and it is to toggle the option "Power On after Power Fail" in the BIOS. This brings the server back when power is on only if power fail was registered. I am not sure if there is a setting to stop the shut down process if meanwhile power is back. regards
[toc] | [prev] | [standalone]
Back to top | Article view | linux.debian.user
csiph-web