Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.user > #193274

Re: Using apcupsd for power failure controle

From deloptes <deloptes@gmail.com>
Newsgroups linux.debian.user
Subject Re: Using apcupsd for power failure controle
Date 2018-03-02 11:20 +0100
Message-ID <voPXc-1cM-1@gated-at.bofh.it> (permalink)
References <voxdU-4TA-3@gated-at.bofh.it> <voxdU-4TA-5@gated-at.bofh.it> <voxdU-4TA-7@gated-at.bofh.it> <voxdU-4TA-1@gated-at.bofh.it> <voICq-4FN-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Richard Hector wrote:

> On 02/03/18 03:09, Marc Auslander wrote:
>>> I think you can usually set the power-on behaviour in the BIOS (or EFI,
>>> presumably) - independently of the OS or any shutdown process.
>>>
>>> Richard
>> So here's the issue - maybe I'm missing something.
>> 
>> If I configure apcupsd to shutdown on power fail and the power really
>> stays off till the apc unit shut down, my machine will reboot on power
>> up.  But what if the power comes back once the daemon has started the
>> shutdown?
>> 
>> What is needed is a guaranteed power cycle from the apc unit - which
>> AFAIK is not an option.
> 
> Interesting point.
> 
> I confess I've never set up a ups for all this before, but I've read
> about it ... I'm pretty sure you can instruct the ups to shut down, but
> I don't know whether you can tell it to come back as soon as the power
> is stable (possibly immediately).
> 
> I guess you could go more extreme, and have the ups controlled by
> something else, like a battery-powered Raspberry Pi ... does the ups
> listen for instructions in its 'down' state?
> 
> Richard

This seems to be a common use case but depends on server (bios) and UPS
make/model

https://serverfault.com/questions/617762/automatic-power-on-after-graceful-shutdown-on-ups
http://www.apc.com/us/en/faqs/FA244868/

I just checked our setup here and it is to toggle the option "Power On after
Power Fail" in the BIOS. This brings the server back when power is on only
if power fail was registered. 
I am not sure if there is a setting to stop the shut down process if
meanwhile power is back. 

regards

Back to linux.debian.user | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

Re: Using apcupsd for power failure controle Marc Auslander <marcslists@gmail.com> - 2018-03-01 15:20 +0100
  Re: Using apcupsd for power failure controle Richard Hector <richard@walnut.gen.nz> - 2018-03-02 03:30 +0100
    Re: Using apcupsd for power failure controle deloptes <deloptes@gmail.com> - 2018-03-02 09:10 +0100
    Re: Using apcupsd for power failure controle deloptes <deloptes@gmail.com> - 2018-03-02 11:20 +0100

csiph-web