Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.maint.python > #13941 > unrolled thread

Bug#1005303: ITP: python-rfc3987 -- Parsing and validation of URIs (RFC 3896) and IRIs (RFC 3987)

Started byRomain Porte <debian@microjoe.org>
First post2022-02-10 22:10 +0100
Last post2022-02-10 22:10 +0100
Articles 1 — 1 participant

Back to article view | Back to linux.debian.maint.python


Contents

  Bug#1005303: ITP: python-rfc3987 -- Parsing and validation of URIs (RFC 3896) and IRIs (RFC 3987) Romain Porte <debian@microjoe.org> - 2022-02-10 22:10 +0100

#13941 — Bug#1005303: ITP: python-rfc3987 -- Parsing and validation of URIs (RFC 3896) and IRIs (RFC 3987)

FromRomain Porte <debian@microjoe.org>
Date2022-02-10 22:10 +0100
SubjectBug#1005303: ITP: python-rfc3987 -- Parsing and validation of URIs (RFC 3896) and IRIs (RFC 3987)
Message-ID<DPoRr-W5X-1@gated-at.bofh.it>
Package: wnpp
Severity: wishlist
Owner: Agathe Porte <debian@microjoe.org>
X-Debbugs-Cc: debian-devel@lists.debian.org, debian-python@lists.debian.org, debian@microjoe.org

* Package name    : python-rfc3987
  Version         : 1.3.8
  Upstream Author : Daniel Gerber <daniel.g.gerber@gmail.com>
* URL             : https://pypi.org/project/rfc3987/
* License         : GPL-3+
  Programming Lang: Python
  Description     : Parsing and validation of URIs (RFC 3896) and IRIs (RFC 3987)

This module provides regular expressions according to RFC 3986 “Uniform
Resource Identifier (URI): Generic Syntax” and RFC 3987
“Internationalized Resource Identifiers (IRIs)”, and utilities for
composition and relative resolution of references.

This module is introduced as a dependency for python-dt-schema. I intent
to maintain this package under the umbrella of the Debian Python Team.

[toc] | [standalone]


Back to top | Article view | linux.debian.maint.python


csiph-web