Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.maint.python > #12994 > unrolled thread
| Started by | Otto Kekäläinen <otto@debian.org> |
|---|---|
| First post | 2020-11-01 18:40 +0100 |
| Last post | 2020-11-01 20:10 +0100 |
| Articles | 4 — 4 participants |
Back to article view | Back to linux.debian.maint.python
Package naming advice: python3-pyls-jsonrpc or python3-jsonrpc-server? Otto Kekäläinen <otto@debian.org> - 2020-11-01 18:40 +0100
Re: Package naming advice: python3-pyls-jsonrpc or python3-jsonrpc-server? Jochen Sprickerhof <jspricke@debian.org> - 2020-11-01 19:00 +0100
Re: Package naming advice: python3-pyls-jsonrpc or python3-jsonrpc-server? Simon McVittie <smcv@debian.org> - 2020-11-01 19:40 +0100
Re: Package naming advice: python3-pyls-jsonrpc or python3-jsonrpc-server? Otto Kekäläinen <otto@seravo.fi> - 2020-11-01 20:10 +0100
| From | Otto Kekäläinen <otto@debian.org> |
|---|---|
| Date | 2020-11-01 18:40 +0100 |
| Subject | Package naming advice: python3-pyls-jsonrpc or python3-jsonrpc-server? |
| Message-ID | <B6puF-13o-5@gated-at.bofh.it> |
Hello! I am currently reviewing the Debian packaging at https://salsa.debian.org/python-team/packages/python-jsonrpc-server of the upstream project https://github.com/palantir/python-jsonrpc-server Upstream uses 'python-jsonrpc-server' as the repository and also the pip package name. Should we follow that in Debian or perhaps use the alternative name 'python3-pyls-jsonrpc'? Is there some existing naming convention/policy about Python modules of this sort? - Otto
[toc] | [next] | [standalone]
| From | Jochen Sprickerhof <jspricke@debian.org> |
|---|---|
| Date | 2020-11-01 19:00 +0100 |
| Subject | Re: Package naming advice: python3-pyls-jsonrpc or python3-jsonrpc-server? |
| Message-ID | <B6pO2-1a9-3@gated-at.bofh.it> |
| In reply to | #12994 |
[Multipart message — attachments visible in raw view] — view raw
Hi Otto, * Otto Kekäläinen <otto@debian.org> [2020-11-01 19:36]: >Upstream uses 'python-jsonrpc-server' as the repository and also the >pip package name. Should we follow that in Debian or perhaps use the >alternative name 'python3-pyls-jsonrpc'? > >Is there some existing naming convention/policy about Python modules >of this sort? https://www.debian.org/doc/packaging-manuals/python-policy/module_packages.html#package_names So python3-pyls-jsonrpc for the binary package is correct. Cheers Jochen
[toc] | [prev] | [next] | [standalone]
| From | Simon McVittie <smcv@debian.org> |
|---|---|
| Date | 2020-11-01 19:40 +0100 |
| Subject | Re: Package naming advice: python3-pyls-jsonrpc or python3-jsonrpc-server? |
| Message-ID | <B6qqK-1Cc-9@gated-at.bofh.it> |
| In reply to | #12994 |
On Sun, 01 Nov 2020 at 19:36:52 +0200, Otto Kekäläinen wrote:
> I am currently reviewing the Debian packaging at
> https://salsa.debian.org/python-team/packages/python-jsonrpc-server of
> the upstream project https://github.com/palantir/python-jsonrpc-server
>
> Upstream uses 'python-jsonrpc-server' as the repository and also the
> pip package name. Should we follow that in Debian or perhaps use the
> alternative name 'python3-pyls-jsonrpc'?
>
> Is there some existing naming convention/policy about Python modules
> of this sort?
When you say "follow that", do you mean for the Debian source package
name (.dsc, like dbus-python), or for the Debian binary package name
(.deb, like python3-dbus)?
The binary package name should be mechanically derived from what you
import. If you 'import pyls_jsonrpc', then python3-pyls-jsonrpc is right.
If you 'import pyls.jsonrpc', then python3-pyls.jsonrpc, and so on.
The source package name is less important, and could either resemble the
binary package name or match what upstream calls it.
smcv
[toc] | [prev] | [next] | [standalone]
| From | Otto Kekäläinen <otto@seravo.fi> |
|---|---|
| Date | 2020-11-01 20:10 +0100 |
| Message-ID | <B6qTN-26f-25@gated-at.bofh.it> |
| In reply to | #12997 |
Hi! > When you say "follow that", do you mean for the Debian source package > name (.dsc, like dbus-python), or for the Debian binary package name > (.deb, like python3-dbus)? We'll go with 'python3-pyls-jsonrpc' for the binary package. > The binary package name should be mechanically derived from what you > import. If you 'import pyls_jsonrpc', then python3-pyls-jsonrpc is right. > If you 'import pyls.jsonrpc', then python3-pyls.jsonrpc, and so on. We plan to keep the source package name and repository name as 'python-jsonrpc-server' to follow upstream. Thanks for all your help!
[toc] | [prev] | [standalone]
Back to top | Article view | linux.debian.maint.python
csiph-web