Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.kernel > #86864 > unrolled thread

Bug#1102914: VMs don't start up when being passed through a PCI device

Started byBernd Rinn <bb@rinn.ch>
First post2025-04-13 09:10 +0200
Last post2025-04-15 17:40 +0200
Articles 3 — 3 participants

Back to article view | Back to linux.debian.kernel


Contents

  Bug#1102914: VMs don't start up when being passed through a PCI device Bernd Rinn <bb@rinn.ch> - 2025-04-13 09:10 +0200
    Bug#1102914:  Salvatore Bonaccorso <carnil@debian.org> - 2025-04-14 21:10 +0200
    Processed: Re: Bug#1102889: linux-image-6.1.0-33-amd64: KVM GPU  passthrough broken "Debian Bug Tracking System" <owner@bugs.debian.org> - 2025-04-15 17:40 +0200

#86864 — Bug#1102914: VMs don't start up when being passed through a PCI device

FromBernd Rinn <bb@rinn.ch>
Date2025-04-13 09:10 +0200
SubjectBug#1102914: VMs don't start up when being passed through a PCI device
Message-ID<KAZDz-dazz-3@gated-at.bofh.it>
Package: linux-image-amd64
Version: 6.1.133-1

Description:
I noticed a regression with the most recent kernel 6.1.0-33 (6.1.133) of Debian Bookworm:
libvirtd VMs don't start up anymore when they are being passed through a PCI device (in my case the 
PCI device is a network card). The error message is:

"""
Apr 13 07:35:08 noc libvirtd\[4984\]: libvirt version: 9.0.0, package: 9.0.0-4+deb12u2 (Debian)
Apr 13 07:35:08 xyz libvirtd\[4984\]: hostname: xyz
Apr 13 07:35:08 xyz libvirtd\[4984\]: Unable to read from monitor: Connection reset by peer
Apr 13 07:35:08 xyz libvirtd\[4984\]: internal error: qemu unexpectedly closed the monitor: 
2025-04-13T05:35:08.436709Z qemu-system-x86_64: -device 
{"driver":"vfio-pci","host":"0000:05:00.0","id":"hostdev0","bus":"
pci.8","addr":"0x0"}: VFIO_MAP_DMA failed: Cannot allocate memory
2025-04-13T05:35:08.447462Z qemu-system-x86_64: -device 
{"driver":"vfio-pci","host":"0000:05:00.0","id":"hostdev0","bus":"pci.8","addr":"0x0"}: vfio 
0000:05:00.0: failed to set
"""

The definition of the PCI device pass through looks like this:

"""
<hostdev mode="subsystem" type="pci" managed="yes">
<driver name="vfio"/>
<source>
<address domain="0x0000" bus="0x05" slot="0x00" function="0x0"/>
</source>
<alias name="hostdev0"/>
<address type="pci" domain="0x0000" bus="0x08" slot="0x00" function="0x0"/>
</hostdev>
"""

When reverting the kernel back to previous version 6.1.0-32 (6.1.129), the VM boots up OK, i.e. the 
error is gone.

[toc] | [next] | [standalone]


#86894 — Bug#1102914:

FromSalvatore Bonaccorso <carnil@debian.org>
Date2025-04-14 21:10 +0200
SubjectBug#1102914:
Message-ID<KBxlT-dwsP-5@gated-at.bofh.it>
In reply to#86864
Hi,

On Mon, Apr 14, 2025 at 02:01:07PM +0200, Milan Broz wrote:
> Hi,
> 
> we have the same issue with 6.1.133-1 (previous 6.1.129-1 works fine).
> 
> We use passthrough of NVMe device, VM start now fails with
> 
> qemu-system-x86_64: -device {"driver":"vfio-pci","host":"0000:03:00.0","id":"hostdev0","bus":"pci.3","addr":"0x0"}: VFIO_MAP_DMA failed: Cannot allocate memory
> qemu-system-x86_64: -device {"driver":"vfio-pci","host":"0000:03:00.0","id":"hostdev0","bus":"pci.3","addr":"0x0"}: vfio 0000:03:00.0: failed to setup container
> 
> I cannot easily do bisect on this machine, but if you have problem to reproduce it, I can probably try to setup other machine and run upstream bisect there.
> 
> Anyway, I think this is a major regression.

As asked in #1102889 as well, would it be possible to get a full
kernel log as well please?

I have a suspect that it might be related to
https://lore.kernel.org/stable/20250407181218.GA737271@ax162/
so far, but need to verify it.

Regards,
Salvatore

[toc] | [prev] | [next] | [standalone]


#86904 — Processed: Re: Bug#1102889: linux-image-6.1.0-33-amd64: KVM GPU passthrough broken

From"Debian Bug Tracking System" <owner@bugs.debian.org>
Date2025-04-15 17:40 +0200
SubjectProcessed: Re: Bug#1102889: linux-image-6.1.0-33-amd64: KVM GPU passthrough broken
Message-ID<KBQyd-dJuc-5@gated-at.bofh.it>
In reply to#86864
Processing control commands:

> tags -1 - moreinfo
Bug #1102914 [src:linux] VMs don't start up when being passed through a PCI device
Bug #1102889 [src:linux] linux-image-6.1.0-33-amd64: KVM GPU passthrough broken
Bug #1103153 [src:linux] linux-image-6.1.0-33-amd64: kernel fails to boot in xen DomU with pci-passthrough
Ignoring request to alter tags of bug #1102914 to the same tags previously set
Ignoring request to alter tags of bug #1102889 to the same tags previously set
Ignoring request to alter tags of bug #1103153 to the same tags previously set
> tags -1 + confirmed
Bug #1102914 [src:linux] VMs don't start up when being passed through a PCI device
Bug #1102889 [src:linux] linux-image-6.1.0-33-amd64: KVM GPU passthrough broken
Bug #1103153 [src:linux] linux-image-6.1.0-33-amd64: kernel fails to boot in xen DomU with pci-passthrough
Ignoring request to alter tags of bug #1102914 to the same tags previously set
Ignoring request to alter tags of bug #1102889 to the same tags previously set
Ignoring request to alter tags of bug #1103153 to the same tags previously set

-- 
1102889: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1102889
1102914: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1102914
1103153: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1103153
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems

[toc] | [prev] | [standalone]


Back to top | Article view | linux.debian.kernel


csiph-web