Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.kernel > #80514 > unrolled thread
| Started by | Salvatore Bonaccorso <carnil@debian.org> |
|---|---|
| First post | 2023-09-25 10:10 +0200 |
| Last post | 2023-10-03 06:50 +0200 |
| Articles | 4 — 3 participants |
Back to article view | Back to linux.debian.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Bug#1052584: linux-image-6.5.0-1-amd64: NFS4 stopped working in 6.5 with SELinux error Salvatore Bonaccorso <carnil@debian.org> - 2023-09-25 10:10 +0200
Bug#1052584: linux-image-6.5.0-1-amd64: NFS4 stopped working in 6.5 with SELinux error Michal Kaspar <mkaspar@it-media.cz> - 2023-10-02 00:30 +0200
Bug#1052584: linux-image-6.5.0-1-amd64: NFS4 stopped working in 6.5 with SELinux error Salvatore Bonaccorso <carnil@debian.org> - 2023-10-03 06:50 +0200
Processed: Re: Bug#1052584: linux-image-6.5.0-1-amd64: NFS4 stopped working in 6.5 with SELinux error "Debian Bug Tracking System" <owner@bugs.debian.org> - 2023-10-03 06:50 +0200
| From | Salvatore Bonaccorso <carnil@debian.org> |
|---|---|
| Date | 2023-09-25 10:10 +0200 |
| Subject | Bug#1052584: linux-image-6.5.0-1-amd64: NFS4 stopped working in 6.5 with SELinux error |
| Message-ID | <HhOPf-bp7Y-5@gated-at.bofh.it> |
Control: tags -1 + moreinfo Hi Michal, On Mon, Sep 25, 2023 at 12:52:16AM +0200, Michal Kaspar wrote: > Package: src:linux > Version: 6.5.3-1 > Severity: normal > > Dear Maintainer, > After upgrading to kernel version 6.5.0-1-amd64, the NFS4 stopped > working on the station. Whe trying to mount nf4 FS, the mount fails with > error: > mount.nfs: an incorrect mount option was specified for > The kernel log contains error message: > kernel: SELinux: Unable to set superblock options before the security server > is initialized > This puzzles me a bit as I've got SELinux disabled (don't even have > SELinux userspace installed, /sys/fs/selinux/enforce says 0). Tried > booting with selinux=0 boot parameter but with the same result. > Rebooting wih previou (6.4.0-4-amd64) kernel version fixes the problem > immediately. I suspect this is fixed by https://git.kernel.org/linus/ccf1dab96be4caed7c5235b1cfdb606ac161b996 in 6.6-rc2, and which went into 6.5.5 (will be included on next unstable upload). Can you apply the patch on top to confirm if that fixes the issue for you? Regards, Salvatore
[toc] | [next] | [standalone]
| From | Michal Kaspar <mkaspar@it-media.cz> |
|---|---|
| Date | 2023-10-02 00:30 +0200 |
| Message-ID | <Hkd6N-cTgx-5@gated-at.bofh.it> |
| In reply to | #80514 |
Hi Slavatore. I've tried to build a new kernel image with the patch mentioned and it seems it works well. I was able to mount NFS 4 shares with no problem so this patch indeed solves the problem reported for me. Thank you for your help On 25. 09. 23 10:01, Salvatore Bonaccorso wrote: > Control: tags -1 + moreinfo > > Hi Michal, > > On Mon, Sep 25, 2023 at 12:52:16AM +0200, Michal Kaspar wrote: >> Package: src:linux >> Version: 6.5.3-1 >> Severity: normal >> >> Dear Maintainer, >> After upgrading to kernel version 6.5.0-1-amd64, the NFS4 stopped >> working on the station. Whe trying to mount nf4 FS, the mount fails with >> error: >> mount.nfs: an incorrect mount option was specified for >> The kernel log contains error message: >> kernel: SELinux: Unable to set superblock options before the security server >> is initialized >> This puzzles me a bit as I've got SELinux disabled (don't even have >> SELinux userspace installed, /sys/fs/selinux/enforce says 0). Tried >> booting with selinux=0 boot parameter but with the same result. >> Rebooting wih previou (6.4.0-4-amd64) kernel version fixes the problem >> immediately. > I suspect this is fixed by > https://git.kernel.org/linus/ccf1dab96be4caed7c5235b1cfdb606ac161b996 > in 6.6-rc2, and which went into 6.5.5 (will be included on next > unstable upload). > > Can you apply the patch on top to confirm if that fixes the issue for > you? > > Regards, > Salvatore
[toc] | [prev] | [next] | [standalone]
| From | Salvatore Bonaccorso <carnil@debian.org> |
|---|---|
| Date | 2023-10-03 06:50 +0200 |
| Message-ID | <HkFw5-dblg-1@gated-at.bofh.it> |
| In reply to | #80573 |
Control: tags -1 + confirmed pending Control: tags -1 - moreinfo On Sun, Oct 01, 2023 at 11:33:43PM +0200, Michal Kaspar wrote: > Hi Slavatore. > I've tried to build a new kernel image with the patch mentioned and it seems > it works well. I was able to mount NFS 4 shares with no problem so this > patch indeed solves the problem reported for me. > Thank you for your help Thanks for confirming! It should land with the next upload then for unstable (not know when exactly that will follow, but hopefully soon). Regards, Salvatore
[toc] | [prev] | [next] | [standalone]
| From | "Debian Bug Tracking System" <owner@bugs.debian.org> |
|---|---|
| Date | 2023-10-03 06:50 +0200 |
| Subject | Processed: Re: Bug#1052584: linux-image-6.5.0-1-amd64: NFS4 stopped working in 6.5 with SELinux error |
| Message-ID | <HkFw5-dblg-11@gated-at.bofh.it> |
| In reply to | #80582 |
Processing control commands: > tags -1 + confirmed pending Bug #1052584 [src:linux] linux-image-6.5.0-1-amd64: NFS4 stopped working in 6.5 with SELinux error Added tag(s) confirmed and pending. > tags -1 - moreinfo Bug #1052584 [src:linux] linux-image-6.5.0-1-amd64: NFS4 stopped working in 6.5 with SELinux error Removed tag(s) moreinfo. -- 1052584: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1052584 Debian Bug Tracking System Contact owner@bugs.debian.org with problems
[toc] | [prev] | [standalone]
Back to top | Article view | linux.debian.kernel
csiph-web