Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > de.comm.software.mailreader > #966 > unrolled thread

Fetchmail: Pause zwischen den Anrufen

Started byeh@rsli.inka.de (Volker Englisch)
First post2022-05-27 17:28 +0000
Last post2022-05-29 15:27 +0200
Articles 14 — 7 participants

Back to article view | Back to de.comm.software.mailreader


Contents

  Fetchmail: Pause zwischen den Anrufen eh@rsli.inka.de (Volker Englisch) - 2022-05-27 17:28 +0000
    Re: Fetchmail: Pause zwischen den Anrufen Andreas Kohlbach <ank@spamfence.net> - 2022-05-27 18:13 -0400
      Re: Fetchmail: Pause zwischen den Anrufen Volker Englisch <eh@rsli.inka.de> - 2022-05-28 14:23 +0200
        Re: Fetchmail: Pause zwischen den Anrufen Joerg Mertens <joerg-mertens@t-online.de> - 2022-05-29 10:52 +0200
          Re: Fetchmail: Pause zwischen den Anrufen Volker Englisch <eh@rsli.inka.de> - 2022-05-29 12:50 +0200
    Re: Fetchmail: Pause zwischen den Anrufen Michael Schütz <der.schultze@web.de> - 2022-05-28 19:56 +0200
      Re: Fetchmail: Pause zwischen den Anrufen Volker Englisch <eh@rsli.inka.de> - 2022-05-28 20:42 +0200
        Re: Fetchmail: Pause zwischen den Anrufen Clemens Schüller <cs.usenet@mailbox.org> - 2022-05-28 21:08 +0200
          Re: Fetchmail: Pause zwischen den Anrufen Volker Englisch <eh@rsli.inka.de> - 2022-05-29 10:08 +0200
        Re: Fetchmail: Pause zwischen den Anrufen Andreas Fenner <Andis_Spamtonne@web.de> - 2022-05-29 12:11 +0200
          Re: Fetchmail: Pause zwischen den Anrufen Volker Englisch <eh@rsli.inka.de> - 2022-05-29 12:49 +0200
          Re: Fetchmail: Pause zwischen den Anrufen Volker Englisch <eh@rsli.inka.de> - 2022-06-01 13:44 +0200
    Re: Fetchmail: Pause zwischen den Anrufen Michael Schütz <der.schultze@web.de> - 2022-05-29 14:38 +0200
      Re: Fetchmail: Pause zwischen den Anrufen Volker Englisch <eh@rsli.inka.de> - 2022-05-29 15:27 +0200

#966 — Fetchmail: Pause zwischen den Anrufen

Fromeh@rsli.inka.de (Volker Englisch)
Date2022-05-27 17:28 +0000
SubjectFetchmail: Pause zwischen den Anrufen
Message-ID<t6r1o7$qvg$1@rsli.inka.de>
Hallo!

Ich habe in meiner .fetchmailrc mehrere POP3-Postfächer, die bei meinem 
Provider liegen, zum Abholen eingerichtet. Diese werden, wenn ich das 
richtig sehe, seriell abgearbeitet. Und das offenbar zu schnell 
nacheinander, denn ab und zu bekomme ich Login-Fehler ins Log 
geschrieben, die keine andere Ursache haben können.

Gibt es eine Möglichkeit, eine Pause zwischen den einzelnen Anrufen zu 
definieren? Also sowas wie:

poll xxx.xxx.xxx ...
pause 5
poll yyy.yyy.yyy ...
pause 5

Meine Internet-Recherche brachte leider keinen Erfolg.

Es macht dabei keinen Unterschied, ob fetchmail als Daemon läuft oder in 
regelmäßigen Intervallen von cron gestartet wird.

Der einzige Workaround, der mir im Moment einfällt, ist für jedes 
Postfach eine *rc zu erstellen und diese in minütlichem Abstand von cron 
zu starten. Ist aber irgendwie nicht schön...

Gibts bessere Ideen?

[toc] | [next] | [standalone]


#967

FromAndreas Kohlbach <ank@spamfence.net>
Date2022-05-27 18:13 -0400
Message-ID<87pmjysjxo.fsf@usenet.ankman.de>
In reply to#966
On Fri, 27 May 2022 17:28:39 +0000 (UTC), Volker Englisch wrote:
>
> Ich habe in meiner .fetchmailrc mehrere POP3-Postfächer, die bei meinem 
> Provider liegen, zum Abholen eingerichtet. Diese werden, wenn ich das 
> richtig sehe, seriell abgearbeitet. Und das offenbar zu schnell 
> nacheinander, denn ab und zu bekomme ich Login-Fehler ins Log 
> geschrieben, die keine andere Ursache haben können.

Welche Meldungen genau?

> Gibt es eine Möglichkeit, eine Pause zwischen den einzelnen Anrufen zu 
> definieren? Also sowas wie:
>
> poll xxx.xxx.xxx ...
> pause 5
> poll yyy.yyy.yyy ...
> pause 5
>
> Meine Internet-Recherche brachte leider keinen Erfolg.
>
> Es macht dabei keinen Unterschied, ob fetchmail als Daemon läuft oder in 
> regelmäßigen Intervallen von cron gestartet wird.
>
> Der einzige Workaround, der mir im Moment einfällt, ist für jedes 
> Postfach eine *rc zu erstellen und diese in minütlichem Abstand von cron 
> zu starten. Ist aber irgendwie nicht schön...
>
> Gibts bessere Ideen?

Nur Schlechtere. ;-)

Ein Skript:

fetchmail pop.1er_Provider.TLD
sleep 5
fetchmail pop.2er_Provider.TLD
sleep 5
...
-- 
Andreas

[toc] | [prev] | [next] | [standalone]


#968

FromVolker Englisch <eh@rsli.inka.de>
Date2022-05-28 14:23 +0200
Message-ID<t6t47a$r0q$1@rsli.inka.de>
In reply to#967
Am 28.05.2022 00:13, schrieb Andreas Kohlbach:
> On Fri, 27 May 2022 17:28:39 +0000 (UTC), Volker Englisch wrote:
>>
>> Ich habe in meiner .fetchmailrc mehrere POP3-Postfächer, die bei meinem
>> Provider liegen, zum Abholen eingerichtet. Diese werden, wenn ich das
>> richtig sehe, seriell abgearbeitet. Und das offenbar zu schnell
>> nacheinander, denn ab und zu bekomme ich Login-Fehler ins Log
>> geschrieben, die keine andere Ursache haben können.
>
> Welche Meldungen genau?

fetchmail: Authorization failure on xxxxxx_206@pop.example.com
fetchmail: For help, see http://www.fetchmail.info/fetchmail-FAQ.html#R15
fetchmail: Query status=3 (AUTHFAIL)
fetchmail: Authorization failure on xxxxxx_207@pop.example.com
fetchmail: For help, see http://www.fetchmail.info/fetchmail-FAQ.html#R15
fetchmail: Query status=3 (AUTHFAIL)
fetchmail: Authorization failure on xxxxxx_208@pop.example.com
fetchmail: For help, see http://www.fetchmail.info/fetchmail-FAQ.html#R15
fetchmail: Query status=3 (AUTHFAIL)

Grundsätzlich ist es kein Problem mit der Authentifizierung, und der 
Fehler taucht nur ab und zu auf.

>> Gibt es eine Möglichkeit, eine Pause zwischen den einzelnen Anrufen zu
>> definieren? Also sowas wie:
>>
>> poll xxx.xxx.xxx ...
>> pause 5
>> poll yyy.yyy.yyy ...
>> pause 5
>>
>> Meine Internet-Recherche brachte leider keinen Erfolg.
>>
>> Es macht dabei keinen Unterschied, ob fetchmail als Daemon läuft oder in
>> regelmäßigen Intervallen von cron gestartet wird.
>>
>> Der einzige Workaround, der mir im Moment einfällt, ist für jedes
>> Postfach eine *rc zu erstellen und diese in minütlichem Abstand von cron
>> zu starten. Ist aber irgendwie nicht schön...
>>
>> Gibts bessere Ideen?
>
> Nur Schlechtere. ;-)

:-)

> Ein Skript:
>
> fetchmail pop.1er_Provider.TLD
> sleep 5
> fetchmail pop.2er_Provider.TLD
> sleep 5
> ...

Wäre eine Möglichkeit, danke!

[toc] | [prev] | [next] | [standalone]


#973

FromJoerg Mertens <joerg-mertens@t-online.de>
Date2022-05-29 10:52 +0200
Message-ID<87ee0c4t69.fsf@joerg-mertens.dialin.t-online.de>
In reply to#968
Volker Englisch <eh@rsli.inka.de> writes:

> fetchmail: Authorization failure on xxxxxx_206@pop.example.com
> fetchmail: For help, see http://www.fetchmail.info/fetchmail-FAQ.html#R15
> fetchmail: Query status=3 (AUTHFAIL)
> fetchmail: Authorization failure on xxxxxx_207@pop.example.com
> fetchmail: For help, see http://www.fetchmail.info/fetchmail-FAQ.html#R15
> fetchmail: Query status=3 (AUTHFAIL)
> fetchmail: Authorization failure on xxxxxx_208@pop.example.com
> fetchmail: For help, see http://www.fetchmail.info/fetchmail-FAQ.html#R15
> fetchmail: Query status=3 (AUTHFAIL)
>
> Grundsätzlich ist es kein Problem mit der Authentifizierung, und der
> Fehler taucht nur ab und zu auf.

Kannst du mal `fetchmail -v´ machen, um das Loglevel etwas zu erhöhen?

Jörg

[toc] | [prev] | [next] | [standalone]


#976

FromVolker Englisch <eh@rsli.inka.de>
Date2022-05-29 12:50 +0200
Message-ID<t6vj58$lv2$2@rsli.inka.de>
In reply to#973
Am 29.05.2022 10:52, schrieb Joerg Mertens:
> Volker Englisch<eh@rsli.inka.de>  writes:
>
>> fetchmail: Authorization failure on xxxxxx_206@pop.example.com
>> fetchmail: For help, see http://www.fetchmail.info/fetchmail-FAQ.html#R15
>> fetchmail: Query status=3 (AUTHFAIL)
>> fetchmail: Authorization failure on xxxxxx_207@pop.example.com
>> fetchmail: For help, see http://www.fetchmail.info/fetchmail-FAQ.html#R15
>> fetchmail: Query status=3 (AUTHFAIL)
>> fetchmail: Authorization failure on xxxxxx_208@pop.example.com
>> fetchmail: For help, see http://www.fetchmail.info/fetchmail-FAQ.html#R15
>> fetchmail: Query status=3 (AUTHFAIL)
>>
>> Grundsätzlich ist es kein Problem mit der Authentifizierung, und der
>> Fehler taucht nur ab und zu auf.
>
> Kannst du mal `fetchmail -v´ machen, um das Loglevel etwas zu erhöhen?

Mach ich bei Gelegenheit mal, ergibt halt eine Menge Junk im Log, da ja 
nicht vorhersehbar ist, wann der Fehler "zuschlägt"...

[toc] | [prev] | [next] | [standalone]


#969

FromMichael Schütz <der.schultze@web.de>
Date2022-05-28 19:56 +0200
Message-ID<lb4ami-i3r7.ln1@ardbeg.whisky.at.home>
In reply to#966
Volker Englisch <eh@rsli.inka.de> schrieb:
> Hallo!
> 
> Ich habe in meiner .fetchmailrc mehrere POP3-Postfächer, die bei meinem 
> Provider liegen, zum Abholen eingerichtet. Diese werden, wenn ich das 
> richtig sehe, seriell abgearbeitet. Und das offenbar zu schnell 
> nacheinander, denn ab und zu bekomme ich Login-Fehler ins Log 
> geschrieben, die keine andere Ursache haben können.
> 
> Gibt es eine Möglichkeit, eine Pause zwischen den einzelnen Anrufen zu 
> definieren? Also sowas wie:
> 
> poll xxx.xxx.xxx ...
> pause 5
> poll yyy.yyy.yyy ...
> pause 5
> 
> Meine Internet-Recherche brachte leider keinen Erfolg.
> 
> Es macht dabei keinen Unterschied, ob fetchmail als Daemon läuft oder in 
> regelmäßigen Intervallen von cron gestartet wird.
> 
> Der einzige Workaround, der mir im Moment einfällt, ist für jedes 
> Postfach eine *rc zu erstellen und diese in minütlichem Abstand von cron 
> zu starten. Ist aber irgendwie nicht schön...
> 
> Gibts bessere Ideen?
> 
Erstmal eine Frage: Sind das freemail-accounts? Einige dieser Provider
schränken die Häufigkeit/Frequenz der Abrufe ein.
Wenn Du minütlich abrufst wäre das dann zu kurz hintereinander.
Nur als Idee.

Schultze

-- 
Es liegt in der menschlichen Natur, vernünftig zu denken und unlogisch
zu handeln.
                                                        Anatole France

[toc] | [prev] | [next] | [standalone]


#970

FromVolker Englisch <eh@rsli.inka.de>
Date2022-05-28 20:42 +0200
Message-ID<t6tqf7$be0$1@rsli.inka.de>
In reply to#969
Am 28.05.2022 19:56, schrieb Michael Schütz:
> Volker Englisch<eh@rsli.inka.de>  schrieb:
>> Hallo!
>>
>> Ich habe in meiner .fetchmailrc mehrere POP3-Postfächer, die bei meinem
>> Provider liegen, zum Abholen eingerichtet. Diese werden, wenn ich das
>> richtig sehe, seriell abgearbeitet. Und das offenbar zu schnell
>> nacheinander, denn ab und zu bekomme ich Login-Fehler ins Log
>> geschrieben, die keine andere Ursache haben können.
>>
>> Gibt es eine Möglichkeit, eine Pause zwischen den einzelnen Anrufen zu
>> definieren? Also sowas wie:
>>
>> poll xxx.xxx.xxx ...
>> pause 5
>> poll yyy.yyy.yyy ...
>> pause 5
>>
>> Der einzige Workaround, der mir im Moment einfällt, ist für jedes
>> Postfach eine *rc zu erstellen und diese in minütlichem Abstand von cron
>> zu starten. Ist aber irgendwie nicht schön...
>>
>> Gibts bessere Ideen?
>>
> Erstmal eine Frage: Sind das freemail-accounts? Einige dieser Provider
> schränken die Häufigkeit/Frequenz der Abrufe ein.
> Wenn Du minütlich abrufst wäre das dann zu kurz hintereinander.
> Nur als Idee.

Nein, es sind (bezahlte) Accounts bei einem deutschen Provider. Trotzdem 
danke für die Idee.

[toc] | [prev] | [next] | [standalone]


#971

FromClemens Schüller <cs.usenet@mailbox.org>
Date2022-05-28 21:08 +0200
Message-ID<m2o7zhscf8.fsf@cmschueller.my-fqdn.de>
In reply to#970
Servus!

Volker Englisch schrieb am 28. May. 2022 um 20:42:
> Am 28.05.2022 19:56, schrieb Michael Schütz:


>> Erstmal eine Frage: Sind das freemail-accounts? Einige dieser Provider
>> schränken die Häufigkeit/Frequenz der Abrufe ein.
>> Wenn Du minütlich abrufst wäre das dann zu kurz hintereinander.
>> Nur als Idee.
>
> Nein, es sind (bezahlte) Accounts bei einem deutschen
> Provider. Trotzdem danke für die Idee.

Und dieser bezahlte Provider bietet keinen IMAP Zugriff an, sondern
eiert noch mit der POP3 Krücke herum?!?

Very strange xD


-- 
LieGrü aus Graz, Clemens

[toc] | [prev] | [next] | [standalone]


#972

FromVolker Englisch <eh@rsli.inka.de>
Date2022-05-29 10:08 +0200
Message-ID<t6v9mk$11i$1@rsli.inka.de>
In reply to#971
Am 28.05.2022 21:08, schrieb Clemens Schüller:
> Servus!
>
> Volker Englisch schrieb am 28. May. 2022 um 20:42:
>> Am 28.05.2022 19:56, schrieb Michael Schütz:
>
>
>>> Erstmal eine Frage: Sind das freemail-accounts? Einige dieser Provider
>>> schränken die Häufigkeit/Frequenz der Abrufe ein.
>>> Wenn Du minütlich abrufst wäre das dann zu kurz hintereinander.
>>> Nur als Idee.
>>
>> Nein, es sind (bezahlte) Accounts bei einem deutschen
>> Provider. Trotzdem danke für die Idee.
>
> Und dieser bezahlte Provider bietet keinen IMAP Zugriff an, sondern
> eiert noch mit der POP3 Krücke herum?!?

Natürlich bietet er auch IMAP an. Ich sehe bisher nur keinen Vorteil von 
IMAP gegenüber POP3 zum reinen Abholen von Mails.

Am Problem des zu schnellen wiederholten Logins sollte das Protokoll 
doch nichts ändern. Oder?

[toc] | [prev] | [next] | [standalone]


#974

FromAndreas Fenner <Andis_Spamtonne@web.de>
Date2022-05-29 12:11 +0200
Message-ID<jfgv78FbdsaU1@mid.individual.net>
In reply to#970
Am 28.05.2022 um 20:42 schrieb Volker Englisch:

> 
> Nein, es sind (bezahlte) Accounts bei einem deutschen Provider. Trotzdem 
> danke für die Idee.
> 
> 

Was sagt denn der Support?
(Wenn du €€ hinlegst, dann darf der auch antworten :-)


Andi

[toc] | [prev] | [next] | [standalone]


#975

FromVolker Englisch <eh@rsli.inka.de>
Date2022-05-29 12:49 +0200
Message-ID<t6vj33$lv2$1@rsli.inka.de>
In reply to#974
Am 29.05.2022 12:11, schrieb Andreas Fenner:
>
> Am 28.05.2022 um 20:42 schrieb Volker Englisch:
>
>>
>> Nein, es sind (bezahlte) Accounts bei einem deutschen Provider.
>> Trotzdem danke für die Idee.
>
> Was sagt denn der Support?
> (Wenn du €€ hinlegst, dann darf der auch antworten :-)

Habe ich noch nicht angefragt. Mache ich aber demnächst noch. Grund 
meines Postings war ja die evtl. Möglichkeit, Fetchmail etwas zu "bremsen".

Vorläufig habe ich die Skript-Idee von Andreas umgesetzt, momentan ohne 
weitere Probleme. Gefällt mir immer noch besser als zig Aufrufe aus cron 
heraus ;-)

[toc] | [prev] | [next] | [standalone]


#979

FromVolker Englisch <eh@rsli.inka.de>
Date2022-06-01 13:44 +0200
Message-ID<t77jf4$so2$1@rsli.inka.de>
In reply to#974
Am 29.05.2022 12:11, schrieb Andreas Fenner:
>
> Am 28.05.2022 um 20:42 schrieb Volker Englisch:
>
>> Nein, es sind (bezahlte) Accounts bei einem deutschen Provider.
>> Trotzdem danke für die Idee.
>
> Was sagt denn der Support?
> (Wenn du €€ hinlegst, dann darf der auch antworten :-)

JFTR. Gestern geschrieben, heute ist die Antwort da. Zitat:

"Das von Ihnen genannte Beispiel konnte ich auch in unseren Logs finden. 
Die drei Anmeldungen wurden an unseren Server herangetragen und mit 
"Could not connect to Server" abgewiesen. Dies spricht schon dafür, dass 
die übermittelten Daten unvollständig waren.  Ein falsches Passwort oder 
Benutzername hätte sich in den Logs anders gezeigt."

Sieht also nach irgendeinem unerklärlichen Problem von Fetchmail aus.

Da es mit dem Skript mit Pausen zwischen den Anrufen funktioniert, werde 
ich nicht weiter suchen und lasse es dabei bewenden.

[toc] | [prev] | [next] | [standalone]


#977

FromMichael Schütz <der.schultze@web.de>
Date2022-05-29 14:38 +0200
Message-ID<d26cmi-23k8.ln1@ardbeg.whisky.at.home>
In reply to#966
Volker Englisch <eh@rsli.inka.de> schrieb:
> Hallo!
> 
> Ich habe in meiner .fetchmailrc mehrere POP3-Postfächer, die bei meinem 
> Provider liegen, zum Abholen eingerichtet. Diese werden, wenn ich das 
> richtig sehe, seriell abgearbeitet. Und das offenbar zu schnell 
> nacheinander, denn ab und zu bekomme ich Login-Fehler ins Log 
> geschrieben, die keine andere Ursache haben können.
> 
Ich hatte vor Jahren öfter Probleme mit einem web.de-Account. Da ging
das Versenden aus mir unbekannten Gründen manchmal nicht. Da das
Postfach kostenlos war, bekam ich auch keine Hilfe vom Support. Diese
Erfahrungen haben mich aber veranlasst, meinen Bezahl-Account woanders
zu buchen.

Schultze

-- 
Ein Fachmann ist ein Mensch, der zu reden anfängt, wenn er zu denken
aufhört - und umgekehrt.                                Umberto Eco

[toc] | [prev] | [next] | [standalone]


#978

FromVolker Englisch <eh@rsli.inka.de>
Date2022-05-29 15:27 +0200
Message-ID<t6vscl$mke$1@rsli.inka.de>
In reply to#977
Am 29.05.2022 14:38, schrieb Michael Schütz:
> Volker Englisch<eh@rsli.inka.de>  schrieb:
>>
>> Ich habe in meiner .fetchmailrc mehrere POP3-Postfächer, die bei meinem
>> Provider liegen, zum Abholen eingerichtet. Diese werden, wenn ich das
>> richtig sehe, seriell abgearbeitet. Und das offenbar zu schnell
>> nacheinander, denn ab und zu bekomme ich Login-Fehler ins Log
>> geschrieben, die keine andere Ursache haben können.
>>
> Ich hatte vor Jahren öfter Probleme mit einem web.de-Account. Da ging
> das Versenden aus mir unbekannten Gründen manchmal nicht. Da das
> Postfach kostenlos war, bekam ich auch keine Hilfe vom Support. Diese
> Erfahrungen haben mich aber veranlasst, meinen Bezahl-Account woanders
> zu buchen.

Meine liegen bei kontent.com, seit ewigen Zeiten :-) Früher hatte ich 
dort nur mit Mailweiterleitungen gearbeitet, darum fällt das erst jetzt 
auf... Also nichts mit GMX bei mir.

[toc] | [prev] | [standalone]


Back to top | Article view | de.comm.software.mailreader


csiph-web