Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.user > #193966
| From | Neo <neo@spacerat.ch> |
|---|---|
| Newsgroups | linux.debian.user |
| Subject | How to correctly select gcc / why dkms rebuild failed on xtables-addons |
| Date | 2018-03-20 23:40 +0100 |
| Message-ID | <vvy5b-1WX-1@gated-at.bofh.it> (permalink) |
| References | <vuK8p-2X3-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hey folks I've had a setup with xtables-addons running (on jessie with standard repos), especially the geoip module in this case. The normal upgrade path installed gcc-4.9 and broke my dkms setup and in turn my iptables setup. So it fell back on my fail2ban protection against ssh scripts. /usr/bin/gcc-4.8 was on strange file permissions, with not even execute perms for root. Thus de dkms rebuild failed. now my questions: why was gcc-4.8 binary set to no execution, even for root? why is xtables-addons-dkms not using gcc-4.9? a simple chmod 700 /usr/bin/gcc-4.8 fixed the problem. Thank you for any enlightenment best regards
Back to linux.debian.user | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Claws-mail no plugin for html Aldo Maggi <sentiniate@virgilio.it> - 2018-03-18 18:20 +0100
Re: Claws-mail no plugin for html Brad Rogers <brad@fineby.me.uk> - 2018-03-18 18:30 +0100
Re: Claws-mail no plugin for html Aldo Maggi <sentiniate@virgilio.it> - 2018-03-18 22:20 +0100
Re: Claws-mail no plugin for html Abdullah Ramazanoglu <ar018@yahoo.com> - 2018-03-18 20:20 +0100
Re: Claws-mail no plugin for html Brian <ad44@cityscape.co.uk> - 2018-03-18 21:40 +0100
How to correctly select gcc / why dkms rebuild failed on xtables-addons Neo <neo@spacerat.ch> - 2018-03-20 23:40 +0100
Re: How to correctly select gcc / why dkms rebuild failed on xtables-addons David Wright <deblis@lionunicorn.co.uk> - 2018-03-21 00:00 +0100
csiph-web