Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1731458

Re: [PATCH 2/2] iio: Use __ATTR_NAMED to allow passing name as string to IIO_DEVICE_ATTR_NAMED and change usage to pass string

From himanshi <himshijain.hj@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH 2/2] iio: Use __ATTR_NAMED to allow passing name as string to IIO_DEVICE_ATTR_NAMED and change usage to pass string
Date 2017-09-13 10:50 +0200
Message-ID <upbwR-50A-11@gated-at.bofh.it> (permalink)
References <upaKt-4rT-5@gated-at.bofh.it> <upaKt-4rT-7@gated-at.bofh.it> <upaKt-4rT-3@gated-at.bofh.it> <upb3Q-4Pk-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, Sep 13, 2017 at 11:12:21AM +0300, Dan Carpenter wrote:
> On Wed, Sep 13, 2017 at 01:26:27PM +0530, Himanshi Jain wrote:
> > Add IIO_ATTR_NAMED macro to use __ATTR_NAMED to allow passing name as
> > string to IIO_DEVICE_ATTR_NAMED. Change current usage of
> > IIO_DEVICE_ATTR_NAMED to pass name as string.
> > 
> > Signed-off-by: Himanshi Jain <himshijain.hj@gmail.com>
> 
> This version looks nice.  The subject is just *way* too long, though.
> Also you have put a v2 in the subject and a little changelog after the
> --- cut off.  Just call it something like:
> [PATCH 2/2 v2] iio: Change to __ATTR_NAMED()
> 
> regards,
> dan carpenter

Thank you for the review Dan! Does it look fine now in v2?

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 2/2] iio: Use __ATTR_NAMED to allow passing name as string to  IIO_DEVICE_ATTR_NAMED and change usage to pass string Himanshi Jain <himshijain.hj@gmail.com> - 2017-09-13 10:00 +0200
  Re: [PATCH 2/2] iio: Use __ATTR_NAMED to allow passing name as  string to IIO_DEVICE_ATTR_NAMED and change usage to pass string Dan Carpenter <dan.carpenter@oracle.com> - 2017-09-13 10:20 +0200
    Re: [PATCH 2/2] iio: Use __ATTR_NAMED to allow passing name as  string to IIO_DEVICE_ATTR_NAMED and change usage to pass string himanshi <himshijain.hj@gmail.com> - 2017-09-13 10:50 +0200

csiph-web