Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1722341
| From | Alim Akhtar <alim.akhtar@samsung.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] scsi: ufs: Make use of UFS_BIT macro wherever possible |
| Date | 2017-08-29 13:20 +0200 |
| Message-ID | <ujMIQ-1VL-35@gated-at.bofh.it> (permalink) |
| References | <ujrkZ-5xq-5@gated-at.bofh.it> <ujrkZ-5xq-3@gated-at.bofh.it> <ujusy-7mE-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Bart, Thanks for your review. On 08/28/2017 09:15 PM, Bart Van Assche wrote: > On Mon, 2017-08-28 at 17:49 +0530, Alim Akhtar wrote: >> This entire file uses UFS_BIT macro for bits definition, expect for few >> places. This patch convert those defines to use UFS_BIT macro to be aligned >> with reset of the file. > > This is the definition of the UFS_BIT() macro I found in > drivers/scsi/ufs/ufshci.h: > > #define UFS_BIT(x) (1L << (x)) > > Using this macro makes code longer instead of shorter and does not improve > code readability. Is this macro really useful? Wouldn't it be better to > remove the UFS_BIT() macro instead of introducing more uses of it? > Well, the intension of this patch is to make use of already existing UFS_BIT() macro. I am not aware of the history why this macro was created at first place. Well, it does improve code readability, for me at least, no need for one to do a calculation to see which bit it is, as we pass _bit_ number to UFS_BIT. I am totally okay, if you or other reviewers suggests me to change UFS_BIT to actual bit position, something like the original case, which this patch is trying to change. > Thanks, > > Bart. > Thanks! Alim
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] scsi: ufs: Make use of UFS_BIT macro wherever possible Alim Akhtar <alim.akhtar@samsung.com> - 2017-08-28 14:30 +0200
Re: [PATCH] scsi: ufs: Make use of UFS_BIT macro wherever possible Bart Van Assche <Bart.VanAssche@wdc.com> - 2017-08-28 17:50 +0200
Re: [PATCH] scsi: ufs: Make use of UFS_BIT macro wherever possible Alim Akhtar <alim.akhtar@samsung.com> - 2017-08-29 13:20 +0200
csiph-web