Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1712462
| From | Hans de Goede <hdegoede@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v2 02/14] staging: typec: tcpm: Add get_current_limit tcpc_dev callback |
| Date | 2017-08-15 22:10 +0200 |
| Message-ID | <ueQk4-5RL-61@gated-at.bofh.it> (permalink) |
| References | <ueQk1-5RL-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
A Rp signalling the default current limit indicates that we're possibly
connected to an USB2 power-source. In some cases the type-c port-controller
may provide the capability to detect the current-limit in this case,
through e.g. BC1.2 detection.
This commit adds an optional get_current_limit tcpc_dev callback which
allows the port-controller to provide current-limit detection for when
the CC pin is pulled up with Rp.
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
---
Changes in v2:
-s/get_usb2_current_limit/get_current_limit/
---
drivers/staging/typec/tcpm.c | 5 ++++-
drivers/staging/typec/tcpm.h | 7 +++++++
2 files changed, 11 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/typec/tcpm.c b/drivers/staging/typec/tcpm.c
index 20eb4eb..8e823af 100644
--- a/drivers/staging/typec/tcpm.c
+++ b/drivers/staging/typec/tcpm.c
@@ -660,7 +660,10 @@ static u32 tcpm_get_current_limit(struct tcpm_port *port)
break;
case TYPEC_CC_RP_DEF:
default:
- limit = 0;
+ if (port->tcpc->get_current_limit)
+ limit = port->tcpc->get_current_limit(port->tcpc);
+ else
+ limit = 0;
break;
}
diff --git a/drivers/staging/typec/tcpm.h b/drivers/staging/typec/tcpm.h
index 19c307d..1465668 100644
--- a/drivers/staging/typec/tcpm.h
+++ b/drivers/staging/typec/tcpm.h
@@ -108,6 +108,13 @@ struct tcpc_dev {
int (*init)(struct tcpc_dev *dev);
int (*get_vbus)(struct tcpc_dev *dev);
+ /*
+ * This optional callback gets called by the tcpm core when configured
+ * as a snk and cc=Rp-def. This allows the tcpm to provide a fallback
+ * current-limit detection method for the cc=Rp-def case. E.g. some
+ * tcpcs may include BC1.2 charger detection and use that in this case.
+ */
+ int (*get_current_limit)(struct tcpc_dev *dev);
int (*set_cc)(struct tcpc_dev *dev, enum typec_cc_status cc);
int (*get_cc)(struct tcpc_dev *dev, enum typec_cc_status *cc1,
enum typec_cc_status *cc2);
--
2.9.4
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 00/14] Hookup typec power-negotation to the PMIC and charger Hans de Goede <hdegoede@redhat.com> - 2017-08-15 22:10 +0200
[PATCH v2 11/14] power: supply: bq24190_charger: Get input_current_limit from our supplier Hans de Goede <hdegoede@redhat.com> - 2017-08-15 22:10 +0200
Re: [PATCH v2 11/14] power: supply: bq24190_charger: Get input_current_limit from our supplier Liam Breck <liam@networkimprov.net> - 2017-08-16 22:30 +0200
[PATCH v2 09/14] power: supply: bq24190_charger: Export 5V boost converter as regulator Hans de Goede <hdegoede@redhat.com> - 2017-08-15 22:10 +0200
[PATCH v2 06/14] staging: typec: fusb302: Add support for USB2 charger detection through extcon Hans de Goede <hdegoede@redhat.com> - 2017-08-15 22:10 +0200
[PATCH v2 02/14] staging: typec: tcpm: Add get_current_limit tcpc_dev callback Hans de Goede <hdegoede@redhat.com> - 2017-08-15 22:10 +0200
Re: [PATCH v2 02/14] staging: typec: tcpm: Add get_current_limit tcpc_dev callback Guenter Roeck <linux@roeck-us.net> - 2017-08-16 17:20 +0200
[PATCH v2 12/14] power: supply: bq24190_charger: Remove extcon handling Hans de Goede <hdegoede@redhat.com> - 2017-08-15 22:10 +0200
[PATCH v2 08/14] power: supply: Add power_supply_set_input_current_limit_from_supplier helper Hans de Goede <hdegoede@redhat.com> - 2017-08-15 22:10 +0200
Re: [PATCH v2 08/14] power: supply: Add power_supply_set_input_current_limit_from_supplier helper Tony Lindgren <tony@atomide.com> - 2017-08-16 18:00 +0200
Re: [PATCH v2 08/14] power: supply: Add power_supply_set_input_current_limit_from_supplier helper Hans de Goede <hdegoede@redhat.com> - 2017-08-16 19:40 +0200
Re: [PATCH v2 08/14] power: supply: Add power_supply_set_input_current_limit_from_supplier helper Tony Lindgren <tony@atomide.com> - 2017-08-16 21:30 +0200
[PATCH v2 01/14] i2c: Allow overriding dev_name through board_info Hans de Goede <hdegoede@redhat.com> - 2017-08-15 22:10 +0200
csiph-web