Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1698911
| From | David Laight <David.Laight@ACULAB.COM> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | RE: [PATCH net] tcp: avoid bogus gcc-7 array-bounds warning |
| Date | 2017-07-28 17:50 +0200 |
| Message-ID | <u8fGx-5Cs-5@gated-at.bofh.it> (permalink) |
| References | <u8eKv-4ZB-29@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Arnd Bergmann
> Sent: 28 July 2017 15:42
...
> --- a/net/ipv4/tcp_output.c
> +++ b/net/ipv4/tcp_output.c
> @@ -2202,9 +2202,10 @@ static bool tcp_small_queue_check(struct sock *sk, const struct sk_buff *skb,
> static void tcp_chrono_set(struct tcp_sock *tp, const enum tcp_chrono new)
> {
> const u32 now = tcp_jiffies32;
> + enum tcp_chrono old = tp->chrono_type;
>
> - if (tp->chrono_type > TCP_CHRONO_UNSPEC)
> - tp->chrono_stat[tp->chrono_type - 1] += now - tp->chrono_start;
> + if (old > TCP_CHRONO_UNSPEC)
> + tp->chrono_stat[old - 1] += now - tp->chrono_start;
> tp->chrono_start = now;
> tp->chrono_type = new;
What a horrid combination of enum and integers.
Also have u32 chrono_stat[3]; - should probably be [__TCP_CHRONO_MAX - 1]
(or - CHRONO_FIRST which is defined to be 1).
Checking if (old != 0) would make the code more readable.
David
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH net] tcp: avoid bogus gcc-7 array-bounds warning Arnd Bergmann <arnd@arndb.de> - 2017-07-28 16:50 +0200 RE: [PATCH net] tcp: avoid bogus gcc-7 array-bounds warning David Laight <David.Laight@ACULAB.COM> - 2017-07-28 17:50 +0200 Re: [PATCH net] tcp: avoid bogus gcc-7 array-bounds warning David Miller <davem@davemloft.net> - 2017-07-30 08:30 +0200
csiph-web