Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.user > #179370
| From | Felix Winterhalter <felix@audiofair.de> |
|---|---|
| Newsgroups | linux.debian.user |
| Subject | DPKG install fails with read only filesystem on non read-only filesystem |
| Date | 2017-03-26 17:50 +0200 |
| Message-ID | <tpiAx-1SU-7@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
Hello, for various reasons I am currently writing a script to install packages by calling dpkg -i package.deb. This mechanism has worked fine for a while. Now I need to call said script using sudo noninteractively from a webserver. This leads me to my error: Mar 26 11:36:42 debbuilder package-updater[32246]: (Reading database ... 124404 files and directories currently installed.) Mar 26 11:36:42 debbuilder package-updater[32246]: Preparing to unpack .../package_0.2_all.deb ... Mar 26 11:36:42 debbuilder package-updater[32246]: Unpacking package (0.2) over (0.2) ... Mar 26 11:36:42 debbuilder package-updater[32246]: dpkg: error processing archive /tmp/package-update-unpack/unpack/package_0.2_all.deb (--install): Mar 26 11:36:42 debbuilder package-updater[32246]: unable to clean up mess surrounding `./usr/share/doc/package' before installing another version: Read-only file system Mar 26 11:36:42 debbuilder package-updater[32246]: Errors were encountered while processing: Mar 26 11:36:42 debbuilder package-updater[32246]: /tmp/package-update-unpack/unpack/package_0.2_all.deb Neither /tmp nor /usr is non writeable. Calling the package install script manually via sudo from a normal user runs everything as normal without any error. So the package itself is not a problem ( apparently ). I've been trying to find the source of this error since a couple of hours now. I haven't been able to make any real progress and was wondering whether anyone here would have an idea whats going wrong. This error is happening on two independent debian systems. / is mounted /dev/sda1 on / type ext4 (rw,relatime,data=ordered) tmp is a normal folder not another mountpoint The packages are uploaded via a python webserver. However the package integrity is checked before applying the install. The packages themselves are intact. Best regards, Felix
Back to linux.debian.user | Previous | Next — Next in thread | Find similar | Unroll thread
DPKG install fails with read only filesystem on non read-only filesystem Felix Winterhalter <felix@audiofair.de> - 2017-03-26 17:50 +0200 Re: DPKG install fails with read only filesystem on non read-only filesystem Felix Winterhalter <felix@audiofair.de> - 2017-03-26 18:00 +0200
csiph-web