Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1608504
| From | Russell King - ARM Linux <linux@armlinux.org.uk> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] arm/dma-mapping: use for_each_sg |
| Date | 2017-03-24 15:50 +0100 |
| Message-ID | <toyHp-2WH-35@gated-at.bofh.it> (permalink) |
| References | <toyel-2LK-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, Mar 24, 2017 at 10:12:23PM +0800, Geliang Tang wrote:
> Use for_each_sg() instead of open-coding it.
>
> Signed-off-by: Geliang Tang <geliangtang@gmail.com>
No.
> diff --git a/arch/arm/mm/dma-mapping.c b/arch/arm/mm/dma-mapping.c
> index 63eabb0..e551351 100644
> --- a/arch/arm/mm/dma-mapping.c
> +++ b/arch/arm/mm/dma-mapping.c
> @@ -1720,7 +1720,7 @@ static int __map_sg_chunk(struct device *dev, struct scatterlist *sg,
> if (iova == DMA_ERROR_CODE)
> return -ENOMEM;
>
> - for (count = 0, s = sg; count < (size >> PAGE_SHIFT); s = sg_next(s)) {
> + for_each_sg(sg, s, size >> PAGE_SHIFT, count) {
This is _not_ equivalent.
#define for_each_sg(sglist, sg, nr, __i) \
for (__i = 0, sg = (sglist); __i < (nr); __i++, sg = sg_next(sg))
Putting the arguments into that gives:
for (count = 0, s = sg; count < (size >> PAGE_SHIFT); count++, s = sg_next(s))
whereas the old code is:
for (count = 0, s = sg; count < (size >> PAGE_SHIFT); s = sg_next(s))
Spot the difference? "count++".
This is because "size >> PAGE_SHIFT" is not the number of scatterlist
entries, it's the number of pages to map.
Please be more careful in the future to ensure that, when cleaning up
code, that the code is indeed equivalent. Subtle errors like this are
sometimes incredibly difficult to spot.
--
RMK's Patch system: http://www.armlinux.org.uk/developer/patches/
FTTC broadband for 0.8mile line: currently at 9.6Mbps down 400kbps up
according to speedtest.net.
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] arm/dma-mapping: use for_each_sg Geliang Tang <geliangtang@gmail.com> - 2017-03-24 15:20 +0100 [PATCH] [media] ivtv: use for_each_sg Geliang Tang <geliangtang@gmail.com> - 2017-03-24 15:20 +0100 Re: [PATCH] arm/dma-mapping: use for_each_sg Russell King - ARM Linux <linux@armlinux.org.uk> - 2017-03-24 15:50 +0100
csiph-web