Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.user > #179167

Re: Matrox G550 - MGA X server fails

From Sven Joachim <svenjoac@gmx.de>
Newsgroups linux.debian.user
Subject Re: Matrox G550 - MGA X server fails
Date 2017-03-22 21:20 +0100
Message-ID <tnUTF-85w-39@gated-at.bofh.it> (permalink)
References <tnLGG-Ta-21@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 2017-03-22 10:25 +0000, Oliver Elphick wrote:

> I am unable to start X using a Matrox Millennium G550 PCIe card.
>
> This is what I think is the relevant part of the log for the session:
>
> #011compiled for 1.19.2, module version = 0.1.0
> #011ABI class: X.Org Video Driver, version 23.0
> (--) MGA(0): Chipset: "mgag550"
> xf86TokenToOptinfo: table is NULL
> xf86TokenToOptinfo: table is NULL
> (==) MGA(0): Using HW cursor
> (--) MGA(0): Linear framebuffer at 0xF0000000
> (--) MGA(0): MMIO registers at 0xF7020000
> (--) MGA(0): Pseudo-DMA transfer window at 0xF6800000
> (EE) MGA(0): Unable to map Framebuffer F0000000 2000000.  Permission
> denied (13)
> (II) MGA(0): Creating default Display subsection in Screen section
> #011"Default Screen Section" for depth/fbbpp 24/32
> (==) MGA(0): Depth 24, (--) framebuffer bpp 32
> (==) MGA(0): RGB weight 888
> (==) MGA(0): Using AGP 1x mode
> (==) MGA(0): Using XAA acceleration
> (WW) MGA(0): Could not retrieve video BIOS!
> (EE) MGA(0): Unable to detect video RAM.
> (II) UnloadModule: "mga"
>
> The full log is attached.
>
> Can anyone indicate what the problem is, please?

Probably that the X server is no longer running with root rights, and
it has to do that if there is no kernel driver for the graphics card.
See /usr/share/doc/xserver-xorg-core/NEWS.Debian.gz:

,----
| xorg-server (2:1.17.3-1) unstable; urgency=medium
| 
|   The Xorg server is no longer setuid root by default.  This change reduces the
|   risk of privilege escalation due to X server bugs, but has some side effects:
| 
|   * it relies on logind and libpam-systemd
|   * it relies on a kernel video driver (so the userspace component doesn't
|     touch the hardware directly)
|   * it needs X to run on the virtual console (VT) it was started from
|   * it changes the location for storing the Xorg log from /var/log/ to
|     ~/.local/share/xorg/
| 
|   On systems where those are not available, the new xserver-xorg-legacy package
|   is needed to allow X to run with elevated privileges.  See the
|   Xwrapper.config(5) manual page for configuration details.
| 
|  -- Julien Cristau <jcristau@debian.org>  Tue, 27 Oct 2015 22:54:11 +0000
`----

In short, you need to install xserver-xorg-legacy.

Cheers,
       Sven

Back to linux.debian.user | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

Matrox G550 - MGA X server fails Oliver Elphick <olly@lfix.co.uk> - 2017-03-22 11:30 +0100
  Re: Matrox G550 - MGA X server fails Felix Miata <mrmazda@earthlink.net> - 2017-03-22 11:50 +0100
  Re: Matrox G550 - MGA X server fails Sven Joachim <svenjoac@gmx.de> - 2017-03-22 21:20 +0100
    Re: Matrox G550 - MGA X server fails Oliver Elphick <olly@lfix.co.uk> - 2017-03-23 10:50 +0100
      Re: Matrox G550 - MGA X server fails Felix Miata <mrmazda@earthlink.net> - 2017-03-23 12:30 +0100
  Re: Matrox G550 - MGA X server fails Felix Miata <mrmazda@earthlink.net> - 2017-03-23 16:20 +0100

csiph-web