Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1603746
| From | Johan Hovold <johan@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] usbtmc: don't return zero on failure path in usbtmc_probe() |
| Date | 2017-03-18 10:10 +0100 |
| Message-ID | <tmix3-3Zh-13@gated-at.bofh.it> (permalink) |
| References | <tma6t-6ie-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sat, Mar 18, 2017 at 02:38:00AM +0300, Alexey Khoroshilov wrote:
> usbtmc_probe() returns zero in case of allocation failures.
>
> The patch fixes that. By the way it rearranges error lables just to improve
> readability of quite complex dependencies in error handling code.
This was in fact fixed earlier this week by commit 2e47c53503eb ("USB:
usbtmc: fix probe error path") in Greg's usb-linus branch.
The current error label is indeed confusingly named, but that can be
addressed by a follow-on clean-up patch. Note that naming error labels
after what they do (e.g. err_remove_capability) is generally preferred.
Thanks,
Johan
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] usbtmc: don't return zero on failure path in usbtmc_probe() Alexey Khoroshilov <khoroshilov@ispras.ru> - 2017-03-18 01:10 +0100 Re: [PATCH] usbtmc: don't return zero on failure path in usbtmc_probe() Johan Hovold <johan@kernel.org> - 2017-03-18 10:10 +0100
csiph-web