Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1601233
| From | Dan Carpenter <dan.carpenter@oracle.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v3 2/8] staging: rtl8192e: Fix coding style |
| Date | 2017-03-15 11:20 +0100 |
| Message-ID | <tleca-6cz-25@gated-at.bofh.it> (permalink) |
| References | <tkc2K-2cL-21@gated-at.bofh.it> <tldSN-5Pm-5@gated-at.bofh.it> <tldSO-5Pm-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, Mar 15, 2017 at 03:21:51PM +0530, sunil.m@techveda.org wrote:
> @@ -1796,7 +1796,7 @@ static short _rtl92e_alloc_rx_ring(struct net_device *dev)
>
> for (rx_queue_idx = 0; rx_queue_idx < MAX_RX_QUEUE; rx_queue_idx++) {
> priv->rx_ring[rx_queue_idx] = pci_zalloc_consistent(priv->pdev,
> - sizeof(*priv->rx_ring[rx_queue_idx]) * priv->rxringcount,
> + sizeof(*priv->rx_ring[rx_queue_idx]) * priv->rxringcount,
> &priv->rx_ring_dma[rx_queue_idx]);
No, don't do that. The original was easier to read. Ignore
checkpatch.pl if it gives you bad advice.
> if (!priv->rx_ring[rx_queue_idx] ||
> (unsigned long)priv->rx_ring[rx_queue_idx] & 0xFF) {
> @@ -2272,7 +2272,8 @@ static int _rtl92e_ioctl(struct net_device *dev, struct ifreq *rq, int cmd)
> int ret = -1;
> struct rtllib_device *ieee = priv->rtllib;
> u32 key[4];
> - const u8 broadcast_addr[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff, 0xff};
> + const u8 broadcast_addr[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff,
> + 0xff};
Just drop this patch... The original is better.
regards,
dan carpenter
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v3 0/8] staging: rtl8192e: Fix coding style, warnings and checks sunil.m@techveda.org - 2017-03-15 11:00 +0100
[PATCH v3 8/8] staging: rtl8192e: Fix blank lines and space after a cast sunil.m@techveda.org - 2017-03-15 11:00 +0100
[PATCH v3 2/8] staging: rtl8192e: Fix coding style sunil.m@techveda.org - 2017-03-15 11:00 +0100
Re: [PATCH v3 2/8] staging: rtl8192e: Fix coding style Dan Carpenter <dan.carpenter@oracle.com> - 2017-03-15 11:20 +0100
Re: [PATCH v3 2/8] staging: rtl8192e: Fix coding style Dan Carpenter <dan.carpenter@oracle.com> - 2017-03-15 11:20 +0100
Re: [PATCH v3 2/8] staging: rtl8192e: Fix coding style Suniel Mahesh <sunil.m@techveda.org> - 2017-03-15 12:20 +0100
Re: [PATCH v3 2/8] staging: rtl8192e: Fix coding style Dan Carpenter <dan.carpenter@oracle.com> - 2017-03-15 12:20 +0100
[PATCH v3 6/8] staging: rtl8192e: Pass a pointer as an argument to sizeof() instead of struct sunil.m@techveda.org - 2017-03-15 11:00 +0100
[PATCH v3 5/8] staging: rtl8192e: Fix unbalanced braces sunil.m@techveda.org - 2017-03-15 11:00 +0100
Re: [PATCH v3 5/8] staging: rtl8192e: Fix unbalanced braces Dan Carpenter <dan.carpenter@oracle.com> - 2017-03-15 11:30 +0100
[PATCH v3 1/8] staging: rtl8192e: Fix comments as per kernel coding style sunil.m@techveda.org - 2017-03-15 11:00 +0100
[PATCH v3 7/8] staging: rtl8192e: Fix issues reported by checkpatch.pl sunil.m@techveda.org - 2017-03-15 11:00 +0100
[PATCH v3 4/8] staging: rtl8192e: Rectify pointer comparisions with NULL sunil.m@techveda.org - 2017-03-15 11:00 +0100
[PATCH v3 3/8] staging: rtl8192e: Remove unnecessary 'out of memory' message sunil.m@techveda.org - 2017-03-15 11:00 +0100
Re: [PATCH v3 3/8] staging: rtl8192e: Remove unnecessary 'out of memory' message Dan Carpenter <dan.carpenter@oracle.com> - 2017-03-15 11:20 +0100
[PATCH v4 3/8] staging: rtl8192e: Remove unnecessary 'out of memory' message sunil.m@techveda.org - 2017-03-15 12:00 +0100
Re: [PATCH v4 3/8] staging: rtl8192e: Remove unnecessary 'out of memory' message Greg KH <gregkh@linuxfoundation.org> - 2017-03-16 03:40 +0100
[PATCH v4 4/6] staging: rtl8192e: Pass a pointer as an argument to sizeof() instead of struct sunil.m@techveda.org - 2017-03-16 23:30 +0100
[PATCH v4 0/6] staging: rtl8192e: Fix coding style, warnings and checks sunil.m@techveda.org - 2017-03-16 23:30 +0100
[PATCH v4 6/6] staging: rtl8192e: Fix blank lines and space after a cast sunil.m@techveda.org - 2017-03-16 23:30 +0100
Re: [PATCH v4 0/6] staging: rtl8192e: Fix coding style, warnings and checks Greg KH <gregkh@linuxfoundation.org> - 2017-03-17 07:20 +0100
[PATCH v5 2/6] staging: rtl8192e: Remove unnecessary 'out of memory' message suniel.spartan@gmail.com - 2017-03-21 10:10 +0100
[PATCH v5 4/6] staging: rtl8192e: Pass a pointer as an argument to sizeof() instead of struct suniel.spartan@gmail.com - 2017-03-21 10:10 +0100
[PATCH v5 0/6] staging: rtl8192e: Fix coding style, warnings and checks suniel.spartan@gmail.com - 2017-03-21 10:10 +0100
[PATCH v5 6/6] staging: rtl8192e: Fix blank lines and space after a cast suniel.spartan@gmail.com - 2017-03-21 10:10 +0100
[PATCH v5 3/6] staging: rtl8192e: Rectify pointer comparisions with NULL suniel.spartan@gmail.com - 2017-03-21 10:10 +0100
[PATCH v5 1/6] staging: rtl8192e: Fix comments as per kernel coding style suniel.spartan@gmail.com - 2017-03-21 10:10 +0100
[PATCH v5 5/6] staging: rtl8192e: Fix issues reported by checkpatch.pl suniel.spartan@gmail.com - 2017-03-21 10:10 +0100
csiph-web