Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1667791
| From | Joerg Roedel <joro@8bytes.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 0/7] iommu/amd: Disable previously enabled IOMMUs at boot |
| Date | 2017-06-16 16:20 +0200 |
| Message-ID | <tT0gp-1a4-3@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
Hi, here is a patch-set refactoring the AMD IOMMU init code a bit to make sure the IOMMUs get disabled at boot, even when amd_iommu=off is specified on the kernel command line. The patch-set is tested with various combinations of kernel command-line parameters and with kexec. It applies to the x86/amd branch of the iommu-tree. Regards, Joerg Joerg Roedel (7): iommu/amd: Disable IOMMUs at boot if they are enabled iommu/amd: Rename free_on_init_error() iommu/amd: Add new init-state IOMMU_CMDLINE_DISABLED iommu/amd: Check for error states first in iommu_go_to_state() iommu/amd: Set global pointers to NULL after freeing them iommu/amd: Free IOMMU resources when disabled on command line iommu/amd: Remove amd_iommu_disabled check from amd_iommu_detect() drivers/iommu/amd_iommu_init.c | 33 ++++++++++++++++++++++++--------- 1 file changed, 24 insertions(+), 9 deletions(-) -- 2.7.4
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 0/7] iommu/amd: Disable previously enabled IOMMUs at boot Joerg Roedel <joro@8bytes.org> - 2017-06-16 16:20 +0200 [PATCH 6/7] iommu/amd: Free IOMMU resources when disabled on command line Joerg Roedel <joro@8bytes.org> - 2017-06-16 16:20 +0200
csiph-web