Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1656451

Re: [PATCH V1 02/15] spmi: pmic-arb: rename spmi_pmic_arb_dev to spmi_pmic_arb

From Stephen Boyd <sboyd@codeaurora.org>
Newsgroups linux.kernel
Subject Re: [PATCH V1 02/15] spmi: pmic-arb: rename spmi_pmic_arb_dev to spmi_pmic_arb
Date 2017-06-02 20:30 +0200
Message-ID <tNZuF-4Jd-5@gated-at.bofh.it> (permalink)
References <tMOKZ-7oW-9@gated-at.bofh.it> <tMOL0-7oW-21@gated-at.bofh.it> <tMZZM-5Xg-9@gated-at.bofh.it> <tNAZj-4Q6-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 06/01, kgunda@codeaurora.org wrote:
> >>@@ -209,23 +210,24 @@ static void pa_read_data(struct
> >>spmi_pmic_arb_dev *dev, u8 *buf, u32 reg, u8 bc)
> >>  * @buf:	buffer to write. length must be bc + 1.
> >>  */
> >> static void
> >>-pa_write_data(struct spmi_pmic_arb_dev *dev, const u8 *buf, u32
> >>reg, u8 bc)
> >>+pa_write_data(struct spmi_pmic_arb *pa, const u8 *buf, u32 reg,
> >>u8 bc)
> >> {
> >> 	u32 data = 0;
> >>+
> >> 	memcpy(&data, buf, (bc & 3) + 1);
> >>-	__raw_writel(data, dev->wr_base + reg);
> >>+	pmic_arb_base_write(pa, reg, data);
> >
> >This is an unrelated change. Not sure what's going on with this
> >diff but we most likely want to keep the __raw_writel() here. See
> >how renames introduce bugs and why we don't value them?
> >
> Actually pmic_arb_base_write has the writel_relaxed inside it.
> that's why we removed the __raw_writel to use the common function.
> Anyways, we drop the renaming patch from this patch series.

__raw_writel() is there on purpose because we're reading bytes at
a time and the CPU could be big-endian or little-endian.
readl_relaxed() would do a byte swap which we don't want.

-- 
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
a Linux Foundation Collaborative Project

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH V1 02/15] spmi: pmic-arb: rename spmi_pmic_arb_dev to spmi_pmic_arb Kiran Gunda <kgunda@codeaurora.org> - 2017-05-30 14:50 +0200
  Re: [PATCH V1 02/15] spmi: pmic-arb: rename spmi_pmic_arb_dev to  spmi_pmic_arb Stephen Boyd <sboyd@codeaurora.org> - 2017-05-31 02:50 +0200
    Re: [PATCH V1 02/15] spmi: pmic-arb: rename spmi_pmic_arb_dev to  spmi_pmic_arb kgunda@codeaurora.org - 2017-06-01 18:20 +0200
      Re: [PATCH V1 02/15] spmi: pmic-arb: rename spmi_pmic_arb_dev to  spmi_pmic_arb Stephen Boyd <sboyd@codeaurora.org> - 2017-06-02 20:30 +0200
        Re: [PATCH V1 02/15] spmi: pmic-arb: rename spmi_pmic_arb_dev to  spmi_pmic_arb kgunda@codeaurora.org - 2017-06-05 08:30 +0200

csiph-web