Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1634258
| From | Richard Genoud <richard.genoud@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2] tty/serial: atmel: use offset_in_page() macro |
| Date | 2017-05-02 10:50 +0200 |
| Message-ID | <tCBFo-4eG-5@gated-at.bofh.it> (permalink) |
| References | <tBpwC-7AB-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 29/04/2017 03:39, Geliang Tang wrote: > Use offset_in_page() macro instead of open-coding. > > Signed-off-by: Geliang Tang <geliangtang@gmail.com> Acked-by: Richard Genoud <richard.genoud@gmail.com> > --- > Changes in v2: > - include mm.h > --- > drivers/tty/serial/atmel_serial.c | 5 +++-- > 1 file changed, 3 insertions(+), 2 deletions(-) > > diff --git a/drivers/tty/serial/atmel_serial.c b/drivers/tty/serial/atmel_serial.c > index c355ac9..d25f044 100644 > --- a/drivers/tty/serial/atmel_serial.c > +++ b/drivers/tty/serial/atmel_serial.c > @@ -46,6 +46,7 @@ > #include <linux/err.h> > #include <linux/irq.h> > #include <linux/suspend.h> > +#include <linux/mm.h> > > #include <asm/io.h> > #include <asm/ioctls.h> > @@ -959,7 +960,7 @@ static int atmel_prepare_tx_dma(struct uart_port *port) > sg_set_page(&atmel_port->sg_tx, > virt_to_page(port->state->xmit.buf), > UART_XMIT_SIZE, > - (unsigned long)port->state->xmit.buf & ~PAGE_MASK); > + offset_in_page(port->state->xmit.buf)); > nent = dma_map_sg(port->dev, > &atmel_port->sg_tx, > 1, > @@ -1141,7 +1142,7 @@ static int atmel_prepare_rx_dma(struct uart_port *port) > sg_set_page(&atmel_port->sg_rx, > virt_to_page(ring->buf), > sizeof(struct atmel_uart_char) * ATMEL_SERIAL_RINGSIZE, > - (unsigned long)ring->buf & ~PAGE_MASK); > + offset_in_page(ring->buf)); > nent = dma_map_sg(port->dev, > &atmel_port->sg_rx, > 1, > Thanks !
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v2] tty/serial: atmel: use offset_in_page() macro Geliang Tang <geliangtang@gmail.com> - 2017-04-29 03:40 +0200 Re: [PATCH v2] tty/serial: atmel: use offset_in_page() macro Richard Genoud <richard.genoud@gmail.com> - 2017-05-02 10:50 +0200
csiph-web