Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1568525
| From | Mathieu Poirier <mathieu.poirier@linaro.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/3] perf, pt, coresight: Clean up address filter structure |
| Date | 2017-01-27 18:20 +0100 |
| Message-ID | <t4ilQ-6Xe-25@gated-at.bofh.it> (permalink) |
| References | <t3OQN-5FW-15@gated-at.bofh.it> <t3OQO-5FW-35@gated-at.bofh.it> <t3WY2-2hB-9@gated-at.bofh.it> <t4dFw-42B-29@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 27 January 2017 at 05:12, Alexander Shishkin <alexander.shishkin@linux.intel.com> wrote: > Mathieu Poirier <mathieu.poirier@linaro.org> writes: > >> Hi Alex, > > Hi Mathieu, > >> This changes the behavior we used to have. Now a range filter with a size of 0 >> will be treated as start filter rather than an error. See below on a possible >> way of fixing this. > > Not really. Currently we have 2 drivers using this and both reject the > type=range&&size==0 filters with either -EOPNOTSUPP or -EINVAL. With > this change, PT will still reject it as it doesn't support single > address triggers, but Coresight will treat it as if it was a single > address filter. Hence my statement about a change in behaviour. > Which makes sense, because that's what a range of size > zero is. Note, that a range that covers one instruction has to be at > least size==1 (and I'm guessing size==4 for Coresight, but I may be > wrong). > > So yes, this does change the existing behavior, but in doing so it > removes the ambiguity of zero sized ranges. Specifying a size of zero with a range filter is wrong and as such should be treated as an error, which is what the current code is doing. If people want a start filter they can use the syntax required for that. In my opinion treating a range filter with a size zero as a start filter is adding intelligence to the machine, something that should probably be avoided. > >> if (filter->action == PERF_ADDR_FILTER_ACTION_RANGE) > > But "range" is not an action, it's a type of a filter. It determines the > condition that triggers an action. An action, however, is what we do > when the condition comes true. Then filter->action could be renamed 'type'. In the end filters on PT are range filters, the same way they are on CS. But changing the naming convention is a matter of personal opinion - I am fine with what we currently have. On the flip side reordering the fields in the 'if_tokens' match table would allow to set the filters properly in perf_event_parse_addr_filter(), keep the current behaviour intact and get rid of filter->range. Thanks, Mathieu > > Regards, > -- > Alex
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 0/3] perf: Updates for address filters Alexander Shishkin <alexander.shishkin@linux.intel.com> - 2017-01-26 10:50 +0100
[PATCH 3/3] perf: Allow kernel filters on cpu events Alexander Shishkin <alexander.shishkin@linux.intel.com> - 2017-01-26 10:50 +0100
Re: [PATCH 3/3] perf: Allow kernel filters on cpu events Mathieu Poirier <mathieu.poirier@linaro.org> - 2017-01-26 22:50 +0100
Re: [PATCH 3/3] perf: Allow kernel filters on cpu events Alexander Shishkin <alexander.shishkin@linux.intel.com> - 2017-01-27 13:50 +0100
Re: [PATCH 3/3] perf: Allow kernel filters on cpu events Mathieu Poirier <mathieu.poirier@linaro.org> - 2017-01-27 22:50 +0100
[PATCH 1/3] perf, pt, coresight: Clean up address filter structure Alexander Shishkin <alexander.shishkin@linux.intel.com> - 2017-01-26 10:50 +0100
Re: [PATCH 1/3] perf, pt, coresight: Clean up address filter structure Mathieu Poirier <mathieu.poirier@linaro.org> - 2017-01-26 19:30 +0100
Re: [PATCH 1/3] perf, pt, coresight: Clean up address filter structure Alexander Shishkin <alexander.shishkin@linux.intel.com> - 2017-01-27 13:20 +0100
Re: [PATCH 1/3] perf, pt, coresight: Clean up address filter structure Mathieu Poirier <mathieu.poirier@linaro.org> - 2017-01-27 18:20 +0100
csiph-web