Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1566514
| From | Laura Abbott <labbott@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA |
| Date | 2017-01-25 12:30 +0100 |
| Message-ID | <t3tW2-16w-21@gated-at.bofh.it> (permalink) |
| References | <t19RM-3iT-5@gated-at.bofh.it> <t19RM-3iT-3@gated-at.bofh.it> <t1iBJ-uk-37@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 01/19/2017 11:56 AM, Mark Rutland wrote: > Hi Laura, > > On Wed, Jan 18, 2017 at 05:29:05PM -0800, Laura Abbott wrote: >> >> Despite the word 'debug' in CONFIG_DEBUG_RODATA, this kernel option >> provides key security features that are to be expected on a modern >> system. Change the name to CONFIG_HARDENED_PAGE_MAPPINGS which more >> accurately describes what this option is intended to do. > > This generally sounds good. Thanks for attacking this! > > On the bikeshedding front, *maybe* it would be nice to mention > permissions in the name, something like STRICT_KERNEL_RWX. That might > also prevent the reading of 'hardened' as 'optional overhead'. > > That said, the proposed name is fine by me -- I'm happy so long as > 'DEBUG' goes. > (Apologies for the delay, my SMTP was set up incorrectly so my messages didn't actually get sent out) I like that better since it's describing specifically what the config should be setting as opposed to something more vague. That might fit better with what Pavel was suggesting as well. Thanks, Laura
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Laura Abbott <labbott@redhat.com> - 2017-01-19 02:40 +0100
Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Pavel Machek <pavel@ucw.cz> - 2017-01-19 09:00 +0100
Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Laura Abbott <labbott@redhat.com> - 2017-01-25 12:30 +0100
Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Pavel Machek <pavel@ucw.cz> - 2017-01-25 15:00 +0100
Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Mark Rutland <mark.rutland@arm.com> - 2017-01-19 12:00 +0100
Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Heiko Carstens <heiko.carstens@de.ibm.com> - 2017-01-19 12:40 +0100
Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Helge Deller <deller@gmx.de> - 2017-01-19 22:20 +0100
Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Laura Abbott <labbott@redhat.com> - 2017-01-25 12:40 +0100
Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Kees Cook <keescook@chromium.org> - 2017-01-19 23:10 +0100
Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Laura Abbott <labbott@redhat.com> - 2017-01-25 12:30 +0100
Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Kees Cook <keescook@chromium.org> - 2017-01-19 23:10 +0100
csiph-web